summaryrefslogtreecommitdiffstats
path: root/meta/recipes-multimedia/x264/x264_git.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-multimedia/x264/x264_git.bb')
-rw-r--r--meta/recipes-multimedia/x264/x264_git.bb52
1 files changed, 52 insertions, 0 deletions
diff --git a/meta/recipes-multimedia/x264/x264_git.bb b/meta/recipes-multimedia/x264/x264_git.bb
new file mode 100644
index 0000000000..295818ae98
--- /dev/null
+++ b/meta/recipes-multimedia/x264/x264_git.bb
@@ -0,0 +1,52 @@
1SUMMARY = "A free software library and application for encoding video streams into the H.264/MPEG-4 AVC format"
2HOMEPAGE = "http://www.videolan.org/developers/x264.html"
3
4LICENSE = "GPLv2"
5LICENSE_FLAGS = "commercial"
6LIC_FILES_CHKSUM = "file://COPYING;md5=94d55d512a9ba36caa9b7df079bae19f"
7
8DEPENDS = "yasm-native"
9
10SRC_URI = "git://git.videolan.org/x264.git \
11 file://don-t-default-to-cortex-a9-with-neon.patch \
12 "
13
14SRCREV = "585324fee380109acd9986388f857f413a60b896"
15
16PV = "r2265+git${SRCPV}"
17
18S = "${WORKDIR}/git"
19
20inherit lib_package pkgconfig
21
22X264_DISABLE_ASM = ""
23X264_DISABLE_ASM_armv4 = "--disable-asm"
24X264_DISABLE_ASM_armv5 = "--disable-asm"
25
26EXTRA_OECONF = '--prefix=${prefix} \
27 --host=${HOST_SYS} \
28 --cross-prefix=${TARGET_PREFIX} \
29 --sysroot=${STAGING_DIR_TARGET} \
30 --enable-shared \
31 --enable-static \
32 --disable-lavf \
33 --disable-swscale \
34 --enable-pic \
35 ${X264_DISABLE_ASM} \
36 '
37
38do_configure() {
39 ./configure ${EXTRA_OECONF}
40}
41
42# Get rid of -e
43EXTRA_OEMAKE = ""
44AS = "${TARGET_PREFIX}gcc"
45
46do_install() {
47 oe_runmake install DESTDIR=${D}
48}
49
50# PIC can't be enabled for 32-bit x86
51INSANE_SKIP_${PN}_append_i586 = " textrel"
52