summaryrefslogtreecommitdiffstats
path: root/meta/recipes-multimedia/x264/x264_git.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-multimedia/x264/x264_git.bb')
-rw-r--r--meta/recipes-multimedia/x264/x264_git.bb55
1 files changed, 55 insertions, 0 deletions
diff --git a/meta/recipes-multimedia/x264/x264_git.bb b/meta/recipes-multimedia/x264/x264_git.bb
new file mode 100644
index 0000000000..0e856b3ba1
--- /dev/null
+++ b/meta/recipes-multimedia/x264/x264_git.bb
@@ -0,0 +1,55 @@
1SUMMARY = "H.264/MPEG-4 AVC video encoder"
2DESCRIPTION = "A free software library and application for encoding video streams into the H.264/MPEG-4 AVC format."
3HOMEPAGE = "http://www.videolan.org/developers/x264.html"
4
5LICENSE = "GPLv2"
6LICENSE_FLAGS = "commercial"
7LIC_FILES_CHKSUM = "file://COPYING;md5=94d55d512a9ba36caa9b7df079bae19f"
8
9DEPENDS = "yasm-native"
10
11SRC_URI = "git://git.videolan.org/x264.git \
12 file://don-t-default-to-cortex-a9-with-neon.patch \
13 "
14
15SRCREV = "ffc3ad4945da69f3caa2b40e4eed715a9a8d9526"
16
17PV = "r2265+git${SRCPV}"
18
19S = "${WORKDIR}/git"
20
21inherit lib_package pkgconfig perlnative
22
23X264_DISABLE_ASM = ""
24X264_DISABLE_ASM_armv4 = "--disable-asm"
25X264_DISABLE_ASM_armv5 = "--disable-asm"
26X264_DISABLE_ASM_powerpc = "${@bb.utils.contains("TUNE_FEATURES", "spe", "--disable-asm", "", d)}"
27
28EXTRA_OECONF = '--prefix=${prefix} \
29 --host=${HOST_SYS} \
30 --libdir=${libdir} \
31 --cross-prefix=${TARGET_PREFIX} \
32 --sysroot=${STAGING_DIR_TARGET} \
33 --enable-shared \
34 --enable-static \
35 --disable-lavf \
36 --disable-swscale \
37 --enable-pic \
38 ${X264_DISABLE_ASM} \
39 '
40
41do_configure() {
42 ./configure ${EXTRA_OECONF}
43}
44
45# Get rid of -e
46EXTRA_OEMAKE = ""
47AS = "${TARGET_PREFIX}gcc"
48
49do_install() {
50 oe_runmake install DESTDIR=${D}
51}
52
53# PIC can't be enabled for 32-bit x86
54INSANE_SKIP_${PN}_append_i586 = " textrel"
55