summaryrefslogtreecommitdiffstats
path: root/meta/recipes-multimedia/webp/libwebp_1.0.3.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-multimedia/webp/libwebp_1.0.3.bb')
-rw-r--r--meta/recipes-multimedia/webp/libwebp_1.0.3.bb53
1 files changed, 53 insertions, 0 deletions
diff --git a/meta/recipes-multimedia/webp/libwebp_1.0.3.bb b/meta/recipes-multimedia/webp/libwebp_1.0.3.bb
new file mode 100644
index 0000000000..01fc02d23b
--- /dev/null
+++ b/meta/recipes-multimedia/webp/libwebp_1.0.3.bb
@@ -0,0 +1,53 @@
1SUMMARY = "WebP is an image format designed for the Web"
2DESCRIPTION = "WebP is a method of lossy and lossless compression that can be \
3 used on a large variety of photographic, translucent and \
4 graphical images found on the web. The degree of lossy \
5 compression is adjustable so a user can choose the trade-off \
6 between file size and image quality. WebP typically achieves \
7 an average of 30% more compression than JPEG and JPEG 2000, \
8 without loss of image quality."
9HOMEPAGE = "https://developers.google.com/speed/webp/"
10SECTION = "libs"
11
12LICENSE = "BSD"
13LIC_FILES_CHKSUM = "file://COPYING;md5=6e8dee932c26f2dab503abf70c96d8bb \
14 file://PATENTS;md5=c6926d0cb07d296f886ab6e0cc5a85b7"
15
16SRC_URI = "http://downloads.webmproject.org/releases/webp/${BP}.tar.gz"
17SRC_URI[md5sum] = "906ad85daaaa2eac97c8aa2dec9e8b77"
18SRC_URI[sha256sum] = "e20a07865c8697bba00aebccc6f54912d6bc333bb4d604e6b07491c1a226b34f"
19
20UPSTREAM_CHECK_URI = "http://downloads.webmproject.org/releases/webp/index.html"
21
22EXTRA_OECONF = " \
23 --disable-wic \
24 --enable-libwebpmux \
25 --enable-libwebpdemux \
26 --enable-threading \
27"
28# Do not trust configure to determine if neon is available.
29#
30EXTRA_OECONF_append_arm = " \
31 ${@bb.utils.contains("TUNE_FEATURES","neon","--enable-neon","--disable-neon",d)} \
32"
33
34inherit autotools lib_package
35
36PACKAGECONFIG ??= ""
37
38# libwebpdecoder is a subset of libwebp, don't build it unless requested
39PACKAGECONFIG[decoder] = "--enable-libwebpdecoder,--disable-libwebpdecoder"
40
41# Apply for examples programs: cwebp and dwebp
42PACKAGECONFIG[gif] = "--enable-gif,--disable-gif,giflib"
43PACKAGECONFIG[jpeg] = "--enable-jpeg,--disable-jpeg,jpeg"
44PACKAGECONFIG[png] = "--enable-png,--disable-png,,libpng"
45PACKAGECONFIG[tiff] = "--enable-tiff,--disable-tiff,tiff"
46
47# Apply only for example program vwebp
48PACKAGECONFIG[gl] = "--enable-gl,--disable-gl,mesa-glut"
49
50PACKAGES =+ "${PN}-gif2webp"
51
52DESCRIPTION_${PN}-gif2webp = "Simple tool to convert animated GIFs to WebP"
53FILES_${PN}-gif2webp = "${bindir}/gif2webp"