summaryrefslogtreecommitdiffstats
path: root/meta/recipes-multimedia/webp/libwebp_0.6.0.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-multimedia/webp/libwebp_0.6.0.bb')
-rw-r--r--meta/recipes-multimedia/webp/libwebp_0.6.0.bb54
1 files changed, 54 insertions, 0 deletions
diff --git a/meta/recipes-multimedia/webp/libwebp_0.6.0.bb b/meta/recipes-multimedia/webp/libwebp_0.6.0.bb
new file mode 100644
index 0000000000..bc565e9019
--- /dev/null
+++ b/meta/recipes-multimedia/webp/libwebp_0.6.0.bb
@@ -0,0 +1,54 @@
1SUMMARY = "WebP is an image format designed for the Web"
2DESCRIPTION = "WebP is a method of lossy and lossless compression that can be \
3 used on a large variety of photographic, translucent and \
4 graphical images found on the web. The degree of lossy \
5 compression is adjustable so a user can choose the trade-off \
6 between file size and image quality. WebP typically achieves \
7 an average of 30% more compression than JPEG and JPEG 2000, \
8 without loss of image quality."
9HOMEPAGE = "https://developers.google.com/speed/webp/"
10SECTION = "libs"
11
12LICENSE = "BSD"
13LIC_FILES_CHKSUM = "file://COPYING;md5=6e8dee932c26f2dab503abf70c96d8bb \
14 file://PATENTS;md5=c6926d0cb07d296f886ab6e0cc5a85b7"
15
16SRC_URI = "http://downloads.webmproject.org/releases/webp/${BP}.tar.gz"
17SRC_URI[md5sum] = "19a6e926ab1721268df03161b84bb4a0"
18SRC_URI[sha256sum] = "c928119229d4f8f35e20113ffb61f281eda267634a8dc2285af4b0ee27cf2b40"
19
20UPSTREAM_CHECK_URI = "http://downloads.webmproject.org/releases/webp/index.html"
21
22EXTRA_OECONF = " \
23 --disable-experimental \
24 --disable-wic \
25 --enable-libwebpmux \
26 --enable-libwebpdemux \
27 --enable-threading \
28"
29# Do not trust configure to determine if neon is available.
30#
31EXTRA_OECONF_append_arm = " \
32 ${@bb.utils.contains("TUNE_FEATURES","neon","--enable-neon","--disable-neon",d)} \
33"
34
35inherit autotools lib_package
36
37PACKAGECONFIG ??= ""
38
39# libwebpdecoder is a subset of libwebp, don't build it unless requested
40PACKAGECONFIG[decoder] = "--enable-libwebpdecoder,--disable-libwebpdecoder"
41
42# Apply for examples programs: cwebp and dwebp
43PACKAGECONFIG[gif] = "--enable-gif,--disable-gif,giflib"
44PACKAGECONFIG[jpeg] = "--enable-jpeg,--disable-jpeg,jpeg"
45PACKAGECONFIG[png] = "--enable-png,--disable-png,,libpng"
46PACKAGECONFIG[tiff] = "--enable-tiff,--disable-tiff,tiff"
47
48# Apply only for example program vwebp
49PACKAGECONFIG[gl] = "--enable-gl,--disable-gl,mesa-glut"
50
51PACKAGES =+ "${PN}-gif2webp"
52
53DESCRIPTION_${PN}-gif2webp = "Simple tool to convert animated GIFs to WebP"
54FILES_${PN}-gif2webp = "${bindir}/gif2webp"