diff options
Diffstat (limited to 'meta/recipes-multimedia/mpg123/mpg123_1.25.7.bb')
-rw-r--r-- | meta/recipes-multimedia/mpg123/mpg123_1.25.7.bb | 51 |
1 files changed, 51 insertions, 0 deletions
diff --git a/meta/recipes-multimedia/mpg123/mpg123_1.25.7.bb b/meta/recipes-multimedia/mpg123/mpg123_1.25.7.bb new file mode 100644 index 0000000000..1d2b875d18 --- /dev/null +++ b/meta/recipes-multimedia/mpg123/mpg123_1.25.7.bb | |||
@@ -0,0 +1,51 @@ | |||
1 | SUMMARY = "Audio decoder for MPEG-1 Layer 1/2/3" | ||
2 | DESCRIPTION = "The core of mpg123 is an MPEG-1 Layer 1/2/3 decoding library, which can be used by other programs. \ | ||
3 | mpg123 also comes with a command-line tool which can playback using ALSA, PulseAudio, OSS, and several other APIs, \ | ||
4 | and also can write the decoded audio to WAV." | ||
5 | HOMEPAGE = "http://mpg123.de/" | ||
6 | BUGTRACKER = "http://sourceforge.net/p/mpg123/bugs/" | ||
7 | SECTION = "multimedia" | ||
8 | |||
9 | LICENSE = "LGPLv2.1" | ||
10 | LICENSE_FLAGS = "commercial" | ||
11 | LIC_FILES_CHKSUM = "file://COPYING;md5=1e86753638d3cf2512528b99079bc4f3" | ||
12 | |||
13 | SRC_URI = "https://www.mpg123.de/download/${BP}.tar.bz2" | ||
14 | SRC_URI[md5sum] = "710f2d8689b24e86376bd64a05d7888b" | ||
15 | SRC_URI[sha256sum] = "31b15ebcf26111b874732e07c8e60de5053ee555eea15fb70c657a4f9f0344f3" | ||
16 | |||
17 | inherit autotools pkgconfig | ||
18 | |||
19 | # The options should be mutually exclusive for configuration script. | ||
20 | # If both alsa and pulseaudio are specified (as in the default distro features) | ||
21 | # pulseaudio takes precedence. | ||
22 | PACKAGECONFIG_ALSA = "${@bb.utils.filter('DISTRO_FEATURES', 'alsa', d)}" | ||
23 | PACKAGECONFIG ??= "${@bb.utils.contains('DISTRO_FEATURES', 'pulseaudio', 'pulseaudio', '${PACKAGECONFIG_ALSA}', d)}" | ||
24 | |||
25 | PACKAGECONFIG[alsa] = "--with-default-audio=alsa,,alsa-lib" | ||
26 | PACKAGECONFIG[esd] = ",,esound" | ||
27 | PACKAGECONFIG[jack] = ",,jack" | ||
28 | PACKAGECONFIG[openal] = ",,openal-soft" | ||
29 | PACKAGECONFIG[portaudio] = ",,portaudio-v19" | ||
30 | PACKAGECONFIG[pulseaudio] = "--with-default-audio=pulse,,pulseaudio" | ||
31 | PACKAGECONFIG[sdl] = ",,libsdl" | ||
32 | |||
33 | # Following are possible sound output modules: | ||
34 | # alsa arts coreaudio dummy esd jack nas openal os2 oss portaudio pulse sdl sndio sun tinyalsa win32 win32_wasapi | ||
35 | AUDIOMODS += "${@bb.utils.filter('PACKAGECONFIG', 'alsa esd jack openal portaudio sdl', d)}" | ||
36 | AUDIOMODS += "${@bb.utils.contains('PACKAGECONFIG', 'pulseaudio', 'pulse', '', d)}" | ||
37 | |||
38 | EXTRA_OECONF = " \ | ||
39 | --enable-shared \ | ||
40 | --with-audio='${AUDIOMODS}' \ | ||
41 | ${@bb.utils.contains('TUNE_FEATURES', 'neon', '--with-cpu=neon', '', d)} \ | ||
42 | ${@bb.utils.contains('TUNE_FEATURES', 'altivec', '--with-cpu=altivec', '', d)} \ | ||
43 | " | ||
44 | # Fails to build with thumb-1 (qemuarm) | ||
45 | #| {standard input}: Assembler messages: | ||
46 | #| {standard input}:47: Error: selected processor does not support Thumb mode `smull r5,r6,r7,r4' | ||
47 | #| {standard input}:48: Error: shifts in CMP/MOV instructions are only supported in unified syntax -- `mov r5,r5,lsr#24' | ||
48 | #... | ||
49 | #| make[3]: *** [equalizer.lo] Error 1 | ||
50 | ARM_INSTRUCTION_SET_armv4 = "arm" | ||
51 | ARM_INSTRUCTION_SET_armv5 = "arm" | ||