summaryrefslogtreecommitdiffstats
path: root/meta/recipes-multimedia/mpg123/mpg123_1.25.0.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-multimedia/mpg123/mpg123_1.25.0.bb')
-rw-r--r--meta/recipes-multimedia/mpg123/mpg123_1.25.0.bb51
1 files changed, 51 insertions, 0 deletions
diff --git a/meta/recipes-multimedia/mpg123/mpg123_1.25.0.bb b/meta/recipes-multimedia/mpg123/mpg123_1.25.0.bb
new file mode 100644
index 0000000000..f86098ce20
--- /dev/null
+++ b/meta/recipes-multimedia/mpg123/mpg123_1.25.0.bb
@@ -0,0 +1,51 @@
1SUMMARY = "Audio decoder for MPEG-1 Layer 1/2/3"
2DESCRIPTION = "The core of mpg123 is an MPEG-1 Layer 1/2/3 decoding library, which can be used by other programs. \
3mpg123 also comes with a command-line tool which can playback using ALSA, PulseAudio, OSS, and several other APIs, \
4and also can write the decoded audio to WAV."
5HOMEPAGE = "http://mpg123.de/"
6BUGTRACKER = "http://sourceforge.net/p/mpg123/bugs/"
7SECTION = "multimedia"
8
9LICENSE = "LGPLv2.1"
10LICENSE_FLAGS = "commercial"
11LIC_FILES_CHKSUM = "file://COPYING;md5=1e86753638d3cf2512528b99079bc4f3"
12
13SRC_URI = "https://www.mpg123.de/download/${BP}.tar.bz2"
14SRC_URI[md5sum] = "2ffbe29c99130215b0ee7d1b11c0ea4b"
15SRC_URI[sha256sum] = "552e3e1db045e00f474252917007795ac295863fc8b13891859b3382d2f24e48"
16
17inherit autotools pkgconfig
18
19# The options should be mutually exclusive for configuration script.
20# If both alsa and pulseaudio are specified (as in the default distro features)
21# pulseaudio takes precedence.
22PACKAGECONFIG_ALSA = "${@bb.utils.filter('DISTRO_FEATURES', 'alsa', d)}"
23PACKAGECONFIG ??= "${@bb.utils.contains('DISTRO_FEATURES', 'pulseaudio', 'pulseaudio', '${PACKAGECONFIG_ALSA}', d)}"
24
25PACKAGECONFIG[alsa] = "--with-default-audio=alsa,,alsa-lib"
26PACKAGECONFIG[esd] = ",,esound"
27PACKAGECONFIG[jack] = ",,jack"
28PACKAGECONFIG[openal] = ",,openal-soft"
29PACKAGECONFIG[portaudio] = ",,portaudio-v19"
30PACKAGECONFIG[pulseaudio] = "--with-default-audio=pulse,,pulseaudio"
31PACKAGECONFIG[sdl] = ",,libsdl"
32
33# Following are possible sound output modules:
34# alsa arts coreaudio dummy esd jack nas openal os2 oss portaudio pulse sdl sndio sun tinyalsa win32 win32_wasapi
35AUDIOMODS += "${@bb.utils.filter('PACKAGECONFIG', 'alsa esd jack openal portaudio sdl', d)}"
36AUDIOMODS += "${@bb.utils.contains('PACKAGECONFIG', 'pulseaudio', 'pulse', '', d)}"
37
38EXTRA_OECONF = " \
39 --enable-shared \
40 --with-audio='${AUDIOMODS}' \
41 ${@bb.utils.contains('TUNE_FEATURES', 'neon', '--with-cpu=neon', '', d)} \
42 ${@bb.utils.contains('TUNE_FEATURES', 'altivec', '--with-cpu=altivec', '', d)} \
43"
44# Fails to build with thumb-1 (qemuarm)
45#| {standard input}: Assembler messages:
46#| {standard input}:47: Error: selected processor does not support Thumb mode `smull r5,r6,r7,r4'
47#| {standard input}:48: Error: shifts in CMP/MOV instructions are only supported in unified syntax -- `mov r5,r5,lsr#24'
48#...
49#| make[3]: *** [equalizer.lo] Error 1
50ARM_INSTRUCTION_SET_armv4 = "arm"
51ARM_INSTRUCTION_SET_armv5 = "arm"