diff options
Diffstat (limited to 'meta/recipes-multimedia/mpg123/mpg123_1.23.8.bb')
-rw-r--r-- | meta/recipes-multimedia/mpg123/mpg123_1.23.8.bb | 63 |
1 files changed, 63 insertions, 0 deletions
diff --git a/meta/recipes-multimedia/mpg123/mpg123_1.23.8.bb b/meta/recipes-multimedia/mpg123/mpg123_1.23.8.bb new file mode 100644 index 0000000000..f4c5c7cce8 --- /dev/null +++ b/meta/recipes-multimedia/mpg123/mpg123_1.23.8.bb | |||
@@ -0,0 +1,63 @@ | |||
1 | SUMMARY = "Audio decoder for MPEG-1 Layer 1/2/3" | ||
2 | DESCRIPTION = "The core of mpg123 is an MPEG-1 Layer 1/2/3 decoding library, which can be used by other programs. \ | ||
3 | mpg123 also comes with a command-line tool which can playback using ALSA, PulseAudio, OSS, and several other APIs, \ | ||
4 | and also can write the decoded audio to WAV." | ||
5 | HOMEPAGE = "http://mpg123.de/" | ||
6 | BUGTRACKER = "http://sourceforge.net/p/mpg123/bugs/" | ||
7 | SECTION = "multimedia" | ||
8 | |||
9 | LICENSE = "LGPLv2.1" | ||
10 | LICENSE_FLAGS = "commercial" | ||
11 | LIC_FILES_CHKSUM = "file://COPYING;md5=1e86753638d3cf2512528b99079bc4f3" | ||
12 | |||
13 | SRC_URI = "https://www.mpg123.de/download/${BP}.tar.bz2" | ||
14 | |||
15 | SRC_URI[md5sum] = "4dde045123a2ad1e385a0a82c0ef9268" | ||
16 | SRC_URI[sha256sum] = "de2303c8ecb65593e39815c0a2f2f2d91f708c43b85a55fdd1934c82e677cf8e" | ||
17 | |||
18 | inherit autotools pkgconfig | ||
19 | |||
20 | # The options should be mutually exclusive for configuration script. | ||
21 | # If both alsa and pulseaudio are specified (as in the default distro features) | ||
22 | # pulseaudio takes precedence. | ||
23 | PACKAGECONFIG_ALSA = "${@bb.utils.contains('DISTRO_FEATURES', 'alsa', 'alsa', '', d)}" | ||
24 | PACKAGECONFIG ??= "${@bb.utils.contains('DISTRO_FEATURES', 'pulseaudio', 'pulseaudio', '${PACKAGECONFIG_ALSA}', d)}" | ||
25 | |||
26 | PACKAGECONFIG[alsa] = "--with-default-audio=alsa,,alsa-lib" | ||
27 | PACKAGECONFIG[esd] = ",,esound" | ||
28 | PACKAGECONFIG[jack] = ",,jack" | ||
29 | PACKAGECONFIG[openal] = ",,openal-soft" | ||
30 | PACKAGECONFIG[portaudio] = ",,portaudio-v19" | ||
31 | PACKAGECONFIG[pulseaudio] = "--with-default-audio=pulse,,pulseaudio" | ||
32 | PACKAGECONFIG[sdl] = ",,libsdl" | ||
33 | |||
34 | # Following are possible sound output modules: | ||
35 | # alsa arts coreaudio dummy esd jack nas openal os2 oss portaudio pulse sdl sndio sun tinyalsa win32 win32_wasapi | ||
36 | AUDIOMODS += "${@bb.utils.contains('PACKAGECONFIG', 'alsa', 'alsa', '', d)}" | ||
37 | AUDIOMODS += "${@bb.utils.contains('PACKAGECONFIG', 'esd', 'esd', '', d)}" | ||
38 | AUDIOMODS += "${@bb.utils.contains('PACKAGECONFIG', 'jack', 'jack', '', d)}" | ||
39 | AUDIOMODS += "${@bb.utils.contains('PACKAGECONFIG', 'openal', 'openal', '', d)}" | ||
40 | AUDIOMODS += "${@bb.utils.contains('PACKAGECONFIG', 'portaudio', 'portaudio', '', d)}" | ||
41 | AUDIOMODS += "${@bb.utils.contains('PACKAGECONFIG', 'pulseaudio', 'pulse', '', d)}" | ||
42 | AUDIOMODS += "${@bb.utils.contains('PACKAGECONFIG', 'sdl', 'sdl', '', d)}" | ||
43 | |||
44 | EXTRA_OECONF = " \ | ||
45 | --enable-shared \ | ||
46 | --with-audio='${AUDIOMODS}' \ | ||
47 | --with-module-suffix=.so \ | ||
48 | ${@bb.utils.contains('TUNE_FEATURES', 'neon', '--with-cpu=neon', '', d)} \ | ||
49 | ${@bb.utils.contains('TUNE_FEATURES', 'altivec', '--with-cpu=altivec', '', d)} \ | ||
50 | " | ||
51 | |||
52 | # The x86 assembler optimisations contains text relocations and there are no | ||
53 | # upstream plans to fix them: http://sourceforge.net/p/mpg123/bugs/168/ | ||
54 | INSANE_SKIP_${PN}_append_x86 = " textrel" | ||
55 | |||
56 | # Fails to build with thumb-1 (qemuarm) | ||
57 | #| {standard input}: Assembler messages: | ||
58 | #| {standard input}:47: Error: selected processor does not support Thumb mode `smull r5,r6,r7,r4' | ||
59 | #| {standard input}:48: Error: shifts in CMP/MOV instructions are only supported in unified syntax -- `mov r5,r5,lsr#24' | ||
60 | #... | ||
61 | #| make[3]: *** [equalizer.lo] Error 1 | ||
62 | ARM_INSTRUCTION_SET_armv4 = "arm" | ||
63 | ARM_INSTRUCTION_SET_armv5 = "arm" | ||