summaryrefslogtreecommitdiffstats
path: root/meta/recipes-multimedia/libtiff/tiff_4.0.7.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-multimedia/libtiff/tiff_4.0.7.bb')
-rw-r--r--meta/recipes-multimedia/libtiff/tiff_4.0.7.bb48
1 files changed, 48 insertions, 0 deletions
diff --git a/meta/recipes-multimedia/libtiff/tiff_4.0.7.bb b/meta/recipes-multimedia/libtiff/tiff_4.0.7.bb
new file mode 100644
index 0000000000..729678208f
--- /dev/null
+++ b/meta/recipes-multimedia/libtiff/tiff_4.0.7.bb
@@ -0,0 +1,48 @@
1SUMMARY = "Provides support for the Tag Image File Format (TIFF)"
2LICENSE = "BSD-2-Clause"
3LIC_FILES_CHKSUM = "file://COPYRIGHT;md5=34da3db46fab7501992f9615d7e158cf"
4
5CVE_PRODUCT = "libtiff"
6
7SRC_URI = "http://download.osgeo.org/libtiff/tiff-${PV}.tar.gz \
8 file://libtool2.patch \
9 "
10
11SRC_URI[md5sum] = "77ae928d2c6b7fb46a21c3a29325157b"
12SRC_URI[sha256sum] = "9f43a2cfb9589e5cecaa66e16bf87f814c945f22df7ba600d63aac4632c4f019"
13
14# exclude betas
15UPSTREAM_CHECK_REGEX = "tiff-(?P<pver>\d+(\.\d+)+).tar"
16
17inherit autotools
18
19CACHED_CONFIGUREVARS = "ax_cv_check_gl_libgl=no"
20
21PACKAGECONFIG ?= "cxx jpeg zlib lzma \
22 strip-chopping extrasample-as-alpha check-ycbcr-subsampling"
23
24PACKAGECONFIG[cxx] = "--enable-cxx,--disable-cxx,,"
25PACKAGECONFIG[jpeg] = "--enable-jpeg,--disable-jpeg,jpeg,"
26PACKAGECONFIG[zlib] = "--enable-zlib,--disable-zlib,zlib,"
27PACKAGECONFIG[lzma] = "--enable-lzma,--disable-lzma,xz,"
28
29# Convert single-strip uncompressed images to multiple strips of specified
30# size (default: 8192) to reduce memory usage
31PACKAGECONFIG[strip-chopping] = "--enable-strip-chopping,--disable-strip-chopping,,"
32
33# Treat a fourth sample with no EXTRASAMPLE_ value as being ASSOCALPHA
34PACKAGECONFIG[extrasample-as-alpha] = "--enable-extrasample-as-alpha,--disable-extrasample-as-alpha,,"
35
36# Control picking up YCbCr subsample info. Disable to support files lacking
37# the tag
38PACKAGECONFIG[check-ycbcr-subsampling] = "--enable-check-ycbcr-subsampling,--disable-check-ycbcr-subsampling,,"
39
40# Support a mechanism allowing reading large strips (usually one strip files)
41# in chunks when using TIFFReadScanline. Experimental 4.0+ feature
42PACKAGECONFIG[chunky-strip-read] = "--enable-chunky-strip-read,--disable-chunky-strip-read,,"
43
44PACKAGES =+ "tiffxx tiff-utils"
45FILES_tiffxx = "${libdir}/libtiffxx.so.*"
46FILES_tiff-utils = "${bindir}/*"
47
48BBCLASSEXTEND = "native"