summaryrefslogtreecommitdiffstats
path: root/meta/recipes-multimedia/libtiff/tiff_4.0.6.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-multimedia/libtiff/tiff_4.0.6.bb')
-rw-r--r--meta/recipes-multimedia/libtiff/tiff_4.0.6.bb67
1 files changed, 0 insertions, 67 deletions
diff --git a/meta/recipes-multimedia/libtiff/tiff_4.0.6.bb b/meta/recipes-multimedia/libtiff/tiff_4.0.6.bb
deleted file mode 100644
index 963d4b309f..0000000000
--- a/meta/recipes-multimedia/libtiff/tiff_4.0.6.bb
+++ /dev/null
@@ -1,67 +0,0 @@
1SUMMARY = "Provides support for the Tag Image File Format (TIFF)"
2LICENSE = "BSD-2-Clause"
3LIC_FILES_CHKSUM = "file://COPYRIGHT;md5=34da3db46fab7501992f9615d7e158cf"
4
5CVE_PRODUCT = "libtiff"
6
7SRC_URI = "http://download.osgeo.org/libtiff/tiff-${PV}.tar.gz \
8 file://libtool2.patch \
9 file://CVE-2015-8665_8683.patch \
10 file://CVE-2015-8781.patch \
11 file://CVE-2015-8784.patch \
12 file://CVE-2016-3186.patch \
13 file://CVE-2016-5321.patch \
14 file://CVE-2016-5323.patch \
15 file://CVE-2016-3945.patch \
16 file://CVE-2016-3990.patch \
17 file://CVE-2016-3991.patch \
18 file://CVE-2016-3623.patch \
19 file://CVE-2016-3622.patch \
20 file://CVE-2016-3658.patch \
21 file://CVE-2016-3632.patch \
22 file://CVE-2016-9540.patch \
23 file://CVE-2016-9539.patch \
24 file://CVE-2016-9535-1.patch \
25 file://CVE-2016-9535-2.patch \
26 file://CVE-2016-9538.patch \
27 file://Fix_several_CVE_issues.patch \
28 "
29
30SRC_URI[md5sum] = "d1d2e940dea0b5ad435f21f03d96dd72"
31SRC_URI[sha256sum] = "4d57a50907b510e3049a4bba0d7888930fdfc16ce49f1bf693e5b6247370d68c"
32
33# exclude betas
34UPSTREAM_CHECK_REGEX = "tiff-(?P<pver>\d+(\.\d+)+).tar"
35
36inherit autotools
37
38CACHED_CONFIGUREVARS = "ax_cv_check_gl_libgl=no"
39
40PACKAGECONFIG ?= "cxx jpeg zlib lzma \
41 strip-chopping extrasample-as-alpha check-ycbcr-subsampling"
42
43PACKAGECONFIG[cxx] = "--enable-cxx,--disable-cxx,,"
44PACKAGECONFIG[jpeg] = "--enable-jpeg,--disable-jpeg,jpeg,"
45PACKAGECONFIG[zlib] = "--enable-zlib,--disable-zlib,zlib,"
46PACKAGECONFIG[lzma] = "--enable-lzma,--disable-lzma,xz,"
47
48# Convert single-strip uncompressed images to multiple strips of specified
49# size (default: 8192) to reduce memory usage
50PACKAGECONFIG[strip-chopping] = "--enable-strip-chopping,--disable-strip-chopping,,"
51
52# Treat a fourth sample with no EXTRASAMPLE_ value as being ASSOCALPHA
53PACKAGECONFIG[extrasample-as-alpha] = "--enable-extrasample-as-alpha,--disable-extrasample-as-alpha,,"
54
55# Control picking up YCbCr subsample info. Disable to support files lacking
56# the tag
57PACKAGECONFIG[check-ycbcr-subsampling] = "--enable-check-ycbcr-subsampling,--disable-check-ycbcr-subsampling,,"
58
59# Support a mechanism allowing reading large strips (usually one strip files)
60# in chunks when using TIFFReadScanline. Experimental 4.0+ feature
61PACKAGECONFIG[chunky-strip-read] = "--enable-chunky-strip-read,--disable-chunky-strip-read,,"
62
63PACKAGES =+ "tiffxx tiff-utils"
64FILES_tiffxx = "${libdir}/libtiffxx.so.*"
65FILES_tiff-utils = "${bindir}/*"
66
67BBCLASSEXTEND = "native"