summaryrefslogtreecommitdiffstats
path: root/meta/recipes-multimedia/libtiff/tiff_4.0.3.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-multimedia/libtiff/tiff_4.0.3.bb')
-rw-r--r--meta/recipes-multimedia/libtiff/tiff_4.0.3.bb54
1 files changed, 54 insertions, 0 deletions
diff --git a/meta/recipes-multimedia/libtiff/tiff_4.0.3.bb b/meta/recipes-multimedia/libtiff/tiff_4.0.3.bb
new file mode 100644
index 0000000000..b7d1129ad6
--- /dev/null
+++ b/meta/recipes-multimedia/libtiff/tiff_4.0.3.bb
@@ -0,0 +1,54 @@
1SUMMARY = "Provides support for the Tag Image File Format (TIFF)"
2LICENSE = "BSD-2-Clause"
3LIC_FILES_CHKSUM = "file://COPYRIGHT;md5=34da3db46fab7501992f9615d7e158cf"
4HOMEPAGE = "http://www.remotesensing.org/libtiff/"
5
6SRC_URI = "ftp://ftp.remotesensing.org/pub/libtiff/tiff-${PV}.tar.gz \
7 file://libtool2.patch \
8 file://libtiff-CVE-2013-1960.patch \
9 file://libtiff-CVE-2013-1961.patch \
10 file://libtiff-CVE-2013-4232.patch \
11 file://libtiff-CVE-2013-4243.patch \
12 file://libtiff-CVE-2013-4244.patch \
13 file://libtiff-CVE-2013-4231.patch \
14 file://tiff-CVE-2012-4564.patch "
15
16SRC_URI[md5sum] = "051c1068e6a0627f461948c365290410"
17SRC_URI[sha256sum] = "ea1aebe282319537fb2d4d7805f478dd4e0e05c33d0928baba76a7c963684872"
18
19inherit autotools
20
21CACHED_CONFIGUREVARS = "ax_cv_check_gl_libgl=no"
22
23PACKAGECONFIG ?= "cxx jpeg zlib lzma \
24 strip-chopping extrasample-as-alpha check-ycbcr-subsampling"
25
26PACKAGECONFIG[cxx] = "--enable-cxx,--disable-cxx,,"
27PACKAGECONFIG[jpeg] = "--enable-jpeg,--disable-jpeg,jpeg,"
28PACKAGECONFIG[zlib] = "--enable-zlib,--disable-zlib,zlib,"
29PACKAGECONFIG[lzma] = "--enable-lzma,--disable-lzma,xz,"
30
31# Convert single-strip uncompressed images to multiple strips of specified
32# size (default: 8192) to reduce memory usage
33PACKAGECONFIG[strip-chopping] = "--enable-strip-chopping,--disable-strip-chopping,,"
34
35# Treat a fourth sample with no EXTRASAMPLE_ value as being ASSOCALPHA
36PACKAGECONFIG[extrasample-as-alpha] = "--enable-extrasample-as-alpha,--disable-extrasample-as-alpha,,"
37
38# Control picking up YCbCr subsample info. Disable to support files lacking
39# the tag
40PACKAGECONFIG[check-ycbcr-subsampling] = "--enable-check-ycbcr-subsampling,--disable-check-ycbcr-subsampling,,"
41
42# Support a mechanism allowing reading large strips (usually one strip files)
43# in chunks when using TIFFReadScanline. Experimental 4.0+ feature
44PACKAGECONFIG[chunky-strip-read] = "--enable-chunky-strip-read,--disable-chunky-strip-read,,"
45
46PACKAGES =+ "tiffxx tiffxx-dbg tiffxx-dev tiffxx-staticdev tiff-utils tiff-utils-dbg"
47FILES_tiffxx = "${libdir}/libtiffxx.so.*"
48FILES_tiffxx-dev = "${libdir}/libtiffxx.so ${libdir}/libtiffxx.la"
49FILES_tiffxx-staticdev = "${libdir}/libtiffxx.a"
50FILES_tiffxx-dbg += "${libdir}/.debug/libtiffxx.so*"
51FILES_tiff-utils = "${bindir}/*"
52FILES_tiff-utils-dbg += "${bindir}/.debug/"
53
54BBCLASSEXTEND = "native"