summaryrefslogtreecommitdiffstats
path: root/meta/recipes-multimedia/libpng/libpng_1.6.37.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-multimedia/libpng/libpng_1.6.37.bb')
-rw-r--r--meta/recipes-multimedia/libpng/libpng_1.6.37.bb18
1 files changed, 16 insertions, 2 deletions
diff --git a/meta/recipes-multimedia/libpng/libpng_1.6.37.bb b/meta/recipes-multimedia/libpng/libpng_1.6.37.bb
index 8c53d11642..9387fc8e2e 100644
--- a/meta/recipes-multimedia/libpng/libpng_1.6.37.bb
+++ b/meta/recipes-multimedia/libpng/libpng_1.6.37.bb
@@ -1,4 +1,7 @@
1SUMMARY = "PNG image format decoding library" 1SUMMARY = "PNG image format decoding library"
2DESCRIPTION = "An open source project to develop and maintain the reference \
3library for use in applications that read, create, and manipulate PNG \
4(Portable Network Graphics) raster image files. "
2HOMEPAGE = "http://www.libpng.org/" 5HOMEPAGE = "http://www.libpng.org/"
3SECTION = "libs" 6SECTION = "libs"
4LICENSE = "Libpng" 7LICENSE = "Libpng"
@@ -7,7 +10,10 @@ DEPENDS = "zlib"
7 10
8LIBV = "16" 11LIBV = "16"
9 12
10SRC_URI = "${SOURCEFORGE_MIRROR}/${BPN}/${BPN}${LIBV}/${BP}.tar.xz" 13SRC_URI = "\
14 ${SOURCEFORGE_MIRROR}/${BPN}/${BPN}${LIBV}/${BP}.tar.xz \
15 file://run-ptest \
16 "
11SRC_URI[md5sum] = "015e8e15db1eecde5f2eb9eb5b6e59e9" 17SRC_URI[md5sum] = "015e8e15db1eecde5f2eb9eb5b6e59e9"
12SRC_URI[sha256sum] = "505e70834d35383537b6491e7ae8641f1a4bed1876dbfe361201fc80868d88ca" 18SRC_URI[sha256sum] = "505e70834d35383537b6491e7ae8641f1a4bed1876dbfe361201fc80868d88ca"
13 19
@@ -17,7 +23,7 @@ UPSTREAM_CHECK_URI = "http://libpng.org/pub/png/libpng.html"
17 23
18BINCONFIG = "${bindir}/libpng-config ${bindir}/libpng16-config" 24BINCONFIG = "${bindir}/libpng-config ${bindir}/libpng16-config"
19 25
20inherit autotools binconfig-disabled pkgconfig 26inherit autotools binconfig-disabled pkgconfig ptest
21 27
22# Work around missing symbols 28# Work around missing symbols
23EXTRA_OECONF_append_class-target = " ${@bb.utils.contains("TUNE_FEATURES", "neon", "--enable-arm-neon=on", "--enable-arm-neon=off" ,d)}" 29EXTRA_OECONF_append_class-target = " ${@bb.utils.contains("TUNE_FEATURES", "neon", "--enable-arm-neon=on", "--enable-arm-neon=off" ,d)}"
@@ -30,3 +36,11 @@ BBCLASSEXTEND = "native nativesdk"
30 36
31# CVE-2019-17371 is actually a memory leak in gif2png 2.x 37# CVE-2019-17371 is actually a memory leak in gif2png 2.x
32CVE_CHECK_WHITELIST += "CVE-2019-17371" 38CVE_CHECK_WHITELIST += "CVE-2019-17371"
39
40do_install_ptest() {
41 install -m644 "${S}/pngtest.png" "${D}${PTEST_PATH}"
42 install -m755 "${B}/.libs/pngfix" "${D}${PTEST_PATH}"
43 install -m755 "${B}/.libs/pngtest" "${D}${PTEST_PATH}"
44 install -m755 "${B}/.libs/pngstest" "${D}${PTEST_PATH}"
45 install -m755 "${B}/.libs/timepng" "${D}${PTEST_PATH}"
46}