summaryrefslogtreecommitdiffstats
path: root/meta/recipes-multimedia/libav/libpostproc_git.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-multimedia/libav/libpostproc_git.bb')
-rw-r--r--meta/recipes-multimedia/libav/libpostproc_git.bb49
1 files changed, 0 insertions, 49 deletions
diff --git a/meta/recipes-multimedia/libav/libpostproc_git.bb b/meta/recipes-multimedia/libav/libpostproc_git.bb
deleted file mode 100644
index 911ae863ae..0000000000
--- a/meta/recipes-multimedia/libav/libpostproc_git.bb
+++ /dev/null
@@ -1,49 +0,0 @@
1SUMMARY = "FFmpeg derived postprocessing library"
2HOMEPAGE = "http://git.videolan.org/?p=libpostproc.git;a=summary"
3SECTION = "libs"
4DEPENDS = "libav"
5LICENSE = "GPLv2+"
6LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263"
7
8# because it depends on libav which has commercial flag
9LICENSE_FLAGS = "commercial"
10
11PV = "52.3.0+git${SRCPV}"
12
13SRCREV = "811db3b957dfde24aef2d0f82e297e5bf552d873"
14SRC_URI = "git://github.com/lu-zero/postproc;protocol=https"
15
16S = "${WORKDIR}/git"
17
18inherit autotools lib_package pkgconfig
19
20FULL_OPTIMIZATION_armv7a = "-fexpensive-optimizations -fomit-frame-pointer -O4 -ffast-math"
21FULL_OPTIMIZATION_armv7ve = "-fexpensive-optimizations -fomit-frame-pointer -O4 -ffast-math"
22BUILD_OPTIMIZATION = "${FULL_OPTIMIZATION}"
23
24EXTRA_FFCONF_armv7a = "--cpu=cortex-a8"
25EXTRA_FFCONF_armv7ve = "--cpu=cortex-a8"
26EXTRA_FFCONF ?= ""
27
28EXTRA_OECONF = " \
29 --enable-shared \
30 --enable-pthreads \
31 --enable-gpl \
32 --enable-postproc \
33 \
34 --cross-prefix=${TARGET_PREFIX} \
35 --prefix=${prefix} \
36 \
37 --arch=${TARGET_ARCH} \
38 --target-os="linux" \
39 --enable-cross-compile \
40 --extra-cflags="${TARGET_CFLAGS} ${HOST_CC_ARCH}${TOOLCHAIN_OPTIONS}" \
41 --extra-ldflags="${TARGET_LDFLAGS}" \
42 --sysroot="${STAGING_DIR_TARGET}" \
43 --shlibdir="${libdir}" \
44 ${EXTRA_FFCONF} \
45"
46
47do_configure() {
48 ${S}/configure ${EXTRA_OECONF}
49}