summaryrefslogtreecommitdiffstats
path: root/meta/recipes-multimedia/lame/lame_3.99.5.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-multimedia/lame/lame_3.99.5.bb')
-rw-r--r--meta/recipes-multimedia/lame/lame_3.99.5.bb34
1 files changed, 34 insertions, 0 deletions
diff --git a/meta/recipes-multimedia/lame/lame_3.99.5.bb b/meta/recipes-multimedia/lame/lame_3.99.5.bb
new file mode 100644
index 0000000000..a0c4cf5c65
--- /dev/null
+++ b/meta/recipes-multimedia/lame/lame_3.99.5.bb
@@ -0,0 +1,34 @@
1DESCRIPTION = "LAME is an educational tool to be used for learning about MP3 encoding."
2HOMEPAGE = "http://sourceforge.net/projects/lame/files/lame/"
3BUGTRACKER = "http://sourceforge.net/tracker/?group_id=290&atid=100290"
4SECTION = "console/utils"
5LICENSE = "LGPLv2+"
6LICENSE_FLAGS = "commercial"
7
8LIC_FILES_CHKSUM = "file://COPYING;md5=c46bda00ffbb0ba1dac22f8d087f54d9 \
9 file://include/lame.h;beginline=1;endline=20;md5=a2258182c593c398d15a48262130a92b \
10"
11PR = "r0"
12
13SRC_URI = "${SOURCEFORGE_MIRROR}/lame/lame-${PV}.tar.gz \
14 file://no-gtk1.patch"
15
16SRC_URI[md5sum] = "84835b313d4a8b68f5349816d33e07ce"
17SRC_URI[sha256sum] = "24346b4158e4af3bd9f2e194bb23eb473c75fb7377011523353196b19b9a23ff"
18
19inherit autotools
20
21PACKAGES += "libmp3lame libmp3lame-dev"
22FILES_${PN} = "${bindir}/lame"
23FILES_libmp3lame = "${libdir}/libmp3lame.so.*"
24FILES_libmp3lame-dev = "${includedir} ${libdir}/*"
25FILES_${PN}-dev = ""
26
27do_configure() {
28 # no autoreconf please
29 aclocal
30 autoconf
31 libtoolize --force
32 gnu-configize --force
33 oe_runconf
34}