summaryrefslogtreecommitdiffstats
path: root/meta/recipes-multimedia/lame/lame_3.99.1.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-multimedia/lame/lame_3.99.1.bb')
-rw-r--r--meta/recipes-multimedia/lame/lame_3.99.1.bb31
1 files changed, 31 insertions, 0 deletions
diff --git a/meta/recipes-multimedia/lame/lame_3.99.1.bb b/meta/recipes-multimedia/lame/lame_3.99.1.bb
new file mode 100644
index 0000000000..31766fd92a
--- /dev/null
+++ b/meta/recipes-multimedia/lame/lame_3.99.1.bb
@@ -0,0 +1,31 @@
1DESCRIPTION = "LAME is an educational tool to be used for learning about MP3 encoding."
2HOMEPAGE = "http://sourceforge.net/projects/lame/files/lame/"
3BUGTRACKER = "http://sourceforge.net/tracker/?group_id=290&atid=100290"
4SECTION = "console/utils"
5LICENSE = "LGPLv2+"
6LIC_FILES_CHKSUM = "file://COPYING;md5=c46bda00ffbb0ba1dac22f8d087f54d9 \
7 file://include/lame.h;beginline=1;endline=20;md5=a2258182c593c398d15a48262130a92b
8PR = "r0"
9
10SRC_URI = "${SOURCEFORGE_MIRROR}/lame/lame-${PV}.tar.gz \
11 file://no-gtk1.patch"
12
13SRC_URI[md5sum] = "2576a7368b5c90a87adc9de6b9f0628c"
14SRC_URI[sha256sum] = "1eedcbe238f81cdef822f367f104a8ff918062727b61f0c62b24e9f79d941cf0"
15
16inherit autotools
17
18PACKAGES += "libmp3lame libmp3lame-dev"
19FILES_${PN} = "${bindir}/lame"
20FILES_libmp3lame = "${libdir}/libmp3lame.so.*"
21FILES_libmp3lame-dev = "${includedir} ${libdir}/*"
22FILES_${PN}-dev = ""
23
24do_configure() {
25 # no autoreconf please
26 aclocal
27 autoconf
28 libtoolize --force
29 gnu-configize --force
30 oe_runconf
31}