summaryrefslogtreecommitdiffstats
path: root/meta/recipes-multimedia/lame/lame_3.98.4.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-multimedia/lame/lame_3.98.4.bb')
-rw-r--r--meta/recipes-multimedia/lame/lame_3.98.4.bb28
1 files changed, 28 insertions, 0 deletions
diff --git a/meta/recipes-multimedia/lame/lame_3.98.4.bb b/meta/recipes-multimedia/lame/lame_3.98.4.bb
new file mode 100644
index 0000000000..316933495c
--- /dev/null
+++ b/meta/recipes-multimedia/lame/lame_3.98.4.bb
@@ -0,0 +1,28 @@
1DESCRIPTION = "LAME is an educational tool to be used for learning about MP3 encoding."
2HOMEPAGE = "http://sourceforge.net/projects/lame/files/lame/"
3BUGTRACKER = "http://sourceforge.net/tracker/?group_id=290&atid=100290"
4SECTION = "console/utils"
5LICENSE = "LGPLv2+"
6LIC_FILES_CHKSUM = "file://COPYING;md5=c46bda00ffbb0ba1dac22f8d087f54d9 \
7 file://include/lame.h;beginline=1;endline=20;md5=d3ff8cae3e79c4e9da7169c7928dc3a2"
8PR = "r0"
9
10SRC_URI = "${SOURCEFORGE_MIRROR}/lame/lame-${PV}.tar.gz \
11 file://no-gtk1.patch;patch=1"
12
13inherit autotools
14
15PACKAGES += "libmp3lame libmp3lame-dev"
16FILES_${PN} = "${bindir}/lame"
17FILES_libmp3lame = "${libdir}/libmp3lame.so.*"
18FILES_libmp3lame-dev = "${includedir} ${libdir}/*"
19FILES_${PN}-dev = ""
20
21do_configure() {
22 # no autoreconf please
23 aclocal
24 autoconf
25 libtoolize --force
26 gnu-configize --force
27 oe_runconf
28}