summaryrefslogtreecommitdiffstats
path: root/meta/recipes-multimedia/gstreamer/gstreamer1.0_1.18.6.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-multimedia/gstreamer/gstreamer1.0_1.18.6.bb')
-rw-r--r--meta/recipes-multimedia/gstreamer/gstreamer1.0_1.18.6.bb71
1 files changed, 71 insertions, 0 deletions
diff --git a/meta/recipes-multimedia/gstreamer/gstreamer1.0_1.18.6.bb b/meta/recipes-multimedia/gstreamer/gstreamer1.0_1.18.6.bb
new file mode 100644
index 0000000000..82fb476a47
--- /dev/null
+++ b/meta/recipes-multimedia/gstreamer/gstreamer1.0_1.18.6.bb
@@ -0,0 +1,71 @@
1SUMMARY = "GStreamer 1.0 multimedia framework"
2DESCRIPTION = "GStreamer is a multimedia framework for encoding and decoding video and sound. \
3It supports a wide range of formats including mp3, ogg, avi, mpeg and quicktime."
4HOMEPAGE = "http://gstreamer.freedesktop.org/"
5BUGTRACKER = "https://bugzilla.gnome.org/enter_bug.cgi?product=Gstreamer"
6SECTION = "multimedia"
7LICENSE = "LGPLv2+"
8
9DEPENDS = "glib-2.0 glib-2.0-native libxml2 bison-native flex-native"
10
11inherit meson pkgconfig gettext upstream-version-is-even gobject-introspection
12
13LIC_FILES_CHKSUM = "file://COPYING;md5=6762ed442b3822387a51c92d928ead0d \
14 file://gst/gst.h;beginline=1;endline=21;md5=e059138481205ee2c6fc1c079c016d0d"
15
16S = "${WORKDIR}/gstreamer-${PV}"
17
18SRC_URI = "https://gstreamer.freedesktop.org/src/gstreamer/gstreamer-${PV}.tar.xz \
19 file://0001-gst-gstpluginloader.c-when-env-var-is-set-do-not-fal.patch \
20 file://0002-Remove-unused-valgrind-detection.patch \
21 file://0003-meson-Add-option-for-installed-tests.patch \
22 file://0001-tests-seek-Don-t-use-too-strict-timeout-for-validati.patch \
23 "
24SRC_URI[sha256sum] = "4ec816010dd4d3a93cf470ad0a6f25315f52b204eb1d71dfa70ab8a1c3bd06e6"
25
26PACKAGECONFIG ??= "${@bb.utils.contains('PTEST_ENABLED', '1', 'tests', '', d)} \
27 check \
28 debug \
29 tools"
30
31PACKAGECONFIG[debug] = "-Dgst_debug=true,-Dgst_debug=false"
32PACKAGECONFIG[tracer-hooks] = "-Dtracer_hooks=true,-Dtracer_hooks=false"
33PACKAGECONFIG[coretracers] = "-Dcoretracers=enabled,-Dcoretracers=disabled"
34PACKAGECONFIG[check] = "-Dcheck=enabled,-Dcheck=disabled"
35PACKAGECONFIG[tests] = "-Dtests=enabled -Dinstalled-tests=true,-Dtests=disabled -Dinstalled-tests=false"
36PACKAGECONFIG[unwind] = "-Dlibunwind=enabled,-Dlibunwind=disabled,libunwind"
37PACKAGECONFIG[dw] = "-Dlibdw=enabled,-Dlibdw=disabled,elfutils"
38PACKAGECONFIG[bash-completion] = "-Dbash-completion=enabled,-Dbash-completion=disabled,bash-completion"
39PACKAGECONFIG[tools] = "-Dtools=enabled,-Dtools=disabled"
40PACKAGECONFIG[setcap] = "-Dptp-helper-permissions=capabilities,,libcap libcap-native"
41
42# TODO: put this in a gettext.bbclass patch
43def gettext_oemeson(d):
44 if d.getVar('USE_NLS') == 'no':
45 return '-Dnls=disabled'
46 # Remove the NLS bits if USE_NLS is no or INHIBIT_DEFAULT_DEPS is set
47 if d.getVar('INHIBIT_DEFAULT_DEPS') and not oe.utils.inherits(d, 'cross-canadian'):
48 return '-Dnls=disabled'
49 return '-Dnls=enabled'
50
51EXTRA_OEMESON += " \
52 -Ddoc=disabled \
53 -Dexamples=disabled \
54 -Ddbghelp=disabled \
55 ${@gettext_oemeson(d)} \
56"
57
58GIR_MESON_ENABLE_FLAG = "enabled"
59GIR_MESON_DISABLE_FLAG = "disabled"
60
61PACKAGES += "${PN}-bash-completion"
62
63# Add the core element plugins to the main package
64FILES_${PN} += "${libdir}/gstreamer-1.0/*.so"
65FILES_${PN}-dev += "${libdir}/gstreamer-1.0/*.a ${libdir}/gstreamer-1.0/include"
66FILES_${PN}-bash-completion += "${datadir}/bash-completion/completions/ ${datadir}/bash-completion/helpers/gst*"
67FILES_${PN}-dbg += "${datadir}/gdb ${datadir}/gstreamer-1.0/gdb"
68
69CVE_PRODUCT = "gstreamer"
70
71require gstreamer1.0-ptest.inc