summaryrefslogtreecommitdiffstats
path: root/meta/recipes-multimedia/gstreamer/gstreamer1.0_1.16.3.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-multimedia/gstreamer/gstreamer1.0_1.16.3.bb')
-rw-r--r--meta/recipes-multimedia/gstreamer/gstreamer1.0_1.16.3.bb76
1 files changed, 76 insertions, 0 deletions
diff --git a/meta/recipes-multimedia/gstreamer/gstreamer1.0_1.16.3.bb b/meta/recipes-multimedia/gstreamer/gstreamer1.0_1.16.3.bb
new file mode 100644
index 0000000000..66ad3e3381
--- /dev/null
+++ b/meta/recipes-multimedia/gstreamer/gstreamer1.0_1.16.3.bb
@@ -0,0 +1,76 @@
1SUMMARY = "GStreamer 1.0 multimedia framework"
2DESCRIPTION = "GStreamer is a multimedia framework for encoding and decoding video and sound. \
3It supports a wide range of formats including mp3, ogg, avi, mpeg and quicktime."
4HOMEPAGE = "http://gstreamer.freedesktop.org/"
5BUGTRACKER = "https://bugzilla.gnome.org/enter_bug.cgi?product=Gstreamer"
6SECTION = "multimedia"
7LICENSE = "LGPLv2+"
8
9DEPENDS = "glib-2.0 glib-2.0-native libxml2 bison-native flex-native"
10
11inherit meson pkgconfig gettext upstream-version-is-even gobject-introspection gtk-doc
12
13LIC_FILES_CHKSUM = "file://COPYING;md5=6762ed442b3822387a51c92d928ead0d \
14 file://gst/gst.h;beginline=1;endline=21;md5=e059138481205ee2c6fc1c079c016d0d"
15
16S = "${WORKDIR}/gstreamer-${PV}"
17
18SRC_URI = " \
19 https://gstreamer.freedesktop.org/src/gstreamer/gstreamer-${PV}.tar.xz \
20 file://0001-gst-gstpluginloader.c-when-env-var-is-set-do-not-fal.patch \
21 file://0002-meson-build-gir-even-when-cross-compiling-if-introsp.patch \
22 file://0003-meson-Add-valgrind-feature.patch \
23 file://0004-meson-Add-option-for-installed-tests.patch \
24"
25SRC_URI[md5sum] = "beecf6965a17fb17fa3b262fd36df70a"
26SRC_URI[sha256sum] = "692f037968e454e508b0f71d9674e2e26c78475021407fcf8193b1c7e59543c7"
27
28PACKAGECONFIG ??= "${@bb.utils.contains('PTEST_ENABLED', '1', 'tests', '', d)} \
29 check \
30 debug \
31 tools"
32
33PACKAGECONFIG[debug] = "-Dgst_debug=true,-Dgst_debug=false"
34PACKAGECONFIG[tracer-hooks] = "-Dtracer_hooks=true,-Dtracer_hooks=false"
35PACKAGECONFIG[check] = "-Dcheck=enabled,-Dcheck=disabled"
36PACKAGECONFIG[tests] = "-Dtests=enabled -Dinstalled-tests=true,-Dtests=disabled -Dinstalled-tests=false"
37PACKAGECONFIG[valgrind] = "-Dvalgrind=enabled,-Dvalgrind=disabled,valgrind,"
38PACKAGECONFIG[unwind] = "-Dlibunwind=enabled,-Dlibunwind=disabled,libunwind"
39PACKAGECONFIG[dw] = "-Dlibdw=enabled,-Dlibdw=disabled,elfutils"
40PACKAGECONFIG[bash-completion] = "-Dbash-completion=enabled,-Dbash-completion=disabled,bash-completion"
41PACKAGECONFIG[tools] = "-Dtools=enabled,-Dtools=disabled"
42PACKAGECONFIG[setcap] = ",,libcap libcap-native"
43
44# TODO: put this in a gettext.bbclass patch
45def gettext_oemeson(d):
46 if d.getVar('USE_NLS') == 'no':
47 return '-Dnls=disabled'
48 # Remove the NLS bits if USE_NLS is no or INHIBIT_DEFAULT_DEPS is set
49 if d.getVar('INHIBIT_DEFAULT_DEPS') and not oe.utils.inherits(d, 'cross-canadian'):
50 return '-Dnls=disabled'
51 return '-Dnls=enabled'
52
53EXTRA_OEMESON += " \
54 -Dexamples=disabled \
55 -Ddbghelp=disabled \
56 ${@gettext_oemeson(d)} \
57"
58
59GTKDOC_MESON_OPTION = "gtk_doc"
60GTKDOC_MESON_ENABLE_FLAG = "enabled"
61GTKDOC_MESON_DISABLE_FLAG = "disabled"
62
63GIR_MESON_ENABLE_FLAG = "enabled"
64GIR_MESON_DISABLE_FLAG = "disabled"
65
66PACKAGES += "${PN}-bash-completion"
67
68# Add the core element plugins to the main package
69FILES_${PN} += "${libdir}/gstreamer-1.0/*.so"
70FILES_${PN}-dev += "${libdir}/gstreamer-1.0/*.a ${libdir}/gstreamer-1.0/include"
71FILES_${PN}-bash-completion += "${datadir}/bash-completion/completions/ ${datadir}/bash-completion/helpers/gst*"
72FILES_${PN}-dbg += "${datadir}/gdb ${datadir}/gstreamer-1.0/gdb"
73
74CVE_PRODUCT = "gstreamer"
75
76require gstreamer1.0-ptest.inc