summaryrefslogtreecommitdiffstats
path: root/meta/recipes-multimedia/gstreamer/gstreamer1.0_1.14.0.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-multimedia/gstreamer/gstreamer1.0_1.14.0.bb')
-rw-r--r--meta/recipes-multimedia/gstreamer/gstreamer1.0_1.14.0.bb71
1 files changed, 71 insertions, 0 deletions
diff --git a/meta/recipes-multimedia/gstreamer/gstreamer1.0_1.14.0.bb b/meta/recipes-multimedia/gstreamer/gstreamer1.0_1.14.0.bb
new file mode 100644
index 0000000000..b4398c8111
--- /dev/null
+++ b/meta/recipes-multimedia/gstreamer/gstreamer1.0_1.14.0.bb
@@ -0,0 +1,71 @@
1SUMMARY = "GStreamer 1.0 multimedia framework"
2DESCRIPTION = "GStreamer is a multimedia framework for encoding and decoding video and sound. \
3It supports a wide range of formats including mp3, ogg, avi, mpeg and quicktime."
4HOMEPAGE = "http://gstreamer.freedesktop.org/"
5BUGTRACKER = "https://bugzilla.gnome.org/enter_bug.cgi?product=Gstreamer"
6SECTION = "multimedia"
7LICENSE = "LGPLv2+"
8
9DEPENDS = "glib-2.0 glib-2.0-native libcap libxml2 bison-native flex-native"
10
11inherit autotools pkgconfig gettext upstream-version-is-even gobject-introspection gtk-doc
12
13# This way common/m4/introspection.m4 will come first
14# (it has a custom INTROSPECTION_INIT macro, and so must be used instead of our common introspection.m4 file)
15acpaths = "-I ${S}/common/m4 -I ${S}/m4"
16
17LIC_FILES_CHKSUM = "file://COPYING;md5=6762ed442b3822387a51c92d928ead0d \
18 file://gst/gst.h;beginline=1;endline=21;md5=e059138481205ee2c6fc1c079c016d0d"
19
20S = "${WORKDIR}/gstreamer-${PV}"
21
22SRC_URI = " \
23 http://gstreamer.freedesktop.org/src/gstreamer/gstreamer-${PV}.tar.xz \
24 file://0001-introspection.m4-prefix-pkgconfig-paths-with-PKG_CON.patch \
25 file://gtk-doc-tweaks.patch \
26 file://0001-gst-gstpluginloader.c-when-env-var-is-set-do-not-fal.patch \
27"
28SRC_URI[md5sum] = "63c7cbfb86aa28c4522e374dc5555b96"
29SRC_URI[sha256sum] = "fc361367f0d4b780a868a8833f9f30b9c9f4ac9faea4e6b251db8b4b0398466e"
30
31PACKAGECONFIG ??= ""
32
33PACKAGECONFIG[debug] = "--enable-debug,--disable-debug"
34PACKAGECONFIG[tests] = "--enable-tests,--disable-tests"
35PACKAGECONFIG[valgrind] = "--enable-valgrind,--disable-valgrind,valgrind,"
36PACKAGECONFIG[gst-tracer-hooks] = "--enable-gst-tracer-hooks,--disable-gst-tracer-hooks,"
37PACKAGECONFIG[unwind] = "--with-unwind,--without-unwind,libunwind"
38PACKAGECONFIG[dw] = "--with-dw,--without-dw,elfutils"
39
40EXTRA_OECONF = " \
41 --disable-dependency-tracking \
42 --disable-examples \
43"
44
45CACHED_CONFIGUREVARS += "ac_cv_header_valgrind_valgrind_h=no"
46
47# musl libc generates warnings if <sys/poll.h> is included directly
48CACHED_CONFIGUREVARS += "ac_cv_header_sys_poll_h=no"
49
50PACKAGES += "${PN}-bash-completion"
51
52FILES_${PN} += "${libdir}/gstreamer-1.0/*.so"
53FILES_${PN}-dev += "${libdir}/gstreamer-1.0/*.la ${libdir}/gstreamer-1.0/*.a ${libdir}/gstreamer-1.0/include"
54FILES_${PN}-bash-completion += "${datadir}/bash-completion/completions/ ${datadir}/bash-completion/helpers/gst*"
55
56RRECOMMENDS_${PN}_qemux86 += "kernel-module-snd-ens1370 kernel-module-snd-rawmidi"
57RRECOMMENDS_${PN}_qemux86-64 += "kernel-module-snd-ens1370 kernel-module-snd-rawmidi"
58
59delete_pkg_m4_file() {
60 # This m4 file is out of date and is missing PKG_CONFIG_SYSROOT_PATH tweaks which we need for introspection
61 rm "${S}/common/m4/pkg.m4" || true
62 rm -f "${S}/common/m4/gtk-doc.m4"
63}
64
65do_configure[prefuncs] += "delete_pkg_m4_file"
66
67do_compile_prepend() {
68 export GIR_EXTRA_LIBS_PATH="${B}/gst/.libs:${B}/libs/gst/base/.libs"
69}
70
71CVE_PRODUCT = "gstreamer"