summaryrefslogtreecommitdiffstats
path: root/meta/recipes-multimedia/gstreamer/gstreamer1.0-vaapi_1.18.3.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-multimedia/gstreamer/gstreamer1.0-vaapi_1.18.3.bb')
-rw-r--r--meta/recipes-multimedia/gstreamer/gstreamer1.0-vaapi_1.18.3.bb52
1 files changed, 52 insertions, 0 deletions
diff --git a/meta/recipes-multimedia/gstreamer/gstreamer1.0-vaapi_1.18.3.bb b/meta/recipes-multimedia/gstreamer/gstreamer1.0-vaapi_1.18.3.bb
new file mode 100644
index 0000000000..23040ad73c
--- /dev/null
+++ b/meta/recipes-multimedia/gstreamer/gstreamer1.0-vaapi_1.18.3.bb
@@ -0,0 +1,52 @@
1SUMMARY = "VA-API support to GStreamer"
2DESCRIPTION = "gstreamer-vaapi consists of a collection of VA-API \
3based plugins for GStreamer and helper libraries: `vaapidecode', \
4`vaapiconvert', and `vaapisink'."
5
6REALPN = "gstreamer-vaapi"
7
8LICENSE = "LGPLv2.1+"
9LIC_FILES_CHKSUM = "file://COPYING.LIB;md5=4fbd65380cdd255951079008b364516c"
10
11SRC_URI = "https://gstreamer.freedesktop.org/src/${REALPN}/${REALPN}-${PV}.tar.xz"
12
13SRC_URI[sha256sum] = "ae9877f15757a661d4dfe6a09755a2faa959ab60752f14ca26b7ff10765e1f12"
14
15S = "${WORKDIR}/${REALPN}-${PV}"
16DEPENDS = "libva gstreamer1.0 gstreamer1.0-plugins-base gstreamer1.0-plugins-bad"
17
18inherit meson pkgconfig features_check upstream-version-is-even
19
20REQUIRED_DISTRO_FEATURES ?= "opengl"
21
22EXTRA_OEMESON += " \
23 -Ddoc=disabled \
24 -Dexamples=disabled \
25 -Dtests=enabled \
26"
27
28PACKAGES =+ "${PN}-tests"
29
30# OpenGL packageconfig factored out to make it easy for distros
31# and BSP layers to pick either glx, egl, or no GL. By default,
32# try detecting X11 first, and if found (with OpenGL), use GLX,
33# otherwise try to check if EGL can be used.
34PACKAGECONFIG_GL ?= "${@bb.utils.contains('DISTRO_FEATURES', 'x11 opengl', 'glx', \
35 bb.utils.contains('DISTRO_FEATURES', 'opengl', 'egl', \
36 '', d), d)}"
37
38PACKAGECONFIG ??= "drm encoders \
39 ${PACKAGECONFIG_GL} \
40 ${@bb.utils.filter('DISTRO_FEATURES', 'wayland x11', d)}"
41
42PACKAGECONFIG[drm] = "-Dwith_drm=yes,-Dwith_drm=no,udev libdrm"
43PACKAGECONFIG[egl] = "-Dwith_egl=yes,-Dwith_egl=no,virtual/egl"
44PACKAGECONFIG[encoders] = "-Dwith_encoders=yes,-Dwith_encoders=no"
45PACKAGECONFIG[glx] = "-Dwith_glx=yes,-Dwith_glx=no,virtual/libgl"
46PACKAGECONFIG[wayland] = "-Dwith_wayland=yes,-Dwith_wayland=no,wayland-native wayland wayland-protocols"
47PACKAGECONFIG[x11] = "-Dwith_x11=yes,-Dwith_x11=no,virtual/libx11 libxrandr libxrender"
48
49FILES_${PN} += "${libdir}/gstreamer-*/*.so"
50FILES_${PN}-dbg += "${libdir}/gstreamer-*/.debug"
51FILES_${PN}-dev += "${libdir}/gstreamer-*/*.a"
52FILES_${PN}-tests = "${bindir}/*"