summaryrefslogtreecommitdiffstats
path: root/meta/recipes-multimedia/gstreamer/gstreamer1.0-vaapi_1.16.3.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-multimedia/gstreamer/gstreamer1.0-vaapi_1.16.3.bb')
-rw-r--r--meta/recipes-multimedia/gstreamer/gstreamer1.0-vaapi_1.16.3.bb57
1 files changed, 57 insertions, 0 deletions
diff --git a/meta/recipes-multimedia/gstreamer/gstreamer1.0-vaapi_1.16.3.bb b/meta/recipes-multimedia/gstreamer/gstreamer1.0-vaapi_1.16.3.bb
new file mode 100644
index 0000000000..9d9b1b8757
--- /dev/null
+++ b/meta/recipes-multimedia/gstreamer/gstreamer1.0-vaapi_1.16.3.bb
@@ -0,0 +1,57 @@
1SUMMARY = "VA-API support to GStreamer"
2DESCRIPTION = "gstreamer-vaapi consists of a collection of VA-API \
3based plugins for GStreamer and helper libraries: `vaapidecode', \
4`vaapiconvert', and `vaapisink'."
5
6REALPN = "gstreamer-vaapi"
7
8LICENSE = "LGPLv2.1+"
9LIC_FILES_CHKSUM = "file://COPYING.LIB;md5=4fbd65380cdd255951079008b364516c"
10
11SRC_URI = "https://gstreamer.freedesktop.org/src/${REALPN}/${REALPN}-${PV}.tar.xz \
12 file://0001-vaapsink-downgrade-to-marginal.patch \
13 "
14
15SRC_URI[md5sum] = "8c9b5a4d20afc04bc5e1536e81511f27"
16SRC_URI[sha256sum] = "77200b3c183fe97cd987deb5544e615873cff5e98ec87573583771e5f1fb9ebe"
17
18S = "${WORKDIR}/${REALPN}-${PV}"
19DEPENDS = "libva gstreamer1.0 gstreamer1.0-plugins-base gstreamer1.0-plugins-bad"
20
21inherit meson pkgconfig gtk-doc features_check upstream-version-is-even
22
23REQUIRED_DISTRO_FEATURES ?= "opengl"
24
25EXTRA_OEMESON += " \
26 -Dexamples=disabled \
27"
28
29GTKDOC_MESON_OPTION = "gtk_doc"
30GTKDOC_MESON_ENABLE_FLAG = "enabled"
31GTKDOC_MESON_DISABLE_FLAG = "disabled"
32
33PACKAGES =+ "${PN}-tests"
34
35# OpenGL packageconfig factored out to make it easy for distros
36# and BSP layers to pick either glx, egl, or no GL. By default,
37# try detecting X11 first, and if found (with OpenGL), use GLX,
38# otherwise try to check if EGL can be used.
39PACKAGECONFIG_GL ?= "${@bb.utils.contains('DISTRO_FEATURES', 'x11 opengl', 'glx', \
40 bb.utils.contains('DISTRO_FEATURES', 'opengl', 'egl', \
41 '', d), d)}"
42
43PACKAGECONFIG ??= "drm encoders \
44 ${PACKAGECONFIG_GL} \
45 ${@bb.utils.filter('DISTRO_FEATURES', 'wayland x11', d)}"
46
47PACKAGECONFIG[drm] = "-Dwith_drm=yes,-Dwith_drm=no,udev libdrm"
48PACKAGECONFIG[egl] = "-Dwith_egl=yes,-Dwith_egl=no,virtual/egl"
49PACKAGECONFIG[encoders] = "-Dwith_encoders=yes,-Dwith_encoders=no"
50PACKAGECONFIG[glx] = "-Dwith_glx=yes,-Dwith_glx=no,virtual/libgl"
51PACKAGECONFIG[wayland] = "-Dwith_wayland=yes,-Dwith_wayland=no,wayland-native wayland wayland-protocols"
52PACKAGECONFIG[x11] = "-Dwith_x11=yes,-Dwith_x11=no,virtual/libx11 libxrandr libxrender"
53
54FILES_${PN} += "${libdir}/gstreamer-*/*.so"
55FILES_${PN}-dbg += "${libdir}/gstreamer-*/.debug"
56FILES_${PN}-dev += "${libdir}/gstreamer-*/*.a"
57FILES_${PN}-tests = "${bindir}/*"