summaryrefslogtreecommitdiffstats
path: root/meta/recipes-multimedia/gstreamer/gstreamer1.0-vaapi_1.16.2.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-multimedia/gstreamer/gstreamer1.0-vaapi_1.16.2.bb')
-rw-r--r--meta/recipes-multimedia/gstreamer/gstreamer1.0-vaapi_1.16.2.bb49
1 files changed, 49 insertions, 0 deletions
diff --git a/meta/recipes-multimedia/gstreamer/gstreamer1.0-vaapi_1.16.2.bb b/meta/recipes-multimedia/gstreamer/gstreamer1.0-vaapi_1.16.2.bb
new file mode 100644
index 0000000000..3170218abd
--- /dev/null
+++ b/meta/recipes-multimedia/gstreamer/gstreamer1.0-vaapi_1.16.2.bb
@@ -0,0 +1,49 @@
1SUMMARY = "VA-API support to GStreamer"
2DESCRIPTION = "gstreamer-vaapi consists of a collection of VA-API \
3based plugins for GStreamer and helper libraries: `vaapidecode', \
4`vaapiconvert', and `vaapisink'."
5
6REALPN = "gstreamer-vaapi"
7
8LICENSE = "LGPLv2.1+"
9LIC_FILES_CHKSUM = "file://COPYING.LIB;md5=4fbd65380cdd255951079008b364516c"
10
11SRC_URI = "https://gstreamer.freedesktop.org/src/${REALPN}/${REALPN}-${PV}.tar.xz \
12 file://0001-gst-vaapi-Makefile.am-Add-EGL_CFLAGS-to-libgstvaapi-.patch \
13 file://0001-vaapsink-downgrade-to-marginal.patch \
14 "
15
16SRC_URI[md5sum] = "13f7cb6a64bde24e67f563377487dcce"
17SRC_URI[sha256sum] = "191de7b0ab64a85dd0875c990721e7be95518f60e2a9106beca162004ed7c601"
18
19S = "${WORKDIR}/${REALPN}-${PV}"
20DEPENDS = "libva gstreamer1.0 gstreamer1.0-plugins-base gstreamer1.0-plugins-bad"
21
22inherit autotools pkgconfig gtk-doc distro_features_check upstream-version-is-even
23
24REQUIRED_DISTRO_FEATURES ?= "opengl"
25
26PACKAGES =+ "${PN}-tests"
27
28# OpenGL packageconfig factored out to make it easy for distros
29# and BSP layers to pick either glx, egl, or no GL. By default,
30# try detecting X11 first, and if found (with OpenGL), use GLX,
31# otherwise try to check if EGL can be used.
32PACKAGECONFIG_GL ?= "${@bb.utils.contains('DISTRO_FEATURES', 'x11 opengl', 'glx', \
33 bb.utils.contains('DISTRO_FEATURES', 'opengl', 'egl', \
34 '', d), d)}"
35
36PACKAGECONFIG ??= "drm \
37 ${PACKAGECONFIG_GL} \
38 ${@bb.utils.filter('DISTRO_FEATURES', 'wayland x11', d)}"
39
40PACKAGECONFIG[drm] = "--enable-drm,--disable-drm,udev libdrm"
41PACKAGECONFIG[egl] = "--enable-egl,--disable-egl,virtual/egl"
42PACKAGECONFIG[glx] = "--enable-glx,--disable-glx,virtual/libgl"
43PACKAGECONFIG[wayland] = "--enable-wayland,--disable-wayland,wayland-native wayland wayland-protocols"
44PACKAGECONFIG[x11] = "--enable-x11,--disable-x11,virtual/libx11 libxrandr libxrender"
45
46FILES_${PN} += "${libdir}/gstreamer-*/*.so"
47FILES_${PN}-dbg += "${libdir}/gstreamer-*/.debug"
48FILES_${PN}-dev += "${libdir}/gstreamer-*/*.la ${libdir}/gstreamer-*/*.a"
49FILES_${PN}-tests = "${bindir}/*"