diff options
Diffstat (limited to 'meta/recipes-multimedia/gstreamer/gstreamer1.0-vaapi_1.14.3.bb')
-rw-r--r-- | meta/recipes-multimedia/gstreamer/gstreamer1.0-vaapi_1.14.3.bb | 48 |
1 files changed, 48 insertions, 0 deletions
diff --git a/meta/recipes-multimedia/gstreamer/gstreamer1.0-vaapi_1.14.3.bb b/meta/recipes-multimedia/gstreamer/gstreamer1.0-vaapi_1.14.3.bb new file mode 100644 index 0000000000..a852f0a938 --- /dev/null +++ b/meta/recipes-multimedia/gstreamer/gstreamer1.0-vaapi_1.14.3.bb | |||
@@ -0,0 +1,48 @@ | |||
1 | SUMMARY = "VA-API support to GStreamer" | ||
2 | DESCRIPTION = "gstreamer-vaapi consists of a collection of VA-API \ | ||
3 | based plugins for GStreamer and helper libraries: `vaapidecode', \ | ||
4 | `vaapiconvert', and `vaapisink'." | ||
5 | |||
6 | REALPN = "gstreamer-vaapi" | ||
7 | |||
8 | LICENSE = "LGPLv2.1+" | ||
9 | LIC_FILES_CHKSUM = "file://COPYING.LIB;md5=4fbd65380cdd255951079008b364516c" | ||
10 | |||
11 | SRC_URI = "https://gstreamer.freedesktop.org/src/${REALPN}/${REALPN}-${PV}.tar.xz \ | ||
12 | file://0001-gst-vaapi-Makefile.am-Add-EGL_CFLAGS-to-libgstvaapi-.patch \ | ||
13 | " | ||
14 | |||
15 | SRC_URI[md5sum] = "c3aeaf8a7fdcbe37d9f40390b620775d" | ||
16 | SRC_URI[sha256sum] = "8f5e65cb96aa6e44ff80926366d4a6fef9b8da68a04bab4bf2cbed93941c74f0" | ||
17 | |||
18 | S = "${WORKDIR}/${REALPN}-${PV}" | ||
19 | DEPENDS = "libva gstreamer1.0 gstreamer1.0-plugins-base gstreamer1.0-plugins-bad" | ||
20 | |||
21 | inherit autotools pkgconfig gtk-doc distro_features_check upstream-version-is-even | ||
22 | |||
23 | REQUIRED_DISTRO_FEATURES ?= "opengl" | ||
24 | |||
25 | PACKAGES =+ "${PN}-tests" | ||
26 | |||
27 | # OpenGL packageconfig factored out to make it easy for distros | ||
28 | # and BSP layers to pick either glx, egl, or no GL. By default, | ||
29 | # try detecting X11 first, and if found (with OpenGL), use GLX, | ||
30 | # otherwise try to check if EGL can be used. | ||
31 | PACKAGECONFIG_GL ?= "${@bb.utils.contains('DISTRO_FEATURES', 'x11 opengl', 'glx', \ | ||
32 | bb.utils.contains('DISTRO_FEATURES', 'opengl', 'egl', \ | ||
33 | '', d), d)}" | ||
34 | |||
35 | PACKAGECONFIG ??= "drm \ | ||
36 | ${PACKAGECONFIG_GL} \ | ||
37 | ${@bb.utils.filter('DISTRO_FEATURES', 'wayland x11', d)}" | ||
38 | |||
39 | PACKAGECONFIG[drm] = "--enable-drm,--disable-drm,udev libdrm" | ||
40 | PACKAGECONFIG[egl] = "--enable-egl,--disable-egl,virtual/egl" | ||
41 | PACKAGECONFIG[glx] = "--enable-glx,--disable-glx,virtual/libgl" | ||
42 | PACKAGECONFIG[wayland] = "--enable-wayland,--disable-wayland,wayland" | ||
43 | PACKAGECONFIG[x11] = "--enable-x11,--disable-x11,virtual/libx11 libxrandr libxrender" | ||
44 | |||
45 | FILES_${PN} += "${libdir}/gstreamer-*/*.so" | ||
46 | FILES_${PN}-dbg += "${libdir}/gstreamer-*/.debug" | ||
47 | FILES_${PN}-dev += "${libdir}/gstreamer-*/*.la ${libdir}/gstreamer-*/*.a" | ||
48 | FILES_${PN}-tests = "${bindir}/*" | ||