summaryrefslogtreecommitdiffstats
path: root/meta/recipes-multimedia/gstreamer/gstreamer1.0-vaapi_1.14.0.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-multimedia/gstreamer/gstreamer1.0-vaapi_1.14.0.bb')
-rw-r--r--meta/recipes-multimedia/gstreamer/gstreamer1.0-vaapi_1.14.0.bb48
1 files changed, 48 insertions, 0 deletions
diff --git a/meta/recipes-multimedia/gstreamer/gstreamer1.0-vaapi_1.14.0.bb b/meta/recipes-multimedia/gstreamer/gstreamer1.0-vaapi_1.14.0.bb
new file mode 100644
index 0000000000..4f752a57b3
--- /dev/null
+++ b/meta/recipes-multimedia/gstreamer/gstreamer1.0-vaapi_1.14.0.bb
@@ -0,0 +1,48 @@
1SUMMARY = "VA-API support to GStreamer"
2DESCRIPTION = "gstreamer-vaapi consists of a collection of VA-API \
3based plugins for GStreamer and helper libraries: `vaapidecode', \
4`vaapiconvert', and `vaapisink'."
5
6REALPN = "gstreamer-vaapi"
7FILESPATH = "${@base_set_filespath(["${FILE_DIRNAME}/${REALPN}", "${FILE_DIRNAME}/${REALPN}"], d)}"
8
9LICENSE = "LGPLv2.1+"
10LIC_FILES_CHKSUM = "file://COPYING.LIB;md5=4fbd65380cdd255951079008b364516c"
11
12SRC_URI = "https://gstreamer.freedesktop.org/src/${REALPN}/${REALPN}-${PV}.tar.xz \
13 "
14
15SRC_URI[md5sum] = "248c3aafab59814e71eb4a6c334cb261"
16SRC_URI[sha256sum] = "e4e31f085ef289bf1049398f641345979d20a1b11a80285744bba98504991df2"
17
18S = "${WORKDIR}/${REALPN}-${PV}"
19DEPENDS = "libva gstreamer1.0 gstreamer1.0-plugins-base gstreamer1.0-plugins-bad"
20
21inherit autotools pkgconfig gtk-doc distro_features_check upstream-version-is-even
22
23REQUIRED_DISTRO_FEATURES ?= "opengl"
24
25PACKAGES =+ "${PN}-tests"
26
27# OpenGL packageconfig factored out to make it easy for distros
28# and BSP layers to pick either glx, egl, or no GL. By default,
29# try detecting X11 first, and if found (with OpenGL), use GLX,
30# otherwise try to check if EGL can be used.
31PACKAGECONFIG_GL ?= "${@bb.utils.contains('DISTRO_FEATURES', 'x11 opengl', 'glx', \
32 bb.utils.contains('DISTRO_FEATURES', 'opengl', 'egl', \
33 '', d), d)}"
34
35PACKAGECONFIG ??= "drm \
36 ${PACKAGECONFIG_GL} \
37 ${@bb.utils.filter('DISTRO_FEATURES', 'wayland x11', d)}"
38
39PACKAGECONFIG[drm] = "--enable-drm,--disable-drm,udev libdrm"
40PACKAGECONFIG[egl] = "--enable-egl,--disable-egl,virtual/egl"
41PACKAGECONFIG[glx] = "--enable-glx,--disable-glx,virtual/libgl"
42PACKAGECONFIG[wayland] = "--enable-wayland,--disable-wayland,wayland"
43PACKAGECONFIG[x11] = "--enable-x11,--disable-x11,virtual/libx11 libxrandr libxrender"
44
45FILES_${PN} += "${libdir}/gstreamer-*/*.so"
46FILES_${PN}-dbg += "${libdir}/gstreamer-*/.debug"
47FILES_${PN}-dev += "${libdir}/gstreamer-*/*.la ${libdir}/gstreamer-*/*.a"
48FILES_${PN}-tests = "${bindir}/*"