summaryrefslogtreecommitdiffstats
path: root/meta/recipes-multimedia/gstreamer/gstreamer1.0-python_1.16.2.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-multimedia/gstreamer/gstreamer1.0-python_1.16.2.bb')
-rw-r--r--meta/recipes-multimedia/gstreamer/gstreamer1.0-python_1.16.2.bb39
1 files changed, 39 insertions, 0 deletions
diff --git a/meta/recipes-multimedia/gstreamer/gstreamer1.0-python_1.16.2.bb b/meta/recipes-multimedia/gstreamer/gstreamer1.0-python_1.16.2.bb
new file mode 100644
index 0000000000..989556ce8b
--- /dev/null
+++ b/meta/recipes-multimedia/gstreamer/gstreamer1.0-python_1.16.2.bb
@@ -0,0 +1,39 @@
1SUMMARY = "Python bindings for GStreamer 1.0"
2HOMEPAGE = "http://cgit.freedesktop.org/gstreamer/gst-python/"
3SECTION = "multimedia"
4
5LICENSE = "LGPLv2.1"
6LIC_FILES_CHKSUM = "file://COPYING;md5=c34deae4e395ca07e725ab0076a5f740"
7
8SRC_URI = "https://gstreamer.freedesktop.org/src/${PNREAL}/${PNREAL}-${PV}.tar.xz \
9 file://0001-meson.build-fix-builds-with-python-3.8.patch \
10 "
11SRC_URI[md5sum] = "6ac709767334d8d0a71cb4e016f6abeb"
12SRC_URI[sha256sum] = "208df3148d73d9f416d016564737585d8ea763d91201732d44b5fe688c6288a8"
13
14DEPENDS = "gstreamer1.0 python3-pygobject"
15RDEPENDS_${PN} += "gstreamer1.0 python3-pygobject"
16
17PNREAL = "gst-python"
18
19S = "${WORKDIR}/${PNREAL}-${PV}"
20
21# gobject-introspection is mandatory and cannot be configured
22REQUIRED_DISTRO_FEATURES = "gobject-introspection-data"
23UNKNOWN_CONFIGURE_WHITELIST_append = " --enable-introspection --disable-introspection"
24
25inherit autotools pkgconfig distutils3-base upstream-version-is-even gobject-introspection distro_features_check
26
27EXTRA_OECONF += "--with-libpython-dir=${libdir}"
28
29do_install_append() {
30
31 # Note that this particular find line is taken from the Debian packaging for
32 # gst-python1.0.
33 find "${D}" \
34 -name '*.pyc' -o \
35 -name '*.pyo' -o \
36 -name '*.la' -o \
37 -name 'libgstpythonplugin*' \
38 -delete
39}