summaryrefslogtreecommitdiffstats
path: root/meta/recipes-multimedia/gstreamer/gstreamer1.0-python_1.16.0.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-multimedia/gstreamer/gstreamer1.0-python_1.16.0.bb')
-rw-r--r--meta/recipes-multimedia/gstreamer/gstreamer1.0-python_1.16.0.bb43
1 files changed, 43 insertions, 0 deletions
diff --git a/meta/recipes-multimedia/gstreamer/gstreamer1.0-python_1.16.0.bb b/meta/recipes-multimedia/gstreamer/gstreamer1.0-python_1.16.0.bb
new file mode 100644
index 0000000000..af9f3f213b
--- /dev/null
+++ b/meta/recipes-multimedia/gstreamer/gstreamer1.0-python_1.16.0.bb
@@ -0,0 +1,43 @@
1SUMMARY = "Python bindings for GStreamer 1.0"
2HOMEPAGE = "http://cgit.freedesktop.org/gstreamer/gst-python/"
3SECTION = "multimedia"
4
5LICENSE = "LGPLv2.1"
6LIC_FILES_CHKSUM = "file://COPYING;md5=c34deae4e395ca07e725ab0076a5f740"
7
8SRC_URI = "http://gstreamer.freedesktop.org/src/${PNREAL}/${PNREAL}-${PV}.tar.xz"
9SRC_URI[md5sum] = "877b2ed2aaffdb62e63f38ea9469b70f"
10SRC_URI[sha256sum] = "55dc7aaed1855565f9b9ef842d93e93bfc5cb2b376faef6af5b463e1774e2d38"
11
12DEPENDS = "gstreamer1.0 python3-pygobject"
13RDEPENDS_${PN} += "gstreamer1.0 python3-pygobject"
14
15PNREAL = "gst-python"
16
17S = "${WORKDIR}/${PNREAL}-${PV}"
18
19# gobject-introspection is mandatory and cannot be configured
20REQUIRED_DISTRO_FEATURES = "gobject-introspection-data"
21UNKNOWN_CONFIGURE_WHITELIST_append = " --enable-introspection --disable-introspection"
22
23inherit autotools pkgconfig distutils3-base upstream-version-is-even gobject-introspection distro_features_check
24
25do_install_append() {
26 # gstpythonplugin hardcodes the location of the libpython from the build
27 # workspace and then fails at runtime. We can override it using
28 # --with-libpython-dir=${libdir}, but it still fails because it looks for a
29 # symlinked library ending in .so instead of the actually library with
30 # LIBNAME.so.MAJOR.MINOR. Although we could patch the code to use the path
31 # we want, it will break again if the library version ever changes. We need
32 # to think about the best way of handling this and possibly consult
33 # upstream.
34 #
35 # Note that this particular find line is taken from the Debian packaging for
36 # gst-python1.0.
37 find "${D}" \
38 -name '*.pyc' -o \
39 -name '*.pyo' -o \
40 -name '*.la' -o \
41 -name 'libgstpythonplugin*' \
42 -delete
43}