summaryrefslogtreecommitdiffstats
path: root/meta/recipes-multimedia/gstreamer/gstreamer1.0-python_1.14.4.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-multimedia/gstreamer/gstreamer1.0-python_1.14.4.bb')
-rw-r--r--meta/recipes-multimedia/gstreamer/gstreamer1.0-python_1.14.4.bb39
1 files changed, 39 insertions, 0 deletions
diff --git a/meta/recipes-multimedia/gstreamer/gstreamer1.0-python_1.14.4.bb b/meta/recipes-multimedia/gstreamer/gstreamer1.0-python_1.14.4.bb
new file mode 100644
index 0000000000..8d45ca2668
--- /dev/null
+++ b/meta/recipes-multimedia/gstreamer/gstreamer1.0-python_1.14.4.bb
@@ -0,0 +1,39 @@
1SUMMARY = "Python bindings for GStreamer 1.0"
2HOMEPAGE = "http://cgit.freedesktop.org/gstreamer/gst-python/"
3SECTION = "multimedia"
4
5LICENSE = "LGPLv2.1"
6LIC_FILES_CHKSUM = "file://COPYING;md5=c34deae4e395ca07e725ab0076a5f740"
7
8SRC_URI = "http://gstreamer.freedesktop.org/src/${PNREAL}/${PNREAL}-${PV}.tar.xz"
9SRC_URI[md5sum] = "d4c0e3915f547feef49208ee08981e5a"
10SRC_URI[sha256sum] = "d0fdb24f93b6d889f309d2f526b8ea9577e0084ff0a62b4623ef1aed52e85a1b"
11
12DEPENDS = "gstreamer1.0 python3-pygobject"
13RDEPENDS_${PN} += "gstreamer1.0 python3-pygobject"
14
15PNREAL = "gst-python"
16
17S = "${WORKDIR}/${PNREAL}-${PV}"
18
19inherit autotools pkgconfig distutils3-base upstream-version-is-even gobject-introspection
20
21do_install_append() {
22 # gstpythonplugin hardcodes the location of the libpython from the build
23 # workspace and then fails at runtime. We can override it using
24 # --with-libpython-dir=${libdir}, but it still fails because it looks for a
25 # symlinked library ending in .so instead of the actually library with
26 # LIBNAME.so.MAJOR.MINOR. Although we could patch the code to use the path
27 # we want, it will break again if the library version ever changes. We need
28 # to think about the best way of handling this and possibly consult
29 # upstream.
30 #
31 # Note that this particular find line is taken from the Debian packaging for
32 # gst-python1.0.
33 find "${D}" \
34 -name '*.pyc' -o \
35 -name '*.pyo' -o \
36 -name '*.la' -o \
37 -name 'libgstpythonplugin*' \
38 -delete
39}