summaryrefslogtreecommitdiffstats
path: root/meta/recipes-multimedia/gstreamer/gstreamer1.0-plugins-good_1.16.2.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-multimedia/gstreamer/gstreamer1.0-plugins-good_1.16.2.bb')
-rw-r--r--meta/recipes-multimedia/gstreamer/gstreamer1.0-plugins-good_1.16.2.bb76
1 files changed, 76 insertions, 0 deletions
diff --git a/meta/recipes-multimedia/gstreamer/gstreamer1.0-plugins-good_1.16.2.bb b/meta/recipes-multimedia/gstreamer/gstreamer1.0-plugins-good_1.16.2.bb
new file mode 100644
index 0000000000..ea0cbddc72
--- /dev/null
+++ b/meta/recipes-multimedia/gstreamer/gstreamer1.0-plugins-good_1.16.2.bb
@@ -0,0 +1,76 @@
1require gstreamer1.0-plugins.inc
2
3SRC_URI = " \
4 https://gstreamer.freedesktop.org/src/gst-plugins-good/gst-plugins-good-${PV}.tar.xz \
5 file://0001-introspection.m4-prefix-pkgconfig-paths-with-PKG_CON.patch \
6 "
7
8SRC_URI[md5sum] = "bd025f8f14974f94b75ac69a9d1b9c93"
9SRC_URI[sha256sum] = "40bb3bafda25c0b739c8fc36e48380fccf61c4d3f83747e97ac3f9b0171b1319"
10
11S = "${WORKDIR}/gst-plugins-good-${PV}"
12
13LICENSE = "GPLv2+ & LGPLv2.1+"
14LIC_FILES_CHKSUM = "file://COPYING;md5=a6f89e2100d9b6cdffcea4f398e37343 \
15 file://common/coverage/coverage-report.pl;beginline=2;endline=17;md5=a4e1830fce078028c8f0974161272607 \
16 file://gst/replaygain/rganalysis.c;beginline=1;endline=23;md5=b60ebefd5b2f5a8e0cab6bfee391a5fe"
17
18DEPENDS += "gstreamer1.0-plugins-base libcap"
19RPROVIDES_${PN}-pulseaudio += "${PN}-pulse"
20RPROVIDES_${PN}-soup += "${PN}-souphttpsrc"
21
22inherit gettext
23
24PACKAGECONFIG ??= " \
25 ${GSTREAMER_ORC} \
26 ${@bb.utils.filter('DISTRO_FEATURES', 'pulseaudio x11', d)} \
27 bz2 cairo flac gdk-pixbuf gudev jpeg lame libpng mpg123 soup speex taglib v4l2 zlib \
28"
29
30X11DEPENDS = "virtual/libx11 libsm libxrender libxfixes libxdamage"
31
32PACKAGECONFIG[bz2] = "--enable-bz2,--disable-bz2,bzip2"
33PACKAGECONFIG[cairo] = "--enable-cairo,--disable-cairo,cairo"
34PACKAGECONFIG[dv1394] = "--enable-dv1394,--disable-dv1394,libiec61883 libavc1394 libraw1394"
35PACKAGECONFIG[flac] = "--enable-flac,--disable-flac,flac"
36PACKAGECONFIG[gdk-pixbuf] = "--enable-gdk_pixbuf,--disable-gdk_pixbuf,gdk-pixbuf"
37PACKAGECONFIG[gtk] = "--enable-gtk3,--disable-gtk3,gtk+3"
38PACKAGECONFIG[gudev] = "--with-gudev,--without-gudev,libgudev"
39PACKAGECONFIG[jack] = "--enable-jack,--disable-jack,jack"
40PACKAGECONFIG[jpeg] = "--enable-jpeg,--disable-jpeg,jpeg"
41PACKAGECONFIG[lame] = "--enable-lame,--disable-lame,lame"
42PACKAGECONFIG[libpng] = "--enable-libpng,--disable-libpng,libpng"
43PACKAGECONFIG[libv4l2] = "--with-libv4l2,--without-libv4l2,v4l-utils"
44PACKAGECONFIG[mpg123] = "--enable-mpg123,--disable-mpg123,mpg123"
45PACKAGECONFIG[pulseaudio] = "--enable-pulse,--disable-pulse,pulseaudio"
46PACKAGECONFIG[soup] = "--enable-soup,--disable-soup,libsoup-2.4"
47PACKAGECONFIG[speex] = "--enable-speex,--disable-speex,speex"
48PACKAGECONFIG[taglib] = "--enable-taglib,--disable-taglib,taglib"
49PACKAGECONFIG[v4l2] = "--enable-gst_v4l2 --enable-v4l2-probe,--disable-gst_v4l2"
50PACKAGECONFIG[vpx] = "--enable-vpx,--disable-vpx,libvpx"
51PACKAGECONFIG[wavpack] = "--enable-wavpack,--disable-wavpack,wavpack"
52PACKAGECONFIG[x11] = "--enable-x,--disable-x,${X11DEPENDS}"
53PACKAGECONFIG[zlib] = "--enable-zlib,--disable-zlib,zlib"
54
55# qt5 support is disabled, because it is not present in OE core, and requires more work than
56# just adding a packageconfig (it requires access to moc, uic, rcc, and qmake paths).
57# This is better done in a separate qt5 layer (which then should add a "qt5" packageconfig
58# in a gstreamer1.0-plugins-good bbappend).
59
60EXTRA_OECONF += " \
61 --enable-oss \
62 --disable-aalib \
63 --disable-aalibtest \
64 --disable-directsound \
65 --disable-libcaca \
66 --disable-libdv \
67 --disable-oss4 \
68 --disable-osx_audio \
69 --disable-osx_video \
70 --disable-qt \
71 --disable-shout2 \
72 --disable-twolame \
73 --disable-waveform \
74"
75
76FILES_${PN}-equalizer += "${datadir}/gstreamer-1.0/presets/*.prs"