summaryrefslogtreecommitdiffstats
path: root/meta/recipes-multimedia/gstreamer/gstreamer1.0-plugins-good_1.14.1.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-multimedia/gstreamer/gstreamer1.0-plugins-good_1.14.1.bb')
-rw-r--r--meta/recipes-multimedia/gstreamer/gstreamer1.0-plugins-good_1.14.1.bb79
1 files changed, 79 insertions, 0 deletions
diff --git a/meta/recipes-multimedia/gstreamer/gstreamer1.0-plugins-good_1.14.1.bb b/meta/recipes-multimedia/gstreamer/gstreamer1.0-plugins-good_1.14.1.bb
new file mode 100644
index 0000000000..36eb3107ae
--- /dev/null
+++ b/meta/recipes-multimedia/gstreamer/gstreamer1.0-plugins-good_1.14.1.bb
@@ -0,0 +1,79 @@
1require gstreamer1.0-plugins.inc
2
3SRC_URI = " \
4 http://gstreamer.freedesktop.org/src/gst-plugins-good/gst-plugins-good-${PV}.tar.xz \
5 file://0001-gstrtpmp4gpay-set-dafault-value-for-MPEG4-without-co.patch \
6 file://avoid-including-sys-poll.h-directly.patch \
7 file://ensure-valid-sentinel-for-gst_structure_get.patch \
8 file://0001-introspection.m4-prefix-pkgconfig-paths-with-PKG_CON.patch \
9 "
10
11SRC_URI[md5sum] = "9afe4dd6678cdbd19d8b316c90d6717a"
12SRC_URI[sha256sum] = "34ec062ddb766a32377532e039781f4a16fbc3e8b449e642605bacab26a99172"
13
14S = "${WORKDIR}/gst-plugins-good-${PV}"
15
16LICENSE = "GPLv2+ & LGPLv2.1+"
17LIC_FILES_CHKSUM = "file://COPYING;md5=a6f89e2100d9b6cdffcea4f398e37343 \
18 file://common/coverage/coverage-report.pl;beginline=2;endline=17;md5=a4e1830fce078028c8f0974161272607 \
19 file://gst/replaygain/rganalysis.c;beginline=1;endline=23;md5=b60ebefd5b2f5a8e0cab6bfee391a5fe"
20
21DEPENDS += "gstreamer1.0-plugins-base libcap"
22RPROVIDES_${PN}-pulseaudio += "${PN}-pulse"
23RPROVIDES_${PN}-soup += "${PN}-souphttpsrc"
24
25inherit gettext
26
27PACKAGECONFIG ??= " \
28 ${GSTREAMER_ORC} \
29 ${@bb.utils.filter('DISTRO_FEATURES', 'pulseaudio x11', d)} \
30 ${@bb.utils.contains_any('DISTRO_FEATURES', d.getVar('GTK3DISTROFEATURES'), 'gtk', '', d)} \
31 cairo flac gdk-pixbuf gudev jpeg libpng soup speex taglib v4l2 bz2 zlib mpg123 lame \
32"
33
34X11DEPENDS = "virtual/libx11 libsm libxrender libxfixes libxdamage"
35
36PACKAGECONFIG[cairo] = "--enable-cairo,--disable-cairo,cairo"
37PACKAGECONFIG[dv1394] = "--enable-dv1394,--disable-dv1394,libiec61883 libavc1394 libraw1394"
38PACKAGECONFIG[flac] = "--enable-flac,--disable-flac,flac"
39PACKAGECONFIG[gdk-pixbuf] = "--enable-gdk_pixbuf,--disable-gdk_pixbuf,gdk-pixbuf"
40PACKAGECONFIG[gudev] = "--with-gudev,--without-gudev,libgudev"
41PACKAGECONFIG[jack] = "--enable-jack,--disable-jack,jack"
42PACKAGECONFIG[jpeg] = "--enable-jpeg,--disable-jpeg,jpeg"
43PACKAGECONFIG[libpng] = "--enable-libpng,--disable-libpng,libpng"
44PACKAGECONFIG[libv4l2] = "--with-libv4l2,--without-libv4l2,v4l-utils"
45PACKAGECONFIG[pulseaudio] = "--enable-pulse,--disable-pulse,pulseaudio"
46PACKAGECONFIG[soup] = "--enable-soup,--disable-soup,libsoup-2.4"
47PACKAGECONFIG[speex] = "--enable-speex,--disable-speex,speex"
48PACKAGECONFIG[taglib] = "--enable-taglib,--disable-taglib,taglib"
49PACKAGECONFIG[v4l2] = "--enable-gst_v4l2 --enable-v4l2-probe,--disable-gst_v4l2"
50PACKAGECONFIG[vpx] = "--enable-vpx,--disable-vpx,libvpx"
51PACKAGECONFIG[wavpack] = "--enable-wavpack,--disable-wavpack,wavpack"
52PACKAGECONFIG[x11] = "--enable-x,--disable-x,${X11DEPENDS}"
53PACKAGECONFIG[bz2] = "--enable-bz2,--disable-bz2,bzip2"
54PACKAGECONFIG[zlib] = "--enable-zlib,--disable-zlib,zlib"
55PACKAGECONFIG[lame] = "--enable-lame,--disable-lame,lame"
56PACKAGECONFIG[mpg123] = "--enable-mpg123,--disable-mpg123,mpg123"
57PACKAGECONFIG[gtk] = "--enable-gtk3,--disable-gtk3,gtk+3"
58
59# qt5 support is disabled, because it is not present in OE core, and requires more work than
60# just adding a packageconfig (it requires access to moc, uic, rcc, and qmake paths).
61# This is better done in a separate qt5 layer (which then should add a "qt5" packageconfig
62# in a gstreamer1.0-plugins-good bbappend).
63
64EXTRA_OECONF += " \
65 --enable-oss \
66 --disable-aalib \
67 --disable-aalibtest \
68 --disable-directsound \
69 --disable-libcaca \
70 --disable-libdv \
71 --disable-oss4 \
72 --disable-osx_audio \
73 --disable-osx_video \
74 --disable-shout2 \
75 --disable-waveform \
76 --disable-qt \
77"
78
79FILES_${PN}-equalizer += "${datadir}/gstreamer-1.0/presets/*.prs"