summaryrefslogtreecommitdiffstats
path: root/meta/recipes-multimedia/gstreamer/gstreamer1.0-plugins-base_1.16.3.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-multimedia/gstreamer/gstreamer1.0-plugins-base_1.16.3.bb')
-rw-r--r--meta/recipes-multimedia/gstreamer/gstreamer1.0-plugins-base_1.16.3.bb99
1 files changed, 99 insertions, 0 deletions
diff --git a/meta/recipes-multimedia/gstreamer/gstreamer1.0-plugins-base_1.16.3.bb b/meta/recipes-multimedia/gstreamer/gstreamer1.0-plugins-base_1.16.3.bb
new file mode 100644
index 0000000000..a4f4772c1c
--- /dev/null
+++ b/meta/recipes-multimedia/gstreamer/gstreamer1.0-plugins-base_1.16.3.bb
@@ -0,0 +1,99 @@
1require gstreamer1.0-plugins-common.inc
2
3LICENSE = "GPLv2+ & LGPLv2+"
4LIC_FILES_CHKSUM = "file://COPYING;md5=6762ed442b3822387a51c92d928ead0d \
5 file://common/coverage/coverage-report.pl;beginline=2;endline=17;md5=a4e1830fce078028c8f0974161272607"
6
7SRC_URI = " \
8 https://gstreamer.freedesktop.org/src/gst-plugins-base/gst-plugins-base-${PV}.tar.xz \
9 file://get-caps-from-src-pad-when-query-caps.patch \
10 file://0001-meson-build-gir-even-when-cross-compiling-if-introsp.patch \
11 file://0002-meson-Add-variables-for-gir-files.patch \
12 file://0003-ssaparse-enhance-SSA-text-lines-parsing.patch \
13 file://0005-viv-fb-Make-sure-config.h-is-included.patch \
14 file://0009-glimagesink-Downrank-to-marginal.patch \
15 "
16SRC_URI[md5sum] = "e3ddb1bae9fb510b49a295f212f1e6e4"
17SRC_URI[sha256sum] = "9f02678b0bbbcc9eff107d3bd89d83ce92fec2154cd607c7c8bd34dc7fee491c"
18
19S = "${WORKDIR}/gst-plugins-base-${PV}"
20
21DEPENDS += "iso-codes util-linux zlib"
22
23inherit gobject-introspection gtk-doc
24
25PACKAGES_DYNAMIC =+ "^libgst.*"
26
27# opengl packageconfig factored out to make it easy for distros
28# and BSP layers to choose OpenGL APIs/platforms/window systems
29PACKAGECONFIG_GL ?= "${@bb.utils.contains('DISTRO_FEATURES', 'opengl', 'gles2 egl', '', d)}"
30
31PACKAGECONFIG ??= " \
32 ${GSTREAMER_ORC} \
33 ${PACKAGECONFIG_GL} \
34 ${@bb.utils.filter('DISTRO_FEATURES', 'alsa x11', d)} \
35 jpeg ogg pango png theora vorbis \
36 ${@bb.utils.contains('DISTRO_FEATURES', 'wayland', 'wayland egl', '', d)} \
37"
38
39OPENGL_APIS = 'opengl gles2'
40OPENGL_PLATFORMS = 'egl'
41
42X11DEPENDS = "virtual/libx11 libsm libxrender libxv"
43X11ENABLEOPTS = "-Dx11=enabled -Dxvideo=enabled -Dxshm=enabled"
44X11DISABLEOPTS = "-Dx11=disabled -Dxvideo=disabled -Dxshm=disabled"
45
46PACKAGECONFIG[alsa] = "-Dalsa=enabled,-Dalsa=disabled,alsa-lib"
47PACKAGECONFIG[cdparanoia] = "-Dcdparanoia=enabled,-Dcdparanoia=disabled,cdparanoia"
48PACKAGECONFIG[jpeg] = "-Dgl-jpeg=enabled,-Dgl-jpeg=disabled,jpeg"
49PACKAGECONFIG[ogg] = "-Dogg=enabled,-Dogg=disabled,libogg"
50PACKAGECONFIG[opus] = "-Dopus=enabled,-Dopus=disabled,libopus"
51PACKAGECONFIG[pango] = "-Dpango=enabled,-Dpango=disabled,pango"
52PACKAGECONFIG[png] = "-Dgl-png=enabled,-Dgl-png=disabled,libpng"
53PACKAGECONFIG[theora] = "-Dtheora=enabled,-Dtheora=disabled,libtheora"
54PACKAGECONFIG[tremor] = "-Dtremor=enabled,-Dtremor=disabled,tremor"
55PACKAGECONFIG[visual] = "-Dlibvisual=enabled,-Dlibvisual=disabled,libvisual"
56PACKAGECONFIG[vorbis] = "-Dvorbis=enabled,-Dvorbis=disabled,libvorbis"
57PACKAGECONFIG[x11] = "${X11ENABLEOPTS},${X11DISABLEOPTS},${X11DEPENDS}"
58
59# OpenGL API packageconfigs
60PACKAGECONFIG[opengl] = ",,virtual/libgl libglu"
61PACKAGECONFIG[gles2] = ",,virtual/libgles2"
62
63# OpenGL platform packageconfigs
64PACKAGECONFIG[egl] = ",,virtual/egl"
65
66# OpenGL window systems (except for X11)
67PACKAGECONFIG[gbm] = ",,virtual/libgbm libgudev libdrm"
68PACKAGECONFIG[wayland] = ",,wayland-native wayland wayland-protocols libdrm"
69PACKAGECONFIG[dispmanx] = ",,virtual/libomxil"
70
71OPENGL_WINSYS_append = "${@bb.utils.contains('PACKAGECONFIG', 'x11', ' x11', '', d)}"
72OPENGL_WINSYS_append = "${@bb.utils.contains('PACKAGECONFIG', 'gbm', ' gbm', '', d)}"
73OPENGL_WINSYS_append = "${@bb.utils.contains('PACKAGECONFIG', 'wayland', ' wayland', '', d)}"
74OPENGL_WINSYS_append = "${@bb.utils.contains('PACKAGECONFIG', 'dispmanx', ' dispmanx', '', d)}"
75
76EXTRA_OEMESON += " \
77 -Dgl-graphene=disabled \
78 ${@get_opengl_cmdline_list('gl_api', d.getVar('OPENGL_APIS'), d)} \
79 ${@get_opengl_cmdline_list('gl_platform', d.getVar('OPENGL_PLATFORMS'), d)} \
80 ${@get_opengl_cmdline_list('gl_winsys', d.getVar('OPENGL_WINSYS'), d)} \
81"
82
83GTKDOC_MESON_OPTION = "gtk_doc"
84GTKDOC_MESON_ENABLE_FLAG = "enabled"
85GTKDOC_MESON_DISABLE_FLAG = "disabled"
86
87FILES_${PN}-dev += "${libdir}/gstreamer-1.0/include/gst/gl/gstglconfig.h"
88FILES_${MLPREFIX}libgsttag-1.0 += "${datadir}/gst-plugins-base/1.0/license-translations.dict"
89
90def get_opengl_cmdline_list(switch_name, options, d):
91 selected_options = []
92 if bb.utils.contains('DISTRO_FEATURES', 'opengl', True, False, d):
93 for option in options.split():
94 if bb.utils.contains('PACKAGECONFIG', option, True, False, d):
95 selected_options += [option]
96 if selected_options:
97 return '-D' + switch_name + '=' + ','.join(selected_options)
98 else:
99 return ''