summaryrefslogtreecommitdiffstats
path: root/meta/recipes-multimedia/gstreamer/gstreamer1.0-plugins-base_1.16.2.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-multimedia/gstreamer/gstreamer1.0-plugins-base_1.16.2.bb')
-rw-r--r--meta/recipes-multimedia/gstreamer/gstreamer1.0-plugins-base_1.16.2.bb73
1 files changed, 73 insertions, 0 deletions
diff --git a/meta/recipes-multimedia/gstreamer/gstreamer1.0-plugins-base_1.16.2.bb b/meta/recipes-multimedia/gstreamer/gstreamer1.0-plugins-base_1.16.2.bb
new file mode 100644
index 0000000000..95d3a3679e
--- /dev/null
+++ b/meta/recipes-multimedia/gstreamer/gstreamer1.0-plugins-base_1.16.2.bb
@@ -0,0 +1,73 @@
1require gstreamer1.0-plugins.inc
2
3LICENSE = "GPLv2+ & LGPLv2+"
4LIC_FILES_CHKSUM = "file://COPYING;md5=6762ed442b3822387a51c92d928ead0d \
5 file://common/coverage/coverage-report.pl;beginline=2;endline=17;md5=a4e1830fce078028c8f0974161272607"
6
7SRC_URI = " \
8 https://gstreamer.freedesktop.org/src/gst-plugins-base/gst-plugins-base-${PV}.tar.xz \
9 file://get-caps-from-src-pad-when-query-caps.patch \
10 file://0003-ssaparse-enhance-SSA-text-lines-parsing.patch \
11 file://make-gio_unix_2_0-dependency-configurable.patch \
12 file://0001-introspection.m4-prefix-pkgconfig-paths-with-PKG_CON.patch \
13 file://0002-Makefile.am-prefix-calls-to-pkg-config-with-PKG_CONF.patch \
14 file://0003-riff-add-missing-include-directories-when-calling-in.patch \
15 file://0004-rtsp-drop-incorrect-reference-to-gstreamer-sdp-in-Ma.patch \
16 file://0005-viv-fb-Make-sure-config.h-is-included.patch \
17 file://0009-glimagesink-Downrank-to-marginal.patch \
18 file://0001-gstreamer-gl.pc.in-don-t-append-GL_CFLAGS-to-CFLAGS.patch \
19 file://link-with-libvchostif.patch \
20 "
21SRC_URI[md5sum] = "3fdb32823535799a748c1fc14f978e2c"
22SRC_URI[sha256sum] = "b13e73e2fe74a4166552f9577c3dcb24bed077021b9c7fa600d910ec6987816a"
23
24S = "${WORKDIR}/gst-plugins-base-${PV}"
25
26DEPENDS += "iso-codes util-linux"
27
28inherit gettext gobject-introspection
29
30PACKAGES_DYNAMIC =+ "^libgst.*"
31
32# opengl packageconfig factored out to make it easy for distros
33# and BSP layers to pick either (desktop) opengl, gles2, or no GL
34PACKAGECONFIG_GL ?= "${@bb.utils.contains('DISTRO_FEATURES', 'opengl', 'gles2 egl', '', d)}"
35
36PACKAGECONFIG ??= " \
37 ${GSTREAMER_ORC} \
38 ${PACKAGECONFIG_GL} \
39 ${@bb.utils.filter('DISTRO_FEATURES', 'alsa x11', d)} \
40 gio-unix-2.0 jpeg ogg pango png theora vorbis zlib \
41 ${@bb.utils.contains('DISTRO_FEATURES', 'wayland', 'wayland egl', '', d)} \
42"
43
44X11DEPENDS = "virtual/libx11 libsm libxrender libxv"
45X11ENABLEOPTS = "--enable-x --enable-xvideo --enable-xshm"
46X11DISABLEOPTS = "--disable-x --disable-xvideo --disable-xshm"
47
48PACKAGECONFIG[alsa] = "--enable-alsa,--disable-alsa,alsa-lib"
49PACKAGECONFIG[cdparanoia] = "--enable-cdparanoia,--disable-cdparanoia,cdparanoia"
50PACKAGECONFIG[egl] = "--enable-egl,--disable-egl,virtual/egl"
51PACKAGECONFIG[gbm] = "--enable-gbm,--disable-gbm,virtual/libgbm libgudev libdrm"
52PACKAGECONFIG[gio-unix-2.0] = "--enable-gio_unix_2_0,--disable-gio_unix_2_0,glib-2.0"
53PACKAGECONFIG[gles2] = "--enable-gles2,--disable-gles2,virtual/libgles2"
54PACKAGECONFIG[ivorbis] = "--enable-ivorbis,--disable-ivorbis,tremor"
55PACKAGECONFIG[jpeg] = "--enable-jpeg,--disable-jpeg,jpeg"
56PACKAGECONFIG[ogg] = "--enable-ogg,--disable-ogg,libogg"
57PACKAGECONFIG[opengl] = "--enable-opengl,--disable-opengl,virtual/libgl libglu"
58PACKAGECONFIG[opus] = "--enable-opus,--disable-opus,libopus"
59PACKAGECONFIG[pango] = "--enable-pango,--disable-pango,pango"
60PACKAGECONFIG[png] = "--enable-png,--disable-png,libpng"
61PACKAGECONFIG[theora] = "--enable-theora,--disable-theora,libtheora"
62PACKAGECONFIG[visual] = "--enable-libvisual,--disable-libvisual,libvisual"
63PACKAGECONFIG[vorbis] = "--enable-vorbis,--disable-vorbis,libvorbis"
64PACKAGECONFIG[x11] = "${X11ENABLEOPTS},${X11DISABLEOPTS},${X11DEPENDS}"
65PACKAGECONFIG[wayland] = "--enable-wayland,--disable-wayland,wayland-native wayland wayland-protocols libdrm"
66PACKAGECONFIG[zlib] = "--enable-zlib,--disable-zlib,zlib"
67
68FILES_${PN}-dev += "${libdir}/gstreamer-${LIBV}/include/gst/gl/gstglconfig.h"
69FILES_${MLPREFIX}libgsttag-1.0 += "${datadir}/gst-plugins-base/1.0/license-translations.dict"
70
71do_compile_prepend() {
72 export GIR_EXTRA_LIBS_PATH="${B}/gst-libs/gst/tag/.libs:${B}/gst-libs/gst/video/.libs:${B}/gst-libs/gst/audio/.libs:${B}/gst-libs/gst/rtp/.libs:${B}/gst-libs/gst/allocators/.libs"
73}