summaryrefslogtreecommitdiffstats
path: root/meta/recipes-multimedia/gstreamer/gstreamer1.0-plugins-base_1.16.1.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-multimedia/gstreamer/gstreamer1.0-plugins-base_1.16.1.bb')
-rw-r--r--meta/recipes-multimedia/gstreamer/gstreamer1.0-plugins-base_1.16.1.bb95
1 files changed, 58 insertions, 37 deletions
diff --git a/meta/recipes-multimedia/gstreamer/gstreamer1.0-plugins-base_1.16.1.bb b/meta/recipes-multimedia/gstreamer/gstreamer1.0-plugins-base_1.16.1.bb
index cb99fba5ff..7ce9238c4a 100644
--- a/meta/recipes-multimedia/gstreamer/gstreamer1.0-plugins-base_1.16.1.bb
+++ b/meta/recipes-multimedia/gstreamer/gstreamer1.0-plugins-base_1.16.1.bb
@@ -1,4 +1,4 @@
1require gstreamer1.0-plugins.inc 1require gstreamer1.0-plugins-common.inc
2 2
3LICENSE = "GPLv2+ & LGPLv2+" 3LICENSE = "GPLv2+ & LGPLv2+"
4LIC_FILES_CHKSUM = "file://COPYING;md5=6762ed442b3822387a51c92d928ead0d \ 4LIC_FILES_CHKSUM = "file://COPYING;md5=6762ed442b3822387a51c92d928ead0d \
@@ -7,67 +7,88 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=6762ed442b3822387a51c92d928ead0d \
7SRC_URI = " \ 7SRC_URI = " \
8 https://gstreamer.freedesktop.org/src/gst-plugins-base/gst-plugins-base-${PV}.tar.xz \ 8 https://gstreamer.freedesktop.org/src/gst-plugins-base/gst-plugins-base-${PV}.tar.xz \
9 file://get-caps-from-src-pad-when-query-caps.patch \ 9 file://get-caps-from-src-pad-when-query-caps.patch \
10 file://0001-meson-build-gir-even-when-cross-compiling-if-introsp.patch \
11 file://0002-meson-Add-variables-for-gir-files.patch \
10 file://0003-ssaparse-enhance-SSA-text-lines-parsing.patch \ 12 file://0003-ssaparse-enhance-SSA-text-lines-parsing.patch \
11 file://make-gio_unix_2_0-dependency-configurable.patch \
12 file://0001-introspection.m4-prefix-pkgconfig-paths-with-PKG_CON.patch \
13 file://0002-Makefile.am-prefix-calls-to-pkg-config-with-PKG_CONF.patch \
14 file://0003-riff-add-missing-include-directories-when-calling-in.patch \
15 file://0004-rtsp-drop-incorrect-reference-to-gstreamer-sdp-in-Ma.patch \
16 file://0005-viv-fb-Make-sure-config.h-is-included.patch \ 13 file://0005-viv-fb-Make-sure-config.h-is-included.patch \
17 file://0009-glimagesink-Downrank-to-marginal.patch \ 14 file://0009-glimagesink-Downrank-to-marginal.patch \
18 file://0001-gstreamer-gl.pc.in-don-t-append-GL_CFLAGS-to-CFLAGS.patch \
19 file://link-with-libvchostif.patch \
20 " 15 "
21SRC_URI[md5sum] = "b5eb0651bab70bf1714f103bdd66ce47" 16SRC_URI[md5sum] = "b5eb0651bab70bf1714f103bdd66ce47"
22SRC_URI[sha256sum] = "5c3cc489933d0597087c9bc6ba251c93693d64554bcc563539a084fa2d5fcb2b" 17SRC_URI[sha256sum] = "5c3cc489933d0597087c9bc6ba251c93693d64554bcc563539a084fa2d5fcb2b"
23 18
24S = "${WORKDIR}/gst-plugins-base-${PV}" 19S = "${WORKDIR}/gst-plugins-base-${PV}"
25 20
26DEPENDS += "iso-codes util-linux" 21DEPENDS += "iso-codes util-linux zlib"
27 22
28inherit gettext gobject-introspection 23inherit gobject-introspection gtk-doc
29 24
30PACKAGES_DYNAMIC =+ "^libgst.*" 25PACKAGES_DYNAMIC =+ "^libgst.*"
31 26
32# opengl packageconfig factored out to make it easy for distros 27# opengl packageconfig factored out to make it easy for distros
33# and BSP layers to pick either (desktop) opengl, gles2, or no GL 28# and BSP layers to choose OpenGL APIs/platforms/window systems
34PACKAGECONFIG_GL ?= "${@bb.utils.contains('DISTRO_FEATURES', 'opengl', 'gles2 egl', '', d)}" 29PACKAGECONFIG_GL ?= "${@bb.utils.contains('DISTRO_FEATURES', 'opengl', 'gles2 egl', '', d)}"
35 30
36PACKAGECONFIG ??= " \ 31PACKAGECONFIG ??= " \
37 ${GSTREAMER_ORC} \ 32 ${GSTREAMER_ORC} \
38 ${PACKAGECONFIG_GL} \ 33 ${PACKAGECONFIG_GL} \
39 ${@bb.utils.filter('DISTRO_FEATURES', 'alsa x11', d)} \ 34 ${@bb.utils.filter('DISTRO_FEATURES', 'alsa x11', d)} \
40 gio-unix-2.0 jpeg ogg pango png theora vorbis zlib \ 35 jpeg ogg pango png theora vorbis \
41 ${@bb.utils.contains('DISTRO_FEATURES', 'wayland', 'wayland egl', '', d)} \ 36 ${@bb.utils.contains('DISTRO_FEATURES', 'wayland', 'wayland egl', '', d)} \
42" 37"
43 38
39OPENGL_APIS = 'opengl gles2'
40OPENGL_PLATFORMS = 'egl'
41OPENGL_WINSYS = 'x11 wayland gbm'
42
44X11DEPENDS = "virtual/libx11 libsm libxrender libxv" 43X11DEPENDS = "virtual/libx11 libsm libxrender libxv"
45X11ENABLEOPTS = "--enable-x --enable-xvideo --enable-xshm" 44X11ENABLEOPTS = "-Dx11=enabled -Dxvideo=enabled -Dxshm=enabled"
46X11DISABLEOPTS = "--disable-x --disable-xvideo --disable-xshm" 45X11DISABLEOPTS = "-Dx11=disabled -Dxvideo=disabled -Dxshm=disabled"
47 46
48PACKAGECONFIG[alsa] = "--enable-alsa,--disable-alsa,alsa-lib" 47PACKAGECONFIG[alsa] = "-Dalsa=enabled,-Dalsa=disabled,alsa-lib"
49PACKAGECONFIG[cdparanoia] = "--enable-cdparanoia,--disable-cdparanoia,cdparanoia" 48PACKAGECONFIG[cdparanoia] = "-Dcdparanoia=enabled,-Dcdparanoia=disabled,cdparanoia"
50PACKAGECONFIG[egl] = "--enable-egl,--disable-egl,virtual/egl" 49PACKAGECONFIG[jpeg] = "-Dgl-jpeg=enabled,-Dgl-jpeg=disabled,jpeg"
51PACKAGECONFIG[gbm] = "--enable-gbm,--disable-gbm,virtual/libgbm libgudev libdrm" 50PACKAGECONFIG[ogg] = "-Dogg=enabled,-Dogg=disabled,libogg"
52PACKAGECONFIG[gio-unix-2.0] = "--enable-gio_unix_2_0,--disable-gio_unix_2_0,glib-2.0" 51PACKAGECONFIG[opus] = "-Dopus=enabled,-Dopus=disabled,libopus"
53PACKAGECONFIG[gles2] = "--enable-gles2,--disable-gles2,virtual/libgles2" 52PACKAGECONFIG[pango] = "-Dpango=enabled,-Dpango=disabled,pango"
54PACKAGECONFIG[ivorbis] = "--enable-ivorbis,--disable-ivorbis,tremor" 53PACKAGECONFIG[png] = "-Dgl-png=enabled,-Dgl-png=disabled,libpng"
55PACKAGECONFIG[jpeg] = "--enable-jpeg,--disable-jpeg,jpeg" 54PACKAGECONFIG[theora] = "-Dtheora=enabled,-Dtheora=disabled,libtheora"
56PACKAGECONFIG[ogg] = "--enable-ogg,--disable-ogg,libogg" 55PACKAGECONFIG[tremor] = "-Dtremor=enabled,-Dtremor=disabled,tremor"
57PACKAGECONFIG[opengl] = "--enable-opengl,--disable-opengl,virtual/libgl libglu" 56PACKAGECONFIG[visual] = "-Dlibvisual=enabled,-Dlibvisual=disabled,libvisual"
58PACKAGECONFIG[opus] = "--enable-opus,--disable-opus,libopus" 57PACKAGECONFIG[vorbis] = "-Dvorbis=enabled,-Dvorbis=disabled,libvorbis"
59PACKAGECONFIG[pango] = "--enable-pango,--disable-pango,pango"
60PACKAGECONFIG[png] = "--enable-png,--disable-png,libpng"
61PACKAGECONFIG[theora] = "--enable-theora,--disable-theora,libtheora"
62PACKAGECONFIG[visual] = "--enable-libvisual,--disable-libvisual,libvisual"
63PACKAGECONFIG[vorbis] = "--enable-vorbis,--disable-vorbis,libvorbis"
64PACKAGECONFIG[x11] = "${X11ENABLEOPTS},${X11DISABLEOPTS},${X11DEPENDS}" 58PACKAGECONFIG[x11] = "${X11ENABLEOPTS},${X11DISABLEOPTS},${X11DEPENDS}"
65PACKAGECONFIG[wayland] = "--enable-wayland,--disable-wayland,wayland-native wayland wayland-protocols libdrm"
66PACKAGECONFIG[zlib] = "--enable-zlib,--disable-zlib,zlib"
67 59
68FILES_${PN}-dev += "${libdir}/gstreamer-${LIBV}/include/gst/gl/gstglconfig.h" 60# OpenGL API packageconfigs
61PACKAGECONFIG[opengl] = ",,virtual/libgl libglu"
62PACKAGECONFIG[gles2] = ",,virtual/libgles2"
63
64# OpenGL platform packageconfigs
65PACKAGECONFIG[egl] = ",,virtual/egl"
66
67# OpenGL window systems (except for X11)
68PACKAGECONFIG[gbm] = ",,virtual/libgbm libgudev libdrm"
69PACKAGECONFIG[wayland] = ",,wayland-native wayland wayland-protocols libdrm"
70
71EXTRA_OEMESON += " \
72 -Dgl-graphene=disabled \
73 ${@get_opengl_cmdline_list('gl_api', d.getVar('OPENGL_APIS'), d)} \
74 ${@get_opengl_cmdline_list('gl_platform', d.getVar('OPENGL_PLATFORMS'), d)} \
75 ${@get_opengl_cmdline_list('gl_winsys', d.getVar('OPENGL_WINSYS'), d)} \
76"
77
78GTKDOC_MESON_OPTION = "gtk_doc"
79GTKDOC_MESON_ENABLE_FLAG = "enabled"
80GTKDOC_MESON_DISABLE_FLAG = "disabled"
81
82FILES_${PN}-dev += "${libdir}/gstreamer-1.0/include/gst/gl/gstglconfig.h"
69FILES_${MLPREFIX}libgsttag-1.0 += "${datadir}/gst-plugins-base/1.0/license-translations.dict" 83FILES_${MLPREFIX}libgsttag-1.0 += "${datadir}/gst-plugins-base/1.0/license-translations.dict"
70 84
71do_compile_prepend() { 85def get_opengl_cmdline_list(switch_name, options, d):
72 export GIR_EXTRA_LIBS_PATH="${B}/gst-libs/gst/tag/.libs:${B}/gst-libs/gst/video/.libs:${B}/gst-libs/gst/audio/.libs:${B}/gst-libs/gst/rtp/.libs:${B}/gst-libs/gst/allocators/.libs" 86 selected_options = []
73} 87 if bb.utils.contains('DISTRO_FEATURES', 'opengl', True, False, d):
88 for option in options.split():
89 if bb.utils.contains('PACKAGECONFIG', option, True, False, d):
90 selected_options += [option]
91 if selected_options:
92 return '-D' + switch_name + '=' + ','.join(selected_options)
93 else:
94 return ''