diff options
Diffstat (limited to 'meta/recipes-multimedia/gstreamer/gstreamer1.0-plugins-base_1.14.4.bb')
-rw-r--r-- | meta/recipes-multimedia/gstreamer/gstreamer1.0-plugins-base_1.14.4.bb | 76 |
1 files changed, 76 insertions, 0 deletions
diff --git a/meta/recipes-multimedia/gstreamer/gstreamer1.0-plugins-base_1.14.4.bb b/meta/recipes-multimedia/gstreamer/gstreamer1.0-plugins-base_1.14.4.bb new file mode 100644 index 0000000000..12c9bbce9d --- /dev/null +++ b/meta/recipes-multimedia/gstreamer/gstreamer1.0-plugins-base_1.14.4.bb | |||
@@ -0,0 +1,76 @@ | |||
1 | require gstreamer1.0-plugins.inc | ||
2 | |||
3 | LICENSE = "GPLv2+ & LGPLv2+" | ||
4 | LIC_FILES_CHKSUM = "file://COPYING;md5=c54ce9345727175ff66d17b67ff51f58 \ | ||
5 | file://COPYING.LIB;md5=6762ed442b3822387a51c92d928ead0d \ | ||
6 | file://common/coverage/coverage-report.pl;beginline=2;endline=17;md5=a4e1830fce078028c8f0974161272607" | ||
7 | |||
8 | SRC_URI = " \ | ||
9 | http://gstreamer.freedesktop.org/src/gst-plugins-base/gst-plugins-base-${PV}.tar.xz \ | ||
10 | file://get-caps-from-src-pad-when-query-caps.patch \ | ||
11 | file://0003-ssaparse-enhance-SSA-text-lines-parsing.patch \ | ||
12 | file://make-gio_unix_2_0-dependency-configurable.patch \ | ||
13 | file://0001-introspection.m4-prefix-pkgconfig-paths-with-PKG_CON.patch \ | ||
14 | file://0001-Makefile.am-don-t-hardcode-libtool-name-when-running.patch \ | ||
15 | file://0002-Makefile.am-prefix-calls-to-pkg-config-with-PKG_CONF.patch \ | ||
16 | file://0003-riff-add-missing-include-directories-when-calling-in.patch \ | ||
17 | file://0004-rtsp-drop-incorrect-reference-to-gstreamer-sdp-in-Ma.patch \ | ||
18 | file://0009-glimagesink-Downrank-to-marginal.patch \ | ||
19 | file://0001-gstreamer-gl.pc.in-don-t-append-GL_CFLAGS-to-CFLAGS.patch \ | ||
20 | file://0010-gl-Add-switch-for-explicitely-enabling-disabling-GBM.patch \ | ||
21 | file://0011-gl-Add-switches-for-explicitely-enabling-disabling-P.patch \ | ||
22 | file://link-with-libvchostif.patch \ | ||
23 | " | ||
24 | SRC_URI[md5sum] = "4dbe20c1bf44191c2b8833234df5cb2a" | ||
25 | SRC_URI[sha256sum] = "ca6139490e48863e7706d870ff4e8ac9f417b56f3b9e4b3ce490c13b09a77461" | ||
26 | |||
27 | S = "${WORKDIR}/gst-plugins-base-${PV}" | ||
28 | |||
29 | DEPENDS += "iso-codes util-linux" | ||
30 | |||
31 | inherit gettext | ||
32 | |||
33 | PACKAGES_DYNAMIC =+ "^libgst.*" | ||
34 | |||
35 | # opengl packageconfig factored out to make it easy for distros | ||
36 | # and BSP layers to pick either (desktop) opengl, gles2, or no GL | ||
37 | PACKAGECONFIG_GL ?= "${@bb.utils.contains('DISTRO_FEATURES', 'opengl', 'gles2 egl', '', d)}" | ||
38 | |||
39 | PACKAGECONFIG ??= " \ | ||
40 | ${GSTREAMER_ORC} \ | ||
41 | ${PACKAGECONFIG_GL} \ | ||
42 | ${@bb.utils.filter('DISTRO_FEATURES', 'alsa x11', d)} \ | ||
43 | gio-unix-2.0 jpeg ogg pango png theora vorbis zlib \ | ||
44 | ${@bb.utils.contains('DISTRO_FEATURES', 'wayland', 'wayland egl', '', d)} \ | ||
45 | " | ||
46 | |||
47 | X11DEPENDS = "virtual/libx11 libsm libxrender libxv" | ||
48 | X11ENABLEOPTS = "--enable-x --enable-xvideo --enable-xshm" | ||
49 | X11DISABLEOPTS = "--disable-x --disable-xvideo --disable-xshm" | ||
50 | |||
51 | PACKAGECONFIG[alsa] = "--enable-alsa,--disable-alsa,alsa-lib" | ||
52 | PACKAGECONFIG[cdparanoia] = "--enable-cdparanoia,--disable-cdparanoia,cdparanoia" | ||
53 | PACKAGECONFIG[egl] = "--enable-egl,--disable-egl,virtual/egl" | ||
54 | PACKAGECONFIG[gbm] = "--enable-gbm,--disable-gbm,virtual/libgbm libgudev libdrm" | ||
55 | PACKAGECONFIG[gio-unix-2.0] = "--enable-gio_unix_2_0,--disable-gio_unix_2_0,glib-2.0" | ||
56 | PACKAGECONFIG[gles2] = "--enable-gles2,--disable-gles2,virtual/libgles2" | ||
57 | PACKAGECONFIG[ivorbis] = "--enable-ivorbis,--disable-ivorbis,tremor" | ||
58 | PACKAGECONFIG[jpeg] = "--enable-jpeg,--disable-jpeg,jpeg" | ||
59 | PACKAGECONFIG[ogg] = "--enable-ogg,--disable-ogg,libogg" | ||
60 | PACKAGECONFIG[opengl] = "--enable-opengl,--disable-opengl,virtual/libgl libglu" | ||
61 | PACKAGECONFIG[opus] = "--enable-opus,--disable-opus,libopus" | ||
62 | PACKAGECONFIG[pango] = "--enable-pango,--disable-pango,pango" | ||
63 | PACKAGECONFIG[png] = "--enable-png,--disable-png,libpng" | ||
64 | PACKAGECONFIG[theora] = "--enable-theora,--disable-theora,libtheora" | ||
65 | PACKAGECONFIG[visual] = "--enable-libvisual,--disable-libvisual,libvisual" | ||
66 | PACKAGECONFIG[vorbis] = "--enable-vorbis,--disable-vorbis,libvorbis" | ||
67 | PACKAGECONFIG[x11] = "${X11ENABLEOPTS},${X11DISABLEOPTS},${X11DEPENDS}" | ||
68 | PACKAGECONFIG[wayland] = "--enable-wayland,--disable-wayland,wayland-native wayland wayland-protocols libdrm" | ||
69 | PACKAGECONFIG[zlib] = "--enable-zlib,--disable-zlib,zlib" | ||
70 | |||
71 | FILES_${PN}-dev += "${libdir}/gstreamer-${LIBV}/include/gst/gl/gstglconfig.h" | ||
72 | FILES_${MLPREFIX}libgsttag-1.0 += "${datadir}/gst-plugins-base/1.0/license-translations.dict" | ||
73 | |||
74 | do_compile_prepend() { | ||
75 | export GIR_EXTRA_LIBS_PATH="${B}/gst-libs/gst/tag/.libs:${B}/gst-libs/gst/video/.libs:${B}/gst-libs/gst/audio/.libs:${B}/gst-libs/gst/rtp/.libs:${B}/gst-libs/gst/allocators/.libs" | ||
76 | } | ||