summaryrefslogtreecommitdiffstats
path: root/meta/recipes-multimedia/gstreamer/gstreamer1.0-plugins-base_1.14.1.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-multimedia/gstreamer/gstreamer1.0-plugins-base_1.14.1.bb')
-rw-r--r--meta/recipes-multimedia/gstreamer/gstreamer1.0-plugins-base_1.14.1.bb70
1 files changed, 70 insertions, 0 deletions
diff --git a/meta/recipes-multimedia/gstreamer/gstreamer1.0-plugins-base_1.14.1.bb b/meta/recipes-multimedia/gstreamer/gstreamer1.0-plugins-base_1.14.1.bb
new file mode 100644
index 0000000000..8d7d3c6192
--- /dev/null
+++ b/meta/recipes-multimedia/gstreamer/gstreamer1.0-plugins-base_1.14.1.bb
@@ -0,0 +1,70 @@
1require gstreamer1.0-plugins.inc
2
3LICENSE = "GPLv2+ & LGPLv2+"
4LIC_FILES_CHKSUM = "file://COPYING;md5=c54ce9345727175ff66d17b67ff51f58 \
5 file://COPYING.LIB;md5=6762ed442b3822387a51c92d928ead0d \
6 file://common/coverage/coverage-report.pl;beginline=2;endline=17;md5=a4e1830fce078028c8f0974161272607"
7
8SRC_URI = " \
9 http://gstreamer.freedesktop.org/src/gst-plugins-base/gst-plugins-base-${PV}.tar.xz \
10 file://get-caps-from-src-pad-when-query-caps.patch \
11 file://0003-ssaparse-enhance-SSA-text-lines-parsing.patch \
12 file://make-gio_unix_2_0-dependency-configurable.patch \
13 file://0001-introspection.m4-prefix-pkgconfig-paths-with-PKG_CON.patch \
14 file://0001-Makefile.am-don-t-hardcode-libtool-name-when-running.patch \
15 file://0002-Makefile.am-prefix-calls-to-pkg-config-with-PKG_CONF.patch \
16 file://0003-riff-add-missing-include-directories-when-calling-in.patch \
17 file://0004-rtsp-drop-incorrect-reference-to-gstreamer-sdp-in-Ma.patch \
18 file://0009-glimagesink-Downrank-to-marginal.patch \
19 file://0001-gstreamer-gl.pc.in-don-t-append-GL_CFLAGS-to-CFLAGS.patch \
20 file://link-with-libvchostif.patch \
21 "
22SRC_URI[md5sum] = "c42154ab6f85c59f0e449d8d7e290342"
23SRC_URI[sha256sum] = "1026c7c3082d825d9b5d034c1a6dd8a4ebab60eb3738b0a0afde4ad2dc0b0db5"
24
25S = "${WORKDIR}/gst-plugins-base-${PV}"
26
27DEPENDS += "iso-codes util-linux"
28
29inherit gettext
30
31PACKAGES_DYNAMIC =+ "^libgst.*"
32
33PACKAGECONFIG_GL ?= "${@bb.utils.contains('DISTRO_FEATURES', 'opengl', 'gles2 egl', '', d)}"
34PACKAGECONFIG ??= " \
35 ${GSTREAMER_ORC} \
36 ${@bb.utils.filter('DISTRO_FEATURES', 'alsa x11', d)} \
37 gio-unix-2.0 ogg pango theora vorbis zlib jpeg \
38 ${PACKAGECONFIG_GL} \
39 ${@bb.utils.contains('DISTRO_FEATURES', 'wayland', 'wayland egl', '', d)} \
40"
41
42X11DEPENDS = "virtual/libx11 libsm libxrender libxv"
43X11ENABLEOPTS = "--enable-x --enable-xvideo --enable-xshm"
44X11DISABLEOPTS = "--disable-x --disable-xvideo --disable-xshm"
45
46PACKAGECONFIG[alsa] = "--enable-alsa,--disable-alsa,alsa-lib"
47PACKAGECONFIG[cdparanoia] = "--enable-cdparanoia,--disable-cdparanoia,cdparanoia"
48PACKAGECONFIG[gio-unix-2.0] = "--enable-gio_unix_2_0,--disable-gio_unix_2_0,glib-2.0"
49PACKAGECONFIG[ivorbis] = "--enable-ivorbis,--disable-ivorbis,tremor"
50PACKAGECONFIG[ogg] = "--enable-ogg,--disable-ogg,libogg"
51PACKAGECONFIG[opus] = "--enable-opus,--disable-opus,libopus"
52PACKAGECONFIG[pango] = "--enable-pango,--disable-pango,pango"
53PACKAGECONFIG[theora] = "--enable-theora,--disable-theora,libtheora"
54PACKAGECONFIG[visual] = "--enable-libvisual,--disable-libvisual,libvisual"
55PACKAGECONFIG[vorbis] = "--enable-vorbis,--disable-vorbis,libvorbis"
56PACKAGECONFIG[x11] = "${X11ENABLEOPTS},${X11DISABLEOPTS},${X11DEPENDS}"
57PACKAGECONFIG[zlib] = "--enable-zlib,--disable-zlib,zlib"
58PACKAGECONFIG[opengl] = "--enable-opengl,--disable-opengl,virtual/libgl libglu"
59PACKAGECONFIG[gles2] = "--enable-gles2,--disable-gles2,virtual/libgles2"
60PACKAGECONFIG[egl] = "--enable-egl,--disable-egl,virtual/egl"
61PACKAGECONFIG[wayland] = "--enable-wayland,--disable-wayland,wayland-native wayland wayland-protocols libdrm"
62PACKAGECONFIG[jpeg] = ",,jpeg"
63
64FILES_${MLPREFIX}libgsttag-1.0 += "${datadir}/gst-plugins-base/1.0/license-translations.dict"
65
66do_compile_prepend() {
67 export GIR_EXTRA_LIBS_PATH="${B}/gst-libs/gst/tag/.libs:${B}/gst-libs/gst/video/.libs:${B}/gst-libs/gst/audio/.libs:${B}/gst-libs/gst/rtp/.libs:${B}/gst-libs/gst/allocators/.libs"
68}
69
70FILES_${PN}-dev += "${libdir}/gstreamer-${LIBV}/include/gst/gl/gstglconfig.h"