summaryrefslogtreecommitdiffstats
path: root/meta/recipes-multimedia/gstreamer/gstreamer1.0-plugins-bad_1.18.6.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-multimedia/gstreamer/gstreamer1.0-plugins-bad_1.18.6.bb')
-rw-r--r--meta/recipes-multimedia/gstreamer/gstreamer1.0-plugins-bad_1.18.6.bb151
1 files changed, 151 insertions, 0 deletions
diff --git a/meta/recipes-multimedia/gstreamer/gstreamer1.0-plugins-bad_1.18.6.bb b/meta/recipes-multimedia/gstreamer/gstreamer1.0-plugins-bad_1.18.6.bb
new file mode 100644
index 0000000000..63e3488e9e
--- /dev/null
+++ b/meta/recipes-multimedia/gstreamer/gstreamer1.0-plugins-bad_1.18.6.bb
@@ -0,0 +1,151 @@
1require gstreamer1.0-plugins-common.inc
2
3DESCRIPTION = "'Bad' GStreamer plugins and helper libraries "
4HOMEPAGE = "https://gstreamer.freedesktop.org/"
5BUGTRACKER = "https://gitlab.freedesktop.org/gstreamer/gst-plugins-bad/-/issues"
6
7SRC_URI = "https://gstreamer.freedesktop.org/src/gst-plugins-bad/gst-plugins-bad-${PV}.tar.xz \
8 file://0001-fix-maybe-uninitialized-warnings-when-compiling-with.patch \
9 file://0002-avoid-including-sys-poll.h-directly.patch \
10 file://0003-ensure-valid-sentinals-for-gst_structure_get-etc.patch \
11 file://0004-opencv-resolve-missing-opencv-data-dir-in-yocto-buil.patch \
12 file://0005-msdk-fix-includedir-path.patch \
13 "
14SRC_URI[sha256sum] = "0b1b50ac6311f0c510248b6cd64d6d3c94369344828baa602db85ded5bc70ec9"
15
16S = "${WORKDIR}/gst-plugins-bad-${PV}"
17
18LICENSE = "GPLv2+ & LGPLv2+ & LGPLv2.1+"
19LIC_FILES_CHKSUM = "file://COPYING;md5=4fbd65380cdd255951079008b364516c"
20
21DEPENDS += "gstreamer1.0-plugins-base"
22
23inherit gobject-introspection
24
25PACKAGECONFIG ??= " \
26 ${GSTREAMER_ORC} \
27 ${@bb.utils.contains('DISTRO_FEATURES', 'bluetooth', 'bluez', '', d)} \
28 ${@bb.utils.filter('DISTRO_FEATURES', 'directfb vulkan', d)} \
29 ${@bb.utils.contains('DISTRO_FEATURES', 'wayland', 'wayland', '', d)} \
30 ${@bb.utils.contains('DISTRO_FEATURES', 'opengl', 'gl', '', d)} \
31 bz2 closedcaption curl dash dtls hls rsvg sbc smoothstreaming sndfile \
32 ttml uvch264 webp \
33"
34
35PACKAGECONFIG[aom] = "-Daom=enabled,-Daom=disabled,aom"
36PACKAGECONFIG[assrender] = "-Dassrender=enabled,-Dassrender=disabled,libass"
37PACKAGECONFIG[bluez] = "-Dbluez=enabled,-Dbluez=disabled,bluez5"
38PACKAGECONFIG[bz2] = "-Dbz2=enabled,-Dbz2=disabled,bzip2"
39PACKAGECONFIG[closedcaption] = "-Dclosedcaption=enabled,-Dclosedcaption=disabled,pango cairo"
40PACKAGECONFIG[curl] = "-Dcurl=enabled,-Dcurl=disabled,curl"
41PACKAGECONFIG[dash] = "-Ddash=enabled,-Ddash=disabled,libxml2"
42PACKAGECONFIG[dc1394] = "-Ddc1394=enabled,-Ddc1394=disabled,libdc1394"
43PACKAGECONFIG[directfb] = "-Ddirectfb=enabled,-Ddirectfb=disabled,directfb"
44PACKAGECONFIG[dtls] = "-Ddtls=enabled,-Ddtls=disabled,openssl"
45PACKAGECONFIG[faac] = "-Dfaac=enabled,-Dfaac=disabled,faac"
46PACKAGECONFIG[faad] = "-Dfaad=enabled,-Dfaad=disabled,faad2"
47PACKAGECONFIG[fluidsynth] = "-Dfluidsynth=enabled,-Dfluidsynth=disabled,fluidsynth"
48PACKAGECONFIG[hls] = "-Dhls=enabled -Dhls-crypto=nettle,-Dhls=disabled,nettle"
49# the gl packageconfig enables OpenGL elements that haven't been ported
50# to -base yet. They depend on the gstgl library in -base, so we do
51# not add GL dependencies here, since these are taken care of in -base.
52PACKAGECONFIG[gl] = "-Dgl=enabled,-Dgl=disabled,"
53PACKAGECONFIG[kms] = "-Dkms=enabled,-Dkms=disabled,libdrm"
54PACKAGECONFIG[libde265] = "-Dlibde265=enabled,-Dlibde265=disabled,libde265"
55PACKAGECONFIG[libmms] = "-Dlibmms=enabled,-Dlibmms=disabled,libmms"
56PACKAGECONFIG[libssh2] = "-Dcurl-ssh2=enabled,-Dcurl-ssh2=disabled,libssh2"
57PACKAGECONFIG[lcms2] = "-Dcolormanagement=enabled,-Dcolormanagement=disabled,lcms"
58PACKAGECONFIG[modplug] = "-Dmodplug=enabled,-Dmodplug=disabled,libmodplug"
59PACKAGECONFIG[msdk] = "-Dmsdk=enabled,-Dmsdk=disabled,intel-mediasdk"
60PACKAGECONFIG[neon] = "-Dneon=enabled,-Dneon=disabled,neon"
61PACKAGECONFIG[openal] = "-Dopenal=enabled,-Dopenal=disabled,openal-soft"
62PACKAGECONFIG[opencv] = "-Dopencv=enabled,-Dopencv=disabled,opencv"
63PACKAGECONFIG[openh264] = "-Dopenh264=enabled,-Dopenh264=disabled,openh264"
64PACKAGECONFIG[openjpeg] = "-Dopenjpeg=enabled,-Dopenjpeg=disabled,openjpeg"
65PACKAGECONFIG[openmpt] = "-Dopenmpt=enabled,-Dopenmpt=disabled,libopenmpt"
66# the opus encoder/decoder elements are now in the -base package,
67# but the opus parser remains in -bad
68PACKAGECONFIG[opusparse] = "-Dopus=enabled,-Dopus=disabled,libopus"
69PACKAGECONFIG[resindvd] = "-Dresindvd=enabled,-Dresindvd=disabled,libdvdread libdvdnav"
70PACKAGECONFIG[rsvg] = "-Drsvg=enabled,-Drsvg=disabled,librsvg"
71PACKAGECONFIG[rtmp] = "-Drtmp=enabled,-Drtmp=disabled,rtmpdump"
72PACKAGECONFIG[sbc] = "-Dsbc=enabled,-Dsbc=disabled,sbc"
73PACKAGECONFIG[sctp] = "-Dsctp=enabled,-Dsctp=disabled"
74PACKAGECONFIG[smoothstreaming] = "-Dsmoothstreaming=enabled,-Dsmoothstreaming=disabled,libxml2"
75PACKAGECONFIG[sndfile] = "-Dsndfile=enabled,-Dsndfile=disabled,libsndfile1"
76PACKAGECONFIG[srt] = "-Dsrt=enabled,-Dsrt=disabled,srt"
77PACKAGECONFIG[srtp] = "-Dsrtp=enabled,-Dsrtp=disabled,libsrtp"
78PACKAGECONFIG[tinyalsa] = "-Dtinyalsa=enabled,-Dtinyalsa=disabled,tinyalsa"
79PACKAGECONFIG[ttml] = "-Dttml=enabled,-Dttml=disabled,libxml2 pango cairo"
80PACKAGECONFIG[uvch264] = "-Duvch264=enabled,-Duvch264=disabled,libusb1 libgudev"
81PACKAGECONFIG[v4l2codecs] = "-Dv4l2codecs=enabled,-Dv4l2codecs=disabled,libgudev"
82PACKAGECONFIG[va] = "-Dva=enabled,-Dva=disabled,libva"
83PACKAGECONFIG[voaacenc] = "-Dvoaacenc=enabled,-Dvoaacenc=disabled,vo-aacenc"
84PACKAGECONFIG[voamrwbenc] = "-Dvoamrwbenc=enabled,-Dvoamrwbenc=disabled,vo-amrwbenc"
85PACKAGECONFIG[vulkan] = "-Dvulkan=enabled,-Dvulkan=disabled,vulkan-loader shaderc-native"
86PACKAGECONFIG[wayland] = "-Dwayland=enabled,-Dwayland=disabled,wayland-native wayland wayland-protocols libdrm"
87PACKAGECONFIG[webp] = "-Dwebp=enabled,-Dwebp=disabled,libwebp"
88PACKAGECONFIG[webrtc] = "-Dwebrtc=enabled,-Dwebrtc=disabled,libnice"
89PACKAGECONFIG[webrtcdsp] = "-Dwebrtcdsp=enabled,-Dwebrtcdsp=disabled,webrtc-audio-processing"
90PACKAGECONFIG[zbar] = "-Dzbar=enabled,-Dzbar=disabled,zbar"
91PACKAGECONFIG[x265] = "-Dx265=enabled,-Dx265=disabled,x265"
92
93EXTRA_OEMESON += " \
94 -Ddoc=disabled \
95 -Ddecklink=enabled \
96 -Ddvb=enabled \
97 -Dfbdev=enabled \
98 -Dipcpipeline=enabled \
99 -Dshm=enabled \
100 -Dtranscode=enabled \
101 -Dandroidmedia=disabled \
102 -Dapplemedia=disabled \
103 -Davtp=disabled \
104 -Dbs2b=disabled \
105 -Dchromaprint=disabled \
106 -Dd3dvideosink=disabled \
107 -Dd3d11=disabled \
108 -Ddirectsound=disabled \
109 -Ddts=disabled \
110 -Dfdkaac=disabled \
111 -Dflite=disabled \
112 -Dgme=disabled \
113 -Dgsm=disabled \
114 -Diqa=disabled \
115 -Dkate=disabled \
116 -Dladspa=disabled \
117 -Dlv2=disabled \
118 -Dmagicleap=disabled \
119 -Dmediafoundation=disabled \
120 -Dmicrodns=disabled \
121 -Dmpeg2enc=disabled \
122 -Dmplex=disabled \
123 -Dmusepack=disabled \
124 -Dnvcodec=disabled \
125 -Dofa=disabled \
126 -Dopenexr=disabled \
127 -Dopenni2=disabled \
128 -Dopensles=disabled \
129 -Dsoundtouch=disabled \
130 -Dspandsp=disabled \
131 -Dsvthevcenc=disabled \
132 -Dteletext=disabled \
133 -Dwasapi=disabled \
134 -Dwasapi2=disabled \
135 -Dwildmidi=disabled \
136 -Dwinks=disabled \
137 -Dwinscreencap=disabled \
138 -Dwpe=disabled \
139 -Dzxing=disabled \
140"
141
142export OPENCV_PREFIX = "${STAGING_DIR_TARGET}${prefix}"
143
144ARM_INSTRUCTION_SET_armv4 = "arm"
145ARM_INSTRUCTION_SET_armv5 = "arm"
146
147FILES_${PN}-freeverb += "${datadir}/gstreamer-1.0/presets/GstFreeverb.prs"
148FILES_${PN}-opencv += "${datadir}/gst-plugins-bad/1.0/opencv*"
149FILES_${PN}-transcode += "${datadir}/gstreamer-1.0/encoding-profiles"
150FILES_${PN}-voamrwbenc += "${datadir}/gstreamer-1.0/presets/GstVoAmrwbEnc.prs"
151