summaryrefslogtreecommitdiffstats
path: root/meta/recipes-multimedia/gstreamer/gst-plugins-bad_0.10.23.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-multimedia/gstreamer/gst-plugins-bad_0.10.23.bb')
-rw-r--r--meta/recipes-multimedia/gstreamer/gst-plugins-bad_0.10.23.bb50
1 files changed, 50 insertions, 0 deletions
diff --git a/meta/recipes-multimedia/gstreamer/gst-plugins-bad_0.10.23.bb b/meta/recipes-multimedia/gstreamer/gst-plugins-bad_0.10.23.bb
new file mode 100644
index 0000000000..0f64871497
--- /dev/null
+++ b/meta/recipes-multimedia/gstreamer/gst-plugins-bad_0.10.23.bb
@@ -0,0 +1,50 @@
1require gst-plugins.inc
2
3LICENSE = "GPLv2+ & LGPLv2+ & LGPLv2.1+ "
4LIC_FILES_CHKSUM = "file://COPYING;md5=0636e73ff0215e8d672dc4c32c317bb3 \
5 file://gst/tta/filters.h;beginline=12;endline=29;md5=629b0c7a665d155a6677778f4460ec06 \
6 file://COPYING.LIB;md5=55ca817ccb7d5b5b66355690e9abc605 \
7 file://gst/tta/crc32.h;beginline=12;endline=29;md5=71a904d99ce7ae0c1cf129891b98145c"
8
9DEPENDS += "gst-plugins-base"
10
11PR = "r4"
12
13inherit gettext gsettings
14
15EXTRA_OECONF += "--disable-experimental \
16 --disable-sdl --disable-cdaudio --disable-directfb \
17 --disable-vdpau --disable-apexsink"
18
19PACKAGECONFIG ??= "bzip curl \
20 ${@bb.utils.contains('DISTRO_FEATURES', 'x11', 'rsvg', '', d)}"
21
22PACKAGECONFIG[bzip] = "--enable-bz2,--disable-bz2,bzip2"
23PACKAGECONFIG[curl] = "--enable-curl,--disable-curl,curl"
24PACKAGECONFIG[rsvg] = "--enable-rsvg,--disable-rsvg,librsvg,"
25PACKAGECONFIG[orc] = "--enable-orc,--disable-orc,orc"
26PACKAGECONFIG[neon] = "--enable-neon,--disable-neon,neon"
27PACKAGECONFIG[mms] = "--enable-libmms,--disable-libmms,libmms"
28PACKAGECONFIG[cog] = "--enable-cog,--disable-cog,libpng"
29PACKAGECONFIG[faad] = "--enable-faad,--disable-faad,faad2"
30PACKAGECONFIG[jp2k] = "--enable-jp2k,--disable-jp2k,jasper"
31PACKAGECONFIG[modplug] = "--enable-modplug,--disable-modplug,libmodplug"
32PACKAGECONFIG[opus] = "--enable-opus,--disable-opus,libopus"
33PACKAGECONFIG[sndfile] = "--enable-sndfile,--disable-sndfile,libsndfile1"
34PACKAGECONFIG[vp8] = "--enable-vp8,--disable-vp8,libvpx"
35PACKAGECONFIG[ass] = "--enable-assrender,--disable-assrender,libass"
36PACKAGECONFIG[openal] = "--enable-openal,--disable-openal,openal-soft"
37PACKAGECONFIG[schro] = "--enable-schro,--disable-schro,schroedinger"
38PACKAGECONFIG[dc1394] = "--enable-dc1394,--disable-dc1394,libdc1394"
39PACKAGECONFIG[faac] = "--enable-faac,--disable-faac,faac"
40PACKAGECONFIG[rtmp] = "--enable-rtmp,--disable-rtmp,rtmpdump"
41
42ARM_INSTRUCTION_SET = "arm"
43
44do_configure_prepend() {
45 # This m4 file contains nastiness which conflicts with libtool 2.2.2
46 rm ${S}/m4/lib-link.m4 || true
47}
48
49SRC_URI[md5sum] = "fcb09798114461955260e4d940db5987"
50SRC_URI[sha256sum] = "0eae7d1a1357ae8377fded6a1b42e663887beabe0e6cc336e2ef9ada42e11491"