summaryrefslogtreecommitdiffstats
path: root/meta/recipes-multimedia/gstreamer/gst-player_git.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-multimedia/gstreamer/gst-player_git.bb')
-rw-r--r--meta/recipes-multimedia/gstreamer/gst-player_git.bb31
1 files changed, 31 insertions, 0 deletions
diff --git a/meta/recipes-multimedia/gstreamer/gst-player_git.bb b/meta/recipes-multimedia/gstreamer/gst-player_git.bb
new file mode 100644
index 0000000000..a7df526b82
--- /dev/null
+++ b/meta/recipes-multimedia/gstreamer/gst-player_git.bb
@@ -0,0 +1,31 @@
1SUMMARY="GStreamer playback helper library and examples"
2
3LICENSE = "LGPL-2.0+"
4LIC_FILES_CHKSUM = "file://lib/gst/player/gstplayer.c;beginline=1;endline=19;md5=03aeca9d8295f811817909075a15ff65"
5
6DEPENDS = "glib-2.0 gstreamer1.0 gstreamer1.0-plugins-base gtk+3"
7
8SRC_URI = "git://github.com/sdroege/gst-player.git \
9 file://filechooser.patch \
10 file://gst-player.desktop"
11
12SRCREV = "5386c5b984d40ef5434673ed62204e69aaf52645"
13
14S = "${WORKDIR}/git"
15
16inherit autotools gtk-doc lib_package pkgconfig
17
18do_configure_prepend() {
19 touch ${S}/ChangeLog
20}
21
22EXTRA_OECONF += "ac_cv_path_VALGRIND=no ac_cv_path_GDB=no"
23
24do_install_append() {
25 install -m 0644 -D ${WORKDIR}/gst-player.desktop ${D}${datadir}/applications/gst-player.desktop
26}
27
28FILES_${PN}-bin += "${datadir}/applications/*.desktop"
29
30RDEPENDS_${PN}-bin = "gstreamer1.0-plugins-base-playback"
31RRECOMMENDS_${PN}-bin = "gstreamer1.0-plugins-base-meta gstreamer1.0-plugins-good-meta gstreamer1.0-plugins-bad-meta gstreamer1.0-plugins-ugly-meta"