summaryrefslogtreecommitdiffstats
path: root/meta/recipes-multimedia/gstreamer/gst-ffmpeg_0.10.1.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-multimedia/gstreamer/gst-ffmpeg_0.10.1.bb')
-rw-r--r--meta/recipes-multimedia/gstreamer/gst-ffmpeg_0.10.1.bb32
1 files changed, 32 insertions, 0 deletions
diff --git a/meta/recipes-multimedia/gstreamer/gst-ffmpeg_0.10.1.bb b/meta/recipes-multimedia/gstreamer/gst-ffmpeg_0.10.1.bb
new file mode 100644
index 0000000000..65d60f9cea
--- /dev/null
+++ b/meta/recipes-multimedia/gstreamer/gst-ffmpeg_0.10.1.bb
@@ -0,0 +1,32 @@
1DESCRIPTION = "FFmpeg-based GStreamer plug-in"
2SECTION = "multimedia"
3PRIORITY = "optional"
4LICENSE = "LGPL"
5HOMEPAGE = "http://www.gstreamer.net/"
6DEPENDS = "gstreamer zlib gst-plugins-base"
7PR = "r4"
8
9inherit autotools pkgconfig
10
11SRC_URI = "http://gstreamer.freedesktop.org/src/${PN}/${PN}-${PV}.tar.bz2 \
12 file://no_beos.patch;patch=1 \
13 file://configure_fix.patch;patch=1"
14
15FILES_${PN} += "${libdir}/gstreamer-0.10/*.so"
16FILES_${PN}-dbg += "${libdir}/gstreamer-0.10/.debug"
17FILES_${PN}-dev += "${libdir}/gstreamer-0.10/*.la ${libdir}/gstreamer-0.10/*.a"
18
19EXTRA_OECONF = "--disable-sdltest --disable-ffplay --disable-freetypetest \
20 --disable-vorbis --disable-vorbistest --disable-encoders \
21 --disable-v4l --disable-audio-oss --disable-dv1394 \
22 --disable-vhook --disable-ffmpeg --disable-ffserver \
23 --enable-pp --disable-decoder-vorbis --with-pic=no"
24
25# We do this because the install program is called with -s which causes it to
26# call "strip" and it then mangles cross compiled stuff..
27PATH_prepend="${STAGING_DIR_NATIVE}${prefix_native}/${TARGET_SYS}/bin:"
28
29# Hack to get STAGING_LIBDIR into the linker path when building ffmpeg
30CC = "${CCACHE} ${HOST_PREFIX}gcc -L${STAGING_LIBDIR}"
31
32acpaths = "-I ${S}/common/m4"