diff options
Diffstat (limited to 'meta/recipes-multimedia/alsa/alsa-utils_1.1.4.bb')
-rw-r--r-- | meta/recipes-multimedia/alsa/alsa-utils_1.1.4.bb | 115 |
1 files changed, 115 insertions, 0 deletions
diff --git a/meta/recipes-multimedia/alsa/alsa-utils_1.1.4.bb b/meta/recipes-multimedia/alsa/alsa-utils_1.1.4.bb new file mode 100644 index 0000000000..c749f32120 --- /dev/null +++ b/meta/recipes-multimedia/alsa/alsa-utils_1.1.4.bb | |||
@@ -0,0 +1,115 @@ | |||
1 | SUMMARY = "ALSA sound utilities" | ||
2 | HOMEPAGE = "http://www.alsa-project.org" | ||
3 | BUGTRACKER = "http://alsa-project.org/main/index.php/Bug_Tracking" | ||
4 | SECTION = "console/utils" | ||
5 | LICENSE = "GPLv2+" | ||
6 | LIC_FILES_CHKSUM = "file://COPYING;md5=59530bdf33659b29e73d4adb9f9f6552 \ | ||
7 | file://alsactl/utils.c;beginline=1;endline=20;md5=fe9526b055e246b5558809a5ae25c0b9" | ||
8 | DEPENDS = "alsa-lib ncurses libsamplerate0" | ||
9 | |||
10 | PACKAGECONFIG ??= "udev" | ||
11 | |||
12 | # alsabat can be built also without fftw support (with reduced functionality). | ||
13 | # It would be better to always enable alsabat, but provide an option for | ||
14 | # enabling/disabling fftw. The configure script doesn't support that, however | ||
15 | # (at least in any obvious way), so for now we only support alsabat with fftw | ||
16 | # or no alsabat at all. | ||
17 | PACKAGECONFIG[bat] = "--enable-bat,--disable-bat,fftwf" | ||
18 | |||
19 | PACKAGECONFIG[udev] = "--with-udev-rules-dir=`pkg-config --variable=udevdir udev`/rules.d,,udev" | ||
20 | PACKAGECONFIG[manpages] = "--enable-xmlto, --disable-xmlto, xmlto-native docbook-xml-dtd4-native docbook-xsl-stylesheets-native" | ||
21 | |||
22 | SRC_URI = "ftp://ftp.alsa-project.org/pub/utils/alsa-utils-${PV}.tar.bz2 \ | ||
23 | file://0001-alsactl-don-t-let-systemd-unit-restore-the-volume-wh.patch \ | ||
24 | " | ||
25 | |||
26 | SRC_URI[md5sum] = "01e3934ca5bd22a80c27289d1b0adcdc" | ||
27 | SRC_URI[sha256sum] = "a7831044de92c5bf33bf3365a3f36e49397f4191e934df460ae1ca15138c9d9d" | ||
28 | |||
29 | # On build machines with python-docutils (not python3-docutils !!) installed | ||
30 | # rst2man (not rst2man.py) is detected and compile fails with | ||
31 | # | make[1]: *** No rule to make target 'alsaucm.1', needed by 'all-am'. Stop. | ||
32 | # Avoid this by disabling expicitly | ||
33 | EXTRA_OECONF = "--disable-rst2man" | ||
34 | |||
35 | # lazy hack. needs proper fixing in gettext.m4, see | ||
36 | # http://bugs.openembedded.org/show_bug.cgi?id=2348 | ||
37 | # please close bug and remove this comment when properly fixed | ||
38 | # | ||
39 | EXTRA_OECONF_append_libc-uclibc = " --disable-nls" | ||
40 | |||
41 | inherit autotools gettext pkgconfig manpages | ||
42 | |||
43 | # This are all packages that we need to make. Also, the now empty alsa-utils | ||
44 | # ipk depends on them. | ||
45 | |||
46 | ALSA_UTILS_PKGS = "\ | ||
47 | ${@bb.utils.contains('PACKAGECONFIG', 'bat', 'alsa-utils-alsabat', '', d)} \ | ||
48 | alsa-utils-alsamixer \ | ||
49 | alsa-utils-alsatplg \ | ||
50 | alsa-utils-midi \ | ||
51 | alsa-utils-aplay \ | ||
52 | alsa-utils-amixer \ | ||
53 | alsa-utils-aconnect \ | ||
54 | alsa-utils-iecset \ | ||
55 | alsa-utils-speakertest \ | ||
56 | alsa-utils-aseqnet \ | ||
57 | alsa-utils-aseqdump \ | ||
58 | alsa-utils-alsactl \ | ||
59 | alsa-utils-alsaloop \ | ||
60 | alsa-utils-alsaucm \ | ||
61 | " | ||
62 | |||
63 | PACKAGES += "${ALSA_UTILS_PKGS}" | ||
64 | RDEPENDS_${PN} += "${ALSA_UTILS_PKGS}" | ||
65 | |||
66 | FILES_${PN} = "" | ||
67 | FILES_alsa-utils-alsabat = "${bindir}/alsabat" | ||
68 | FILES_alsa-utils-alsatplg = "${bindir}/alsatplg" | ||
69 | FILES_alsa-utils-aplay = "${bindir}/aplay ${bindir}/arecord" | ||
70 | FILES_alsa-utils-amixer = "${bindir}/amixer" | ||
71 | FILES_alsa-utils-alsamixer = "${bindir}/alsamixer" | ||
72 | FILES_alsa-utils-speakertest = "${bindir}/speaker-test ${datadir}/sounds/alsa/ ${datadir}/alsa/speaker-test/" | ||
73 | FILES_alsa-utils-midi = "${bindir}/aplaymidi ${bindir}/arecordmidi ${bindir}/amidi" | ||
74 | FILES_alsa-utils-aconnect = "${bindir}/aconnect" | ||
75 | FILES_alsa-utils-aseqnet = "${bindir}/aseqnet" | ||
76 | FILES_alsa-utils-iecset = "${bindir}/iecset" | ||
77 | FILES_alsa-utils-alsactl = "${sbindir}/alsactl */udev/rules.d */*/udev/rules.d ${systemd_unitdir} ${localstatedir}/lib/alsa ${datadir}/alsa/init/" | ||
78 | FILES_alsa-utils-aseqdump = "${bindir}/aseqdump" | ||
79 | FILES_alsa-utils-alsaloop = "${bindir}/alsaloop" | ||
80 | FILES_alsa-utils-alsaucm = "${bindir}/alsaucm" | ||
81 | |||
82 | SUMMARY_alsa-utils-alsabat = "Command-line sound tester for ALSA sound card driver" | ||
83 | SUMMARY_alsa-utils-alsatplg = "Converts topology text files into binary format for kernel" | ||
84 | SUMMARY_alsa-utils-aplay = "Play (and record) sound files using ALSA" | ||
85 | SUMMARY_alsa-utils-amixer = "Command-line control for ALSA mixer and settings" | ||
86 | SUMMARY_alsa-utils-alsamixer = "ncurses-based control for ALSA mixer and settings" | ||
87 | SUMMARY_alsa-utils-speakertest = "ALSA surround speaker test utility" | ||
88 | SUMMARY_alsa-utils-midi = "Miscellaneous MIDI utilities for ALSA" | ||
89 | SUMMARY_alsa-utils-aconnect = "ALSA sequencer connection manager" | ||
90 | SUMMARY_alsa-utils-aseqnet = "Network client/server for ALSA sequencer" | ||
91 | SUMMARY_alsa-utils-iecset = "ALSA utility for setting/showing IEC958 (S/PDIF) status bits" | ||
92 | SUMMARY_alsa-utils-alsactl = "Saves/restores ALSA-settings in /etc/asound.state" | ||
93 | SUMMARY_alsa-utils-aseqdump = "Shows the events received at an ALSA sequencer port" | ||
94 | SUMMARY_alsa-utils-alsaloop = "ALSA PCM loopback utility" | ||
95 | SUMMARY_alsa-utils-alsaucm = "ALSA Use Case Manager" | ||
96 | |||
97 | RRECOMMENDS_alsa-utils-alsactl = "alsa-states" | ||
98 | |||
99 | ALLOW_EMPTY_alsa-utils = "1" | ||
100 | |||
101 | do_install() { | ||
102 | autotools_do_install | ||
103 | |||
104 | # We don't ship this here because it requires a dependency on bash. | ||
105 | # See alsa-utils-scripts_${PV}.bb | ||
106 | rm ${D}${sbindir}/alsaconf | ||
107 | rm ${D}${sbindir}/alsa-info.sh | ||
108 | rm -f ${D}${sbindir}/alsabat-test.sh | ||
109 | |||
110 | if ${@bb.utils.contains('PACKAGECONFIG', 'udev', 'false', 'true', d)}; then | ||
111 | # This is where alsa-utils will install its rules if we don't tell it anything else. | ||
112 | rm -rf ${D}/lib/udev | ||
113 | rmdir --ignore-fail-on-non-empty ${D}/lib | ||
114 | fi | ||
115 | } | ||