diff options
Diffstat (limited to 'meta/recipes-multimedia/alsa/alsa-tools_1.1.7.bb')
-rw-r--r-- | meta/recipes-multimedia/alsa/alsa-tools_1.1.7.bb | 87 |
1 files changed, 87 insertions, 0 deletions
diff --git a/meta/recipes-multimedia/alsa/alsa-tools_1.1.7.bb b/meta/recipes-multimedia/alsa/alsa-tools_1.1.7.bb new file mode 100644 index 0000000000..e1b50fac52 --- /dev/null +++ b/meta/recipes-multimedia/alsa/alsa-tools_1.1.7.bb | |||
@@ -0,0 +1,87 @@ | |||
1 | SUMMARY = "Advanced tools for certain ALSA sound card drivers" | ||
2 | HOMEPAGE = "http://www.alsa-project.org" | ||
3 | BUGTRACKER = "http://alsa-project.org/main/index.php/Bug_Tracking" | ||
4 | SECTION = "console/utils" | ||
5 | LICENSE = "GPLv2 & LGPLv2+" | ||
6 | DEPENDS = "alsa-lib" | ||
7 | |||
8 | LIC_FILES_CHKSUM = "file://hdsploader/COPYING;md5=59530bdf33659b29e73d4adb9f9f6552 \ | ||
9 | file://ld10k1/COPYING.LIB;md5=a916467b91076e631dd8edb7424769c7 \ | ||
10 | " | ||
11 | |||
12 | SRC_URI = "https://www.alsa-project.org/files/pub/tools/${BP}.tar.bz2" | ||
13 | |||
14 | SRC_URI[md5sum] = "475bdf6457bcf55c8c895d653ee56a54" | ||
15 | SRC_URI[sha256sum] = "a0243328a8f6f691a3055c484fd8d3326393096325e93743b246029d327c4ef6" | ||
16 | |||
17 | inherit autotools-brokensep pkgconfig | ||
18 | # brokensep as as10k1 (and probably more) fail out of tree | ||
19 | CLEANBROKEN = "1" | ||
20 | |||
21 | # Here we use PACKAGECONFIG options to pick which directories we configure/build. | ||
22 | # Remember on upgrades to check that no new tools have been added. | ||
23 | PACKAGECONFIG ??= "as10k1 hdajacksensetest hda-verb hdsploader ld10k1 mixartloader pcxhrloader \ | ||
24 | sb16_csp seq--sbiload sscape_ctl us428control usx2yloader vxloader \ | ||
25 | ${@bb.utils.contains_any('DISTRO_FEATURES', '${GTK2DISTROFEATURES}', 'echomixer envy24control rmedigicontrol', '', d)} \ | ||
26 | ${@bb.utils.contains_any('DISTRO_FEATURES', '${GTK3DISTROFEATURES}', 'hdajackretask', '', d)} \ | ||
27 | " | ||
28 | |||
29 | PACKAGECONFIG[as10k1] = "" | ||
30 | PACKAGECONFIG[echomixer] = ",,gtk+" | ||
31 | PACKAGECONFIG[envy24control] = ",,gtk+" | ||
32 | PACKAGECONFIG[hda-verb] = "" | ||
33 | PACKAGECONFIG[hdajackretask] = ",,gtk+3" | ||
34 | PACKAGECONFIG[hdajacksensetest] = ",,glib-2.0" | ||
35 | PACKAGECONFIG[hdspconf] = ",,fltk" | ||
36 | PACKAGECONFIG[hdsploader] = "" | ||
37 | PACKAGECONFIG[hdspmixer] = ",,fltk" | ||
38 | PACKAGECONFIG[ld10k1] = "" | ||
39 | PACKAGECONFIG[mixartloader] = "" | ||
40 | PACKAGECONFIG[pcxhrloader] = "" | ||
41 | PACKAGECONFIG[qlo10k1] = ",,qt-x11-free" | ||
42 | PACKAGECONFIG[rmedigicontrol] = ",,gtk+" | ||
43 | PACKAGECONFIG[sb16_csp] = "" | ||
44 | PACKAGECONFIG[seq--sbiload] = "" | ||
45 | PACKAGECONFIG[sscape_ctl] = "" | ||
46 | PACKAGECONFIG[us428control] = "" | ||
47 | PACKAGECONFIG[usx2yloader] = "" | ||
48 | PACKAGECONFIG[vxloader] = "" | ||
49 | |||
50 | # At the time of writing pyalsa is not packaged for OE, so this is not expected | ||
51 | # to work. | ||
52 | PACKAGECONFIG[hwmixvolume] = ",,,python-core python-pygobject pyalsa" | ||
53 | |||
54 | python do_configure() { | ||
55 | for subdir in d.getVar("PACKAGECONFIG").split(): | ||
56 | subdir = subdir.replace("--", "/") | ||
57 | bb.note("Configuring %s" % subdir) | ||
58 | dd = d.createCopy() | ||
59 | dd.setVar("S", os.path.join(d.getVar("S"), subdir)) | ||
60 | bb.build.exec_func("autotools_do_configure", dd) | ||
61 | } | ||
62 | |||
63 | python do_compile() { | ||
64 | for subdir in d.getVar("PACKAGECONFIG").split(): | ||
65 | subdir = subdir.replace("--", "/") | ||
66 | bb.note("Compiling %s" % subdir) | ||
67 | dd = d.createCopy() | ||
68 | dd.setVar("S", os.path.join(d.getVar("S"), subdir)) | ||
69 | bb.build.exec_func("autotools_do_compile", dd) | ||
70 | } | ||
71 | |||
72 | python do_install() { | ||
73 | for subdir in d.getVar("PACKAGECONFIG").split(): | ||
74 | subdir = subdir.replace("--", "/") | ||
75 | bb.note("Installing %s" % subdir) | ||
76 | dd = d.createCopy() | ||
77 | dd.setVar("S", os.path.join(d.getVar("S"), subdir)) | ||
78 | bb.build.exec_func("autotools_do_install", dd) | ||
79 | |||
80 | # Just remove bash-needing init script that isn't installed as an init script | ||
81 | try: | ||
82 | os.remove(oe.path.join(d.getVar("D"), d.getVar("sbindir"), "ld10k1d")) | ||
83 | except: | ||
84 | pass | ||
85 | } | ||
86 | |||
87 | FILES_${PN} += "${datadir}" | ||