summaryrefslogtreecommitdiffstats
path: root/meta/recipes-multimedia/alsa/alsa-tools_1.1.6.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-multimedia/alsa/alsa-tools_1.1.6.bb')
-rw-r--r--meta/recipes-multimedia/alsa/alsa-tools_1.1.6.bb92
1 files changed, 62 insertions, 30 deletions
diff --git a/meta/recipes-multimedia/alsa/alsa-tools_1.1.6.bb b/meta/recipes-multimedia/alsa/alsa-tools_1.1.6.bb
index e065eec6b8..90e54dbb14 100644
--- a/meta/recipes-multimedia/alsa/alsa-tools_1.1.6.bb
+++ b/meta/recipes-multimedia/alsa/alsa-tools_1.1.6.bb
@@ -3,53 +3,85 @@ HOMEPAGE = "http://www.alsa-project.org"
3BUGTRACKER = "http://alsa-project.org/main/index.php/Bug_Tracking" 3BUGTRACKER = "http://alsa-project.org/main/index.php/Bug_Tracking"
4SECTION = "console/utils" 4SECTION = "console/utils"
5LICENSE = "GPLv2 & LGPLv2+" 5LICENSE = "GPLv2 & LGPLv2+"
6DEPENDS = "alsa-lib ncurses glib-2.0" 6DEPENDS = "alsa-lib"
7 7
8LIC_FILES_CHKSUM = "file://hdsploader/COPYING;md5=59530bdf33659b29e73d4adb9f9f6552 \ 8LIC_FILES_CHKSUM = "file://hdsploader/COPYING;md5=59530bdf33659b29e73d4adb9f9f6552 \
9 file://ld10k1/COPYING.LIB;md5=a916467b91076e631dd8edb7424769c7 \ 9 file://ld10k1/COPYING.LIB;md5=a916467b91076e631dd8edb7424769c7 \
10 " 10 "
11 11
12SRC_URI = "ftp://ftp.alsa-project.org/pub/tools/${BP}.tar.bz2 \ 12SRC_URI = "ftp://ftp.alsa-project.org/pub/tools/${BP}.tar.bz2 \
13 file://autotools.patch \
14 ${@bb.utils.contains('DISTRO_FEATURES', 'x11', '', 'file://makefile_no_gtk.patch', d)} \
15 file://gitcompile_hdajacksensetest \
16 file://0002-Fix-clang-Wreserved-user-defined-literal-warnings.patch \ 13 file://0002-Fix-clang-Wreserved-user-defined-literal-warnings.patch \
14 file://musl.patch \
17 " 15 "
18 16
19SRC_URI[md5sum] = "5ca8c9437ae779997cd62fb2815fef19" 17SRC_URI[md5sum] = "5ca8c9437ae779997cd62fb2815fef19"
20SRC_URI[sha256sum] = "d69c4dc2fb641a974d9903e9eb78c94cb0c7ac6c45bae664f0c9d6c0a1593227" 18SRC_URI[sha256sum] = "d69c4dc2fb641a974d9903e9eb78c94cb0c7ac6c45bae664f0c9d6c0a1593227"
21 19
22inherit autotools-brokensep pkgconfig 20inherit autotools-brokensep pkgconfig
23 21# brokensep as as10k1 (and probably more) fail out of tree
24CLEANBROKEN = "1" 22CLEANBROKEN = "1"
25 23
26EXTRA_OEMAKE += "GITCOMPILE_ARGS='--host=${HOST_SYS} --build=${BUILD_SYS} --target=${TARGET_SYS} --with-libtool-sysroot=${STAGING_DIR_HOST} --prefix=${prefix}'" 24# Here we use PACKAGECONFIG options to pick which directories we configure/build.
27 25# Remember on upgrades to check that no new tools have been added.
28PACKAGECONFIG ??= "${@bb.utils.contains('DISTRO_FEATURES', 'x11', 'gtk+', '', d)}" 26PACKAGECONFIG ??= "as10k1 hdajacksensetest hda-verb hdsploader ld10k1 mixartloader pcxhrloader \
29PACKAGECONFIG[gtk+] = ",,gtk+ gtk+3," 27 sb16_csp seq--sbiload sscape_ctl us428control usx2yloader vxloader \
30 28 ${@bb.utils.contains_any('DISTRO_FEATURES', '${GTK2DISTROFEATURES}', 'echomixer envy24control rmedigicontrol', '', d)} \
31# configure.ac/.in doesn't exist so force copy 29 ${@bb.utils.contains_any('DISTRO_FEATURES', '${GTK3DISTROFEATURES}', 'hdajackretask', '', d)} \
32AUTOTOOLS_COPYACLOCAL = "1" 30 "
33 31
34do_compile_prepend () { 32PACKAGECONFIG[as10k1] = ""
35 #Automake dir is not correctly detected in cross compilation case 33PACKAGECONFIG[echomixer] = ",,gtk+"
36 export AUTOMAKE_DIR="$(automake --print-libdir)" 34PACKAGECONFIG[envy24control] = ",,gtk+"
37 export ACLOCAL_FLAGS="--system-acdir=${ACLOCALDIR}/ ${ACLOCALEXTRAPATH}" 35PACKAGECONFIG[hda-verb] = ""
38 36PACKAGECONFIG[hdajackretask] = ",,gtk+3"
39 cp ${WORKDIR}/gitcompile_hdajacksensetest ${S}/hdajacksensetest/gitcompile 37PACKAGECONFIG[hdajacksensetest] = ",,glib-2.0"
38PACKAGECONFIG[hdspconf] = ",,fltk"
39PACKAGECONFIG[hdsploader] = ""
40PACKAGECONFIG[hdspmixer] = ",,fltk"
41PACKAGECONFIG[hwmixvolume] = ",,,python-core python-pygtk"
42PACKAGECONFIG[ld10k1] = ""
43PACKAGECONFIG[mixartloader] = ""
44PACKAGECONFIG[pcxhrloader] = ""
45PACKAGECONFIG[qlo10k1] = ",,qt-x11-free"
46PACKAGECONFIG[rmedigicontrol] = ",,gtk+"
47PACKAGECONFIG[sb16_csp] = ""
48PACKAGECONFIG[seq--sbiload] = ""
49PACKAGECONFIG[sscape_ctl] = ""
50PACKAGECONFIG[us428control] = ""
51PACKAGECONFIG[usx2yloader] = ""
52PACKAGECONFIG[vxloader] = ""
53
54python do_configure() {
55 for subdir in d.getVar("PACKAGECONFIG").split():
56 subdir = subdir.replace("--", "/")
57 bb.note("Configuring %s" % subdir)
58 dd = d.createCopy()
59 dd.setVar("S", os.path.join(d.getVar("S"), subdir))
60 bb.build.exec_func("autotools_do_configure", dd)
40} 61}
41 62
42do_install_append() { 63python do_compile() {
43 sed -i -e "s|/usr/bin/python2|/usr/bin/env python2|g" ${D}${bindir}/hwmixvolume 64 for subdir in d.getVar("PACKAGECONFIG").split():
65 subdir = subdir.replace("--", "/")
66 bb.note("Compiling %s" % subdir)
67 dd = d.createCopy()
68 dd.setVar("S", os.path.join(d.getVar("S"), subdir))
69 bb.build.exec_func("autotools_do_compile", dd)
44} 70}
45 71
46PACKAGES =+ "${PN}-hwmixvolume" 72python do_install() {
47 73 for subdir in d.getVar("PACKAGECONFIG").split():
48FILES_${PN}-hwmixvolume = "${bindir}/hwmixvolume" 74 subdir = subdir.replace("--", "/")
49 75 bb.note("Installing %s" % subdir)
50FILES_${PN} += "${datadir}/ld10k1 \ 76 dd = d.createCopy()
51 ${datadir}/icons/hicolor \ 77 dd.setVar("S", os.path.join(d.getVar("S"), subdir))
52 " 78 bb.build.exec_func("autotools_do_install", dd)
53 79
54RDEPENDS_${PN}-hwmixvolume += "python" 80 # Just remove bash-needing init script that isn't installed as an init script
81 try:
82 os.remove(oe.path.join(d.getVar("D"), d.getVar("sbindir"), "ld10k1d"))
83 except:
84 pass
85}
55 86
87FILES_${PN} += "${datadir}"