summaryrefslogtreecommitdiffstats
path: root/meta/recipes-multimedia/alsa/alsa-lib_1.0.24.1.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-multimedia/alsa/alsa-lib_1.0.24.1.bb')
-rw-r--r--meta/recipes-multimedia/alsa/alsa-lib_1.0.24.1.bb45
1 files changed, 45 insertions, 0 deletions
diff --git a/meta/recipes-multimedia/alsa/alsa-lib_1.0.24.1.bb b/meta/recipes-multimedia/alsa/alsa-lib_1.0.24.1.bb
new file mode 100644
index 0000000000..53f4d29f5f
--- /dev/null
+++ b/meta/recipes-multimedia/alsa/alsa-lib_1.0.24.1.bb
@@ -0,0 +1,45 @@
1DESCRIPTION = "Alsa sound library"
2HOMEPAGE = "http://www.alsa-project.org"
3BUGTRACKER = "https://bugtrack.alsa-project.org/alsa-bug/login_page.php"
4SECTION = "libs/multimedia"
5LICENSE = "LGPLv2.1 & GPLv2+"
6LIC_FILES_CHKSUM = "file://COPYING;md5=7fbc338309ac38fefcd64b04bb903e34 \
7 file://src/socket.c;beginline=1;endline=26;md5=11ff89a8a7a4a690a5c78effe8159545"
8
9BBCLASSEXTEND = "native"
10
11# configure.in sets -D__arm__ on the command line for any arm system
12# (not just those with the ARM instruction set), this should be removed,
13# (or replaced by a permitted #define).
14#FIXME: remove the following
15ARM_INSTRUCTION_SET = "arm"
16
17PR = "r0"
18
19SRC_URI = "ftp://ftp.alsa-project.org/pub/lib/alsa-lib-${PV}.tar.bz2 \
20 file://fix-tstamp-declaration.patch;patch=1"
21
22SRC_URI[md5sum] = "7cc05f25e1d5b65da8fb3fdcd540f226"
23SRC_URI[sha256sum] = "a32f7c21015b6c71f9a80ff70a2b6a50e4ff4d5c77c744ff0793dea7ba7a2517"
24
25inherit autotools pkgconfig
26
27require alsa-fpu.inc
28EXTRA_OECONF += "${@get_alsa_fpu_setting(bb, d)} "
29
30EXTRA_OECONF = "--with-cards=pdaudiocf --with-oss=yes --disable-python"
31
32PACKAGES =+ "alsa-server libasound alsa-conf-base alsa-conf alsa-doc alsa-dev"
33FILES_${PN}-dbg += "${libdir}/alsa-lib/*/.debu*"
34FILES_libasound = "${libdir}/libasound.so.*"
35FILES_alsa-server = "${bindir}/*"
36FILES_alsa-conf = "${datadir}/alsa/"
37FILES_alsa-dev += "${libdir}/pkgconfig/ /usr/include/ ${datadir}/aclocal/*"
38FILES_alsa-conf-base = "\
39${datadir}/alsa/alsa.conf \
40${datadir}/alsa/cards/aliases.conf \
41${datadir}/alsa/pcm/default.conf \
42${datadir}/alsa/pcm/dmix.conf \
43${datadir}/alsa/pcm/dsnoop.conf"
44
45RDEPENDS_libasound = "alsa-conf-base"