summaryrefslogtreecommitdiffstats
path: root/meta/recipes-multimedia/alsa/alsa-lib_1.0.23.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-multimedia/alsa/alsa-lib_1.0.23.bb')
-rw-r--r--meta/recipes-multimedia/alsa/alsa-lib_1.0.23.bb40
1 files changed, 40 insertions, 0 deletions
diff --git a/meta/recipes-multimedia/alsa/alsa-lib_1.0.23.bb b/meta/recipes-multimedia/alsa/alsa-lib_1.0.23.bb
new file mode 100644
index 0000000000..b0a2a305c0
--- /dev/null
+++ b/meta/recipes-multimedia/alsa/alsa-lib_1.0.23.bb
@@ -0,0 +1,40 @@
1DESCRIPTION = "Alsa sound library"
2HOMEPAGE = "http://www.alsa-project.org"
3BUGTRACKER = "https://bugtrack.alsa-project.org/alsa-bug/login_page.php"
4SECTION = "libs/multimedia"
5LICENSE = "LGPLv2.1 & GPLv2+"
6LIC_FILES_CHKSUM = "file://COPYING;md5=7fbc338309ac38fefcd64b04bb903e34 \
7 file://src/socket.c;beginline=1;endline=26;md5=11ff89a8a7a4a690a5c78effe8159545"
8
9# configure.in sets -D__arm__ on the command line for any arm system
10# (not just those with the ARM instruction set), this should be removed,
11# (or replaced by a permitted #define).
12#FIXME: remove the following
13ARM_INSTRUCTION_SET = "arm"
14
15PR = "r0"
16
17SRC_URI = "ftp://ftp.alsa-project.org/pub/lib/alsa-lib-${PV}.tar.bz2 \
18 file://fix-tstamp-declaration.patch;patch=1"
19
20inherit autotools pkgconfig
21
22require alsa-fpu.inc
23EXTRA_OECONF += "${@get_alsa_fpu_setting(bb, d)} "
24
25EXTRA_OECONF = "--with-cards=pdaudiocf --with-oss=yes --disable-python"
26
27PACKAGES =+ "alsa-server libasound alsa-conf-base alsa-conf alsa-doc alsa-dev"
28FILES_${PN}-dbg += "${libdir}/alsa-lib/*/.debu*"
29FILES_libasound = "${libdir}/libasound.so.*"
30FILES_alsa-server = "${bindir}/*"
31FILES_alsa-conf = "${datadir}/alsa/"
32FILES_alsa-dev += "${libdir}/pkgconfig/ /usr/include/ ${datadir}/aclocal/*"
33FILES_alsa-conf-base = "\
34${datadir}/alsa/alsa.conf \
35${datadir}/alsa/cards/aliases.conf \
36${datadir}/alsa/pcm/default.conf \
37${datadir}/alsa/pcm/dmix.conf \
38${datadir}/alsa/pcm/dsnoop.conf"
39
40RDEPENDS_libasound = "alsa-conf-base"