diff options
Diffstat (limited to 'meta/recipes-kernel/update-modules/update-modules_1.0.bb')
-rw-r--r-- | meta/recipes-kernel/update-modules/update-modules_1.0.bb | 30 |
1 files changed, 30 insertions, 0 deletions
diff --git a/meta/recipes-kernel/update-modules/update-modules_1.0.bb b/meta/recipes-kernel/update-modules/update-modules_1.0.bb new file mode 100644 index 0000000000..73ee558a08 --- /dev/null +++ b/meta/recipes-kernel/update-modules/update-modules_1.0.bb | |||
@@ -0,0 +1,30 @@ | |||
1 | DESCRIPTION = "script to manage module configuration files." | ||
2 | SECTION = "base" | ||
3 | LICENSE = "GPLv2" | ||
4 | PACKAGE_ARCH = "all" | ||
5 | RDEPENDS = "${@base_contains("MACHINE_FEATURES", "kernel26", "module-init-tools-depmod","modutils-depmod",d)} " | ||
6 | PR = "r6" | ||
7 | |||
8 | SRC_URI = "file://update-modules" | ||
9 | |||
10 | pkg_postinst() { | ||
11 | if [ "x$D" != "x" ]; then | ||
12 | exit 1 | ||
13 | fi | ||
14 | update-modules | ||
15 | } | ||
16 | |||
17 | do_install() { | ||
18 | install -d ${D}${sbindir} | ||
19 | install ${WORKDIR}/update-modules ${D}${sbindir} | ||
20 | } | ||
21 | |||
22 | # The Unslung distro uses a 2.4 kernel for a machine (the NSLU2) which | ||
23 | # supports both 2.4 and 2.6 kernels. Rather than forcing OE to have | ||
24 | # to deal with that unique legacy corner case, we just nullify the | ||
25 | # RDEPENDS here and handle it in the Unslung image recipe. I know this | ||
26 | # is ugly. Please don't remove it unless you first make the RDEPENDS | ||
27 | # line at the top of this file understand that a machine can be used | ||
28 | # in both a 2.4 kernel distro and a 2.6 kernel distro. Really, it's | ||
29 | # not worth the effort to do that, so just overlook the next line. | ||
30 | RDEPENDS_unslung = "" | ||