summaryrefslogtreecommitdiffstats
path: root/meta/recipes-kernel/systemtap/systemtap_git.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-kernel/systemtap/systemtap_git.bb')
-rw-r--r--meta/recipes-kernel/systemtap/systemtap_git.bb15
1 files changed, 11 insertions, 4 deletions
diff --git a/meta/recipes-kernel/systemtap/systemtap_git.bb b/meta/recipes-kernel/systemtap/systemtap_git.bb
index 475b2073f1..b280f583e2 100644
--- a/meta/recipes-kernel/systemtap/systemtap_git.bb
+++ b/meta/recipes-kernel/systemtap/systemtap_git.bb
@@ -3,9 +3,7 @@ HOMEPAGE = "https://sourceware.org/systemtap/"
3 3
4require systemtap_git.inc 4require systemtap_git.inc
5 5
6DEPENDS = "boost elfutils" 6DEPENDS = "elfutils"
7
8RDEPENDS_${PN} += "python3-core bash perl"
9 7
10EXTRA_OECONF += "--with-libelf=${STAGING_DIR_TARGET} --without-rpm \ 8EXTRA_OECONF += "--with-libelf=${STAGING_DIR_TARGET} --without-rpm \
11 --without-nss --without-avahi --without-dyninst \ 9 --without-nss --without-avahi --without-dyninst \
@@ -18,7 +16,8 @@ STAP_DOCS ?= "--disable-docs --disable-publican --disable-refdocs"
18 16
19EXTRA_OECONF += "${STAP_DOCS} " 17EXTRA_OECONF += "${STAP_DOCS} "
20 18
21PACKAGECONFIG ??= "sqlite monitor python3-probes" 19PACKAGECONFIG ??= "translator sqlite monitor python3-probes"
20PACKAGECONFIG[translator] = "--enable-translator,--disable-translator,boost,python3-core bash perl"
22PACKAGECONFIG[libvirt] = "--enable-libvirt,--disable-libvirt,libvirt" 21PACKAGECONFIG[libvirt] = "--enable-libvirt,--disable-libvirt,libvirt"
23PACKAGECONFIG[sqlite] = "--enable-sqlite,--disable-sqlite,sqlite3" 22PACKAGECONFIG[sqlite] = "--enable-sqlite,--disable-sqlite,sqlite3"
24PACKAGECONFIG[monitor] = "--enable-monitor,--disable-monitor,ncurses json-c" 23PACKAGECONFIG[monitor] = "--enable-monitor,--disable-monitor,ncurses json-c"
@@ -26,4 +25,12 @@ PACKAGECONFIG[python3-probes] = "--with-python3-probes,--without-python3-probes,
26 25
27inherit autotools gettext pkgconfig distutils3-base 26inherit autotools gettext pkgconfig distutils3-base
28 27
28do_install_append () {
29 if [ ! -f ${D}${bindir}/stap ]; then
30 # translator disabled case, need to leave only minimal runtime
31 rm -rf ${D}${datadir}/${PN}
32 rm ${D}${libexecdir}/${PN}/stap-env
33 fi
34}
35
29BBCLASSEXTEND = "nativesdk" 36BBCLASSEXTEND = "nativesdk"