summaryrefslogtreecommitdiffstats
path: root/meta/recipes-kernel/systemtap/systemtap_git.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-kernel/systemtap/systemtap_git.bb')
-rw-r--r--meta/recipes-kernel/systemtap/systemtap_git.bb9
1 files changed, 5 insertions, 4 deletions
diff --git a/meta/recipes-kernel/systemtap/systemtap_git.bb b/meta/recipes-kernel/systemtap/systemtap_git.bb
index 43bf69e877..fed368a38b 100644
--- a/meta/recipes-kernel/systemtap/systemtap_git.bb
+++ b/meta/recipes-kernel/systemtap/systemtap_git.bb
@@ -4,12 +4,12 @@ require systemtap_git.inc
4 4
5DEPENDS = "boost elfutils" 5DEPENDS = "boost elfutils"
6 6
7RDEPENDS_${PN} += "python3-core bash" 7RDEPENDS_${PN} += "python3-core bash perl"
8 8
9EXTRA_OECONF += "--with-libelf=${STAGING_DIR_TARGET} --without-rpm \ 9EXTRA_OECONF += "--with-libelf=${STAGING_DIR_TARGET} --without-rpm \
10 --without-nss --without-avahi --without-dyninst \ 10 --without-nss --without-avahi --without-dyninst \
11 --disable-server --disable-grapher --enable-prologues \ 11 --disable-server --disable-grapher --enable-prologues \
12 --with-python3 \ 12 --with-python3 --without-python2-probes \
13 ac_cv_prog_have_javac=no \ 13 ac_cv_prog_have_javac=no \
14 ac_cv_prog_have_jar=no " 14 ac_cv_prog_have_jar=no "
15 15
@@ -17,11 +17,12 @@ STAP_DOCS ?= "--disable-docs --disable-publican --disable-refdocs"
17 17
18EXTRA_OECONF += "${STAP_DOCS} " 18EXTRA_OECONF += "${STAP_DOCS} "
19 19
20PACKAGECONFIG ??= "sqlite monitor" 20PACKAGECONFIG ??= "sqlite monitor python3-probes"
21PACKAGECONFIG[libvirt] = "--enable-libvirt,--disable-libvirt,libvirt" 21PACKAGECONFIG[libvirt] = "--enable-libvirt,--disable-libvirt,libvirt"
22PACKAGECONFIG[sqlite] = "--enable-sqlite,--disable-sqlite,sqlite3" 22PACKAGECONFIG[sqlite] = "--enable-sqlite,--disable-sqlite,sqlite3"
23PACKAGECONFIG[monitor] = "--enable-monitor,--disable-monitor,ncurses json-c" 23PACKAGECONFIG[monitor] = "--enable-monitor,--disable-monitor,ncurses json-c"
24PACKAGECONFIG[python3-probes] = "--with-python3-probes,--without-python3-probes,python3-setuptools-native"
24 25
25inherit autotools gettext pkgconfig 26inherit autotools gettext pkgconfig distutils3-base
26 27
27BBCLASSEXTEND = "native nativesdk" 28BBCLASSEXTEND = "native nativesdk"