summaryrefslogtreecommitdiffstats
path: root/meta/recipes-kernel/sysprof/sysprof_git.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-kernel/sysprof/sysprof_git.bb')
-rw-r--r--meta/recipes-kernel/sysprof/sysprof_git.bb34
1 files changed, 20 insertions, 14 deletions
diff --git a/meta/recipes-kernel/sysprof/sysprof_git.bb b/meta/recipes-kernel/sysprof/sysprof_git.bb
index 84c6aad39e..461f414a1e 100644
--- a/meta/recipes-kernel/sysprof/sysprof_git.bb
+++ b/meta/recipes-kernel/sysprof/sysprof_git.bb
@@ -1,29 +1,35 @@
1SUMMARY = "System-wide Performance Profiler for Linux" 1SUMMARY = "System-wide Performance Profiler for Linux"
2LICENSE = "GPLv2" 2LICENSE = "GPLv3+"
3LIC_FILES_CHKSUM = "file://COPYING;md5=94d55d512a9ba36caa9b7df079bae19f" 3LIC_FILES_CHKSUM = "file://COPYING;md5=d32239bcb673463ab874e80d47fae504 \
4 file://src/sp-application.c;endline=17;md5=40e55577ef122c88fe20052acda64875"
5
6inherit gnomebase gettext
4 7
5DEPENDS = "glib-2.0" 8DEPENDS = "glib-2.0"
6 9
7SRCREV = "cd44ee6644c3641507fb53b8a2a69137f2971219" 10S = "${WORKDIR}/git"
8PV = "1.2.0+git${SRCPV}" 11SRCREV = "9c6cec9b49766bf77c1713bc5a7c6d651e628068"
12PV = "3.20.0+git${SRCPV}"
9 13
10SRC_URI = "git://git.gnome.org/sysprof \ 14SRC_URI = "git://git.gnome.org/sysprof \
11 file://define-NT_GNU_BUILD_ID.patch \ 15 file://define-NT_GNU_BUILD_ID.patch \
12 file://gui-argument.patch \ 16 file://0001-Disable-check-for-polkit-for-UI.patch \
17 file://0001-Avoid-building-docs.patch \
18 file://0001-callgraph-Use-U64_TO_POINTER.patch \
19 file://0001-Forward-port-mips-arm-memory-barrier-patches.patch \
13 " 20 "
21SRC_URI[archive.md5sum] = "d56e8492033b60e247634731e7f760b9"
22SRC_URI[archive.sha256sum] = "4a338ad41bfffae87ef281f6e75c9660b3e0c6671bf5233be0c3f55a5e5b1ce5"
14 23
15SRC_URI_append_arm = " file://rmb-arm.patch" 24AUTOTOOLS_AUXDIR = "${S}/build-aux"
16SRC_URI_append_armeb = " file://rmb-arm.patch"
17SRC_URI_append_mips = " file://rmb-mips.patch"
18SRC_URI_append_mips64 = " file://rmb-mips.patch"
19SRC_URI_append_mips64n32 = " file://rmb-mips.patch"
20 25
21S = "${WORKDIR}/git" 26EXTRA_OECONF = "--enable-compile-warnings"
22 27
23inherit autotools pkgconfig 28PACKAGECONFIG ?= "${@bb.utils.contains_any('DISTRO_FEATURES', '${GTK3DISTROFEATURES}', 'gtk', '', d)}"
29PACKAGECONFIG[gtk] = "--enable-gtk,--disable-gtk,gtk+3"
24 30
25PACKAGECONFIG ?= "${@bb.utils.contains_any('DISTRO_FEATURES', '${GTK2DISTROFEATURES}', 'gui', '', d)}" 31FILES_${PN} += "${datadir}/icons/ ${libdir}"
26PACKAGECONFIG[gui] = "--enable-gui,--disable-gui,gtk+ gdk-pixbuf pango libglade" 32FILES_${PN}-dev = "${prefix}/include"
27 33
28# We do not yet work for aarch64. 34# We do not yet work for aarch64.
29# 35#