summaryrefslogtreecommitdiffstats
path: root/meta/recipes-kernel/sysprof/sysprof_3.26.1.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-kernel/sysprof/sysprof_3.26.1.bb')
-rw-r--r--meta/recipes-kernel/sysprof/sysprof_3.26.1.bb34
1 files changed, 34 insertions, 0 deletions
diff --git a/meta/recipes-kernel/sysprof/sysprof_3.26.1.bb b/meta/recipes-kernel/sysprof/sysprof_3.26.1.bb
new file mode 100644
index 0000000000..dbce3d7439
--- /dev/null
+++ b/meta/recipes-kernel/sysprof/sysprof_3.26.1.bb
@@ -0,0 +1,34 @@
1SUMMARY = "System-wide Performance Profiler for Linux"
2HOMEPAGE = "http://www.sysprof.com"
3LICENSE = "GPLv3+"
4LIC_FILES_CHKSUM = "file://COPYING;md5=d32239bcb673463ab874e80d47fae504 \
5 file://src/sp-application.c;endline=17;md5=40e55577ef122c88fe20052acda64875"
6
7inherit gnomebase gettext systemd upstream-version-is-even
8
9DEPENDS = "glib-2.0 libxml2-native glib-2.0-native"
10
11SRC_URI[archive.md5sum] = "6f9f947960ba79bb1269d8ee49b7db78"
12SRC_URI[archive.sha256sum] = "d8b9d5c2246696e4a3776a312731dc7c014fbd33478bb14d5512c6f1f35a3b11"
13SRC_URI += " \
14 file://define-NT_GNU_BUILD_ID.patch \
15 file://0001-configure-Add-option-to-enable-disable-polkit.patch \
16 file://0001-Disable-check-for-polkit-for-UI.patch \
17 file://0001-Avoid-building-docs.patch \
18 "
19
20AUTOTOOLS_AUXDIR = "${S}/build-aux"
21
22EXTRA_OECONF = "--enable-compile-warnings"
23
24PACKAGECONFIG ?= "${@bb.utils.contains_any('DISTRO_FEATURES', '${GTK3DISTROFEATURES}', 'gtk', '', d)}"
25PACKAGECONFIG[gtk] = "--enable-gtk,--disable-gtk,gtk+3"
26PACKAGECONFIG[polkit] = "--enable-polkit,--disable-polkit,polkit dbus"
27
28SOLIBS = ".so"
29FILES_SOLIBSDEV = ""
30
31SYSTEMD_SERVICE_${PN} = "${@bb.utils.contains('PACKAGECONFIG', 'polkit', 'sysprof2.service', '', d)}"
32
33# We do not yet work for aarch64.
34COMPATIBLE_HOST = "^(?!aarch64).*"