summaryrefslogtreecommitdiffstats
path: root/meta/recipes-kernel/sysprof/sysprof_3.24.1.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-kernel/sysprof/sysprof_3.24.1.bb')
-rw-r--r--meta/recipes-kernel/sysprof/sysprof_3.24.1.bb38
1 files changed, 38 insertions, 0 deletions
diff --git a/meta/recipes-kernel/sysprof/sysprof_3.24.1.bb b/meta/recipes-kernel/sysprof/sysprof_3.24.1.bb
new file mode 100644
index 0000000000..ca3589bcc9
--- /dev/null
+++ b/meta/recipes-kernel/sysprof/sysprof_3.24.1.bb
@@ -0,0 +1,38 @@
1SUMMARY = "System-wide Performance Profiler for Linux"
2LICENSE = "GPLv3+"
3LIC_FILES_CHKSUM = "file://COPYING;md5=d32239bcb673463ab874e80d47fae504 \
4 file://src/sp-application.c;endline=17;md5=40e55577ef122c88fe20052acda64875"
5
6inherit gnomebase gettext systemd upstream-version-is-even
7
8DEPENDS = "glib-2.0 libxml2-native glib-2.0-native"
9
10SRC_URI += " \
11 file://define-NT_GNU_BUILD_ID.patch \
12 file://0001-configure-Add-option-to-enable-disable-polkit.patch \
13 file://0001-Disable-check-for-polkit-for-UI.patch \
14 file://0001-Avoid-building-docs.patch \
15 "
16SRC_URI[archive.md5sum] = "2b44ae1d8cd899417294a9c4509d7870"
17SRC_URI[archive.sha256sum] = "054eebe2afb6fe3c06ac8c46bc045c42f675d4fd64e6f16cbc602d5c7ce27bec"
18
19AUTOTOOLS_AUXDIR = "${S}/build-aux"
20
21EXTRA_OECONF = "--enable-compile-warnings"
22
23# This properly relocates msgfmt, which otherwise fails to find its data files.
24# Tips on how to get rid of hardcoded version welcome.
25export GETTEXTDATADIR = "${STAGING_DATADIR_NATIVE}/gettext-0.19.8/"
26
27PACKAGECONFIG ?= "${@bb.utils.contains_any('DISTRO_FEATURES', '${GTK3DISTROFEATURES}', 'gtk', '', d)}"
28PACKAGECONFIG[gtk] = "--enable-gtk,--disable-gtk,gtk+3"
29PACKAGECONFIG[polkit] = "--enable-polkit,--disable-polkit,polkit dbus"
30
31SOLIBS = ".so"
32FILES_SOLIBSDEV = ""
33FILES_${PN} += "${datadir}/icons/ ${datadir}/appdata"
34
35SYSTEMD_SERVICE_${PN} = "${@bb.utils.contains('PACKAGECONFIG', 'polkit', 'sysprof2.service', '', d)}"
36
37# We do not yet work for aarch64.
38COMPATIBLE_HOST = "^(?!aarch64).*"