diff options
Diffstat (limited to 'meta/recipes-kernel/powertop/powertop_2.8.bb')
-rw-r--r-- | meta/recipes-kernel/powertop/powertop_2.8.bb | 34 |
1 files changed, 34 insertions, 0 deletions
diff --git a/meta/recipes-kernel/powertop/powertop_2.8.bb b/meta/recipes-kernel/powertop/powertop_2.8.bb new file mode 100644 index 0000000000..a466067562 --- /dev/null +++ b/meta/recipes-kernel/powertop/powertop_2.8.bb | |||
@@ -0,0 +1,34 @@ | |||
1 | SUMMARY = "Power usage tool" | ||
2 | DESCRIPTION = "Linux tool to diagnose issues with power consumption and power management." | ||
3 | HOMEPAGE = "http://01.org/powertop/" | ||
4 | BUGTRACKER = "http://bugzilla.lesswatts.org/" | ||
5 | DEPENDS = "ncurses libnl pciutils" | ||
6 | LICENSE = "GPLv2" | ||
7 | LIC_FILES_CHKSUM = "file://COPYING;md5=12f884d2ae1ff87c09e5b7ccc2c4ca7e" | ||
8 | |||
9 | SRC_URI = "http://01.org/sites/default/files/downloads/powertop/powertop-${PV}.tar.gz" | ||
10 | |||
11 | SRC_URI[md5sum] = "c55fedb69203e480801b18bd7b886241" | ||
12 | SRC_URI[sha256sum] = "a87b563f73106babfa3e74dcf92f252938c061e309ace20a361358bbfa579c5a" | ||
13 | |||
14 | UPSTREAM_CHECK_URI = "https://01.org/powertop/downloads" | ||
15 | |||
16 | inherit autotools gettext pkgconfig | ||
17 | |||
18 | # we need to explicitly link with libintl in uClibc systems | ||
19 | EXTRA_LDFLAGS ?= "" | ||
20 | EXTRA_LDFLAGS_libc-uclibc = "-lintl" | ||
21 | LDFLAGS += "${EXTRA_LDFLAGS}" | ||
22 | |||
23 | # we do not want libncursesw if we can | ||
24 | do_configure_prepend() { | ||
25 | # configure.ac checks for delwin() in "ncursesw ncurses" so let's drop first one | ||
26 | sed -i -e "s/ncursesw//g" ${S}/configure.ac | ||
27 | mkdir -p ${B}/src/tuning/ | ||
28 | } | ||
29 | |||
30 | inherit update-alternatives | ||
31 | ALTERNATIVE_${PN} = "powertop" | ||
32 | ALTERNATIVE_TARGET[powertop] = "${sbindir}/powertop" | ||
33 | ALTERNATIVE_LINK_NAME[powertop] = "${sbindir}/powertop" | ||
34 | ALTERNATIVE_PRIORITY = "100" | ||