summaryrefslogtreecommitdiffstats
path: root/meta/recipes-kernel/powertop/powertop_2.7.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-kernel/powertop/powertop_2.7.bb')
-rw-r--r--meta/recipes-kernel/powertop/powertop_2.7.bb31
1 files changed, 31 insertions, 0 deletions
diff --git a/meta/recipes-kernel/powertop/powertop_2.7.bb b/meta/recipes-kernel/powertop/powertop_2.7.bb
new file mode 100644
index 0000000000..dce5d715fd
--- /dev/null
+++ b/meta/recipes-kernel/powertop/powertop_2.7.bb
@@ -0,0 +1,31 @@
1SUMMARY = "Power usage tool"
2DESCRIPTION = "Linux tool to diagnose issues with power consumption and power management."
3HOMEPAGE = "http://01.org/powertop/"
4BUGTRACKER = "http://bugzilla.lesswatts.org/"
5DEPENDS = "ncurses libnl pciutils"
6LICENSE = "GPLv2"
7LIC_FILES_CHKSUM = "file://COPYING;md5=12f884d2ae1ff87c09e5b7ccc2c4ca7e"
8
9SRC_URI = "http://01.org/sites/default/files/downloads/powertop/powertop-${PV}.tar.gz"
10
11SRC_URI[md5sum] = "e0d686e47daaf7e9d89031f7763432ef"
12SRC_URI[sha256sum] = "8d4b1490e2baad4467c0ded3c423db4472dcbf7b2dd8f8f2a928f54047c678ca"
13
14inherit autotools gettext pkgconfig
15
16# we need to explicitly link with libintl in uClibc systems
17LDFLAGS += "${EXTRA_LDFLAGS}"
18EXTRA_LDFLAGS_libc-uclibc = "-lintl"
19
20# we do not want libncursesw if we can
21do_configure_prepend() {
22 # configure.ac checks for delwin() in "ncursesw ncurses" so let's drop first one
23 sed -i -e "s/ncursesw//g" ${S}/configure.ac
24 mkdir -p ${B}/src/tuning/
25}
26
27inherit update-alternatives
28ALTERNATIVE_${PN} = "powertop"
29ALTERNATIVE_TARGET[powertop] = "${sbindir}/powertop"
30ALTERNATIVE_LINK_NAME[powertop] = "${sbindir}/powertop"
31ALTERNATIVE_PRIORITY = "100"